ramips: fix DTB generation
authorLuka Perkov <luka@openwrt.org>
Tue, 10 May 2016 22:37:29 +0000 (22:37 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 10 May 2016 22:37:29 +0000 (22:37 +0000)
using preprocessor style includes when calling dtc directly.

Signed-off-by: John Crispin <john@phrozen.org>
SVN-Revision: 49360

target/linux/ramips/image/Makefile

index 6e0349f02163bf1a2a9af6221e759d38e9ca39bc..52dde6780ec07c37a319290ab0157717cb2398da 100644 (file)
@@ -107,7 +107,7 @@ endef
 # $(3), optional filename suffix, e.g. "-initramfs"
 define PatchKernelLzmaDtb
        cp $(KDIR)/vmlinux$(3) $(KDIR)/vmlinux-$(1)$(3)
-       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(KDIR)/$(2).dtb ../dts/$(2).dts
+       $(call Image/BuildDTB,../dts/$(2).dts,$(KDIR)/$(2).dtb)
        $(STAGING_DIR_HOST)/bin/patch-dtb $(KDIR)/vmlinux-$(1)$(3) $(KDIR)/$(2).dtb
        $(call CompressLzma,$(KDIR)/vmlinux-$(1)$(3),$(KDIR)/vmlinux-$(1)$(3).bin.lzma)
 endef