kernel: remove double definition of depends in crypto-mv-cesa and make it look like...
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 2 Apr 2011 19:31:21 +0000 (19:31 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 2 Apr 2011 19:31:21 +0000 (19:31 +0000)
Thank you Maarten

SVN-Revision: 26413

package/kernel/modules/crypto.mk

index 685305066c2491368e8da28b0ddf23b386eae86b..467db8ee23aed3f78eafc8e61e648e7294b753a4 100644 (file)
@@ -427,13 +427,12 @@ endef
 $(eval $(call KernelPackage,crypto-xts))
 
 define KernelPackage/crypto-mv-cesa
-   TITLE:=Marvell crypto engine
-   DEPENDS:=+kmod-crypto-manager
-   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
-   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
-   SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core @TARGET_kirkwood||TARGET_orion
+  TITLE:=Marvell crypto engine
+  DEPENDS:=+kmod-crypto-manager @TARGET_kirkwood||TARGET_orion
+  KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+  FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
+  AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+  $(call AddDepends/crypto)
 endef
 
 $(eval $(call KernelPackage,crypto-mv-cesa))