ramips: add support for Belkin F5D8235 v2 board
authorGabor Juhos <juhosg@openwrt.org>
Wed, 24 Nov 2010 10:01:23 +0000 (10:01 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 24 Nov 2010 10:01:23 +0000 (10:01 +0000)
No support for usb for now.

Signed-off-by: Roman Yeryomin <roman@advem.lv>
SVN-Revision: 24126

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-f5d8235-v2.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.32
target/linux/ramips/rt305x/config-2.6.34

index 286323fe123e880e6f7190345e8d6df30069e0b2..d0aaa6b9c47a7666835468c19d6ee9ebde02217b 100644 (file)
@@ -21,6 +21,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_DIR_300_REVB,       /* D-Link DIR-300 rev B */
 
        /* RT3052 based machines */
+       RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
index f50328b109e083ac9e7f87fd51f47f60f43fabab..d4087aef4809ef777247f2433ede63da32259a6b 100644 (file)
@@ -2,6 +2,12 @@ if RALINK_RT305X
 
 menu "Ralink RT350x machine selection"
 
+config RT305X_MACH_F5D8235_V2
+       bool "Belkin F5D8235 v2 support"
+       default y
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_WHR_G300N
        bool "Buffalo WHR-G300N support"
        default y
index 75f65700bcf18efbb94cca88438ad7035aebb0f1..a18a03500f15488052f38eab415b79731b11812b 100644 (file)
@@ -11,6 +11,7 @@ obj-y := irq.o setup.o devices.o rt305x.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
+obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-f5d8235-v2.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-f5d8235-v2.c
new file mode 100644 (file)
index 0000000..6a40042
--- /dev/null
@@ -0,0 +1,141 @@
+/*
+ *  Belkin F5D8235 v2 board support
+ *
+ *  Copyright (C) 2010 Roman Yeryomin <roman@advem.lv>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <linux/rtl8366rb.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define F5D8235_V2_GPIO_LED_INTERNET_BLUE      5
+#define F5D8235_V2_GPIO_LED_INTERNET_AMBER     6
+#define F5D8235_V2_GPIO_LED_MODEM_BLUE         11
+#define F5D8235_V2_GPIO_LED_MODEM_AMBER                8
+#define F5D8235_V2_GPIO_LED_ROUTER             9
+#define F5D8235_V2_GPIO_LED_STORAGE_BLUE       23
+#define F5D8235_V2_GPIO_LED_STORAGE_AMBER      22
+#define F5D8235_V2_GPIO_LED_SECURITY_BLUE      13
+#define F5D8235_V2_GPIO_LED_SECURITY_AMBER     12
+
+static struct gpio_led f5d8235v2_leds_gpio[] __initdata = {
+        {
+                .name           = "f5d8235v2:blue:internet",
+                .gpio           = F5D8235_V2_GPIO_LED_INTERNET_BLUE,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:amber:internet",
+                .gpio           = F5D8235_V2_GPIO_LED_INTERNET_AMBER,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:blue:modem",
+                .gpio           = F5D8235_V2_GPIO_LED_MODEM_BLUE,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:amber:modem",
+                .gpio           = F5D8235_V2_GPIO_LED_MODEM_AMBER,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:blue:router",
+                .gpio           = F5D8235_V2_GPIO_LED_ROUTER,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:blue:storage",
+                .gpio           = F5D8235_V2_GPIO_LED_STORAGE_BLUE,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:amber:storage",
+                .gpio           = F5D8235_V2_GPIO_LED_STORAGE_AMBER,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:blue:security",
+                .gpio           = F5D8235_V2_GPIO_LED_SECURITY_BLUE,
+                .active_low     = 1,
+        }, {
+                .name           = "f5d8235v2:amber:security",
+                .gpio           = F5D8235_V2_GPIO_LED_SECURITY_AMBER,
+                .active_low     = 1,
+        }
+};
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition f5d8235v2_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x050000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel and rootfs",
+               .offset = 0x050000,
+               .size   = 0x790000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x1D0000,
+               .size   = 0x610000,
+       }, {
+               .name   = "nvram",
+               .offset = 0x7E0000,
+               .size   = 0x010000,
+       }, {
+               .name   = "factory",
+               .offset = 0x7F0000,
+               .size   = 0x010000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data f5d8235v2_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(f5d8235v2_partitions),
+       .parts          = f5d8235v2_partitions,
+#endif
+};
+
+
+static struct rtl8366rb_platform_data f5d8235v2_switch_data = {
+       .gpio_sda        = RT305X_GPIO_I2C_SD,
+       .gpio_sck        = RT305X_GPIO_I2C_SCLK,
+};
+
+static struct platform_device f5d8235v2_switch = {
+        .name           = RTL8366RB_DRIVER_NAME,
+       .id             = -1,
+        .dev           = {
+           .platform_data = &f5d8235v2_switch_data,
+        }
+};
+
+static void __init f5d8235v2_init(void)
+{
+       rt305x_gpio_init((RT305X_GPIO_MODE_GPIO <<
+                                       RT305X_GPIO_MODE_UART0_SHIFT) |
+                                       RT305X_GPIO_MODE_I2C |
+                                       RT305X_GPIO_MODE_SPI |
+                                       RT305X_GPIO_MODE_MDIO);
+       rt305x_register_flash(0, &f5d8235v2_flash_data);
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(f5d8235v2_leds_gpio),
+                                               f5d8235v2_leds_gpio);
+       rt305x_register_ethernet();
+       platform_device_register(&f5d8235v2_switch);
+       rt305x_register_wifi();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_F5D8235_V2, "F5D8235_V2", "Belkin F5D8235 v2",
+            f5d8235v2_init);
index acd328317cfe891cba1718136a5e764d2c9f6f95..79809de9fd1d1acbc867c211e7d450836e36cf78 100644 (file)
@@ -113,6 +113,18 @@ define Image/Build/Profile/WCR150GN
 endef
 
 
+mtdlayout_f5d8235=mtdparts=physmap-flash.0:320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
+mtd_f5d8235_kernel_part_size=1572864
+mtd_f5d8235_rootfs_part_size=6356992
+define Image/Build/Template/F5D8235V2
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
+
+define Image/Build/Profile/F5D8235V2
+       $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
+endef
+
+
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR300B1,$(1))
@@ -121,6 +133,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
+       $(call Image/Build/Profile/F5D8235V2,$(1))
 endef
 endif
 
index 1d29c914f7edbc3b652d5ded1004bac10de76fd5..05388b296d2bb60172b650dd2bdf528858d421b9 100644 (file)
@@ -117,6 +117,7 @@ CONFIG_RALINK_DEV_GPIO_LEDS=y
 # CONFIG_RALINK_RT288X is not set
 CONFIG_RALINK_RT305X=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
+CONFIG_RT305X_MACH_F5D8235_V2=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_PWH2004=y
index 91b7e56426e2d176a4e74e2d9b6cf1a47c1f62da..b677856b6b09b8913e129fc664c09f44989b1b51 100644 (file)
@@ -127,6 +127,7 @@ CONFIG_RALINK_DEV_GPIO_LEDS=y
 # CONFIG_RALINK_RT288X is not set
 CONFIG_RALINK_RT305X=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
+CONFIG_RT305X_MACH_F5D8235_V2=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_PWH2004=y