[package] add mtd-utils version 20090227, thanks Miguel (#4555)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 10 Mar 2009 09:48:57 +0000 (09:48 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 10 Mar 2009 09:48:57 +0000 (09:48 +0000)
SVN-Revision: 14834

utils/mtd-utils/Makefile [new file with mode: 0644]

diff --git a/utils/mtd-utils/Makefile b/utils/mtd-utils/Makefile
new file mode 100644 (file)
index 0000000..a0d4e42
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtd-utils
+PKG_VERSION:=20090227
+PKG_RELEASE:=1
+PKG_INSTALL:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=a2d010f8fca904fffa3c6e5a5d148cc96a37a08a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mtd-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Utilities for flash info/debug
+  URL:=http://www.linux-mtd.infradead.org/
+  DEPENDS:=+zlib +liblzo +libuuid
+endef
+
+define Package/mtd-utils/description
+  Utilities for manipulating memory technology devices.
+endef
+
+MAKE_FLAGS += \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       BUILDDIR="$(PKG_BUILD_DIR)" \
+       WITHOUT_XATTR=1
+
+define Package/mtd-utils/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,mtd-utils))