[kernel] refresh 2.6.32 patches
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 May 2010 18:13:49 +0000 (18:13 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 May 2010 18:13:49 +0000 (18:13 +0000)
SVN-Revision: 21411

19 files changed:
target/linux/generic-2.6/patches-2.6.32/014-samsung_flash
target/linux/generic-2.6/patches-2.6.32/020-mips_multi_machine_support.patch
target/linux/generic-2.6/patches-2.6.32/088-winbond_cmdset.patch
target/linux/generic-2.6/patches-2.6.32/089-mtd-samsung-flash.patch
target/linux/generic-2.6/patches-2.6.32/100-netfilter_layer7_2.21.patch
target/linux/generic-2.6/patches-2.6.32/110-netfilter_match_speedup.patch
target/linux/generic-2.6/patches-2.6.32/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.32/202-mips_mem_functions_performance.patch
target/linux/generic-2.6/patches-2.6.32/203-slab_maxsize.patch
target/linux/generic-2.6/patches-2.6.32/210-mini_fo_2.6.25_fixes.patch
target/linux/generic-2.6/patches-2.6.32/212-mini_fo_2.6.26_fixes.patch
target/linux/generic-2.6/patches-2.6.32/400-ledtrig_morse.patch
target/linux/generic-2.6/patches-2.6.32/402-ledtrig_netdev.patch
target/linux/generic-2.6/patches-2.6.32/511-yaffs-cvs-2009-04-24.patch
target/linux/generic-2.6/patches-2.6.32/903-hostap_txpower.patch
target/linux/generic-2.6/patches-2.6.32/924-cs5535_gpio.patch
target/linux/generic-2.6/patches-2.6.32/971-ocf_20100325.patch
target/linux/generic-2.6/patches-2.6.32/975-ssb_update.patch
target/linux/generic-2.6/patches-2.6.32/998-openwrt_lzma_options.patch

index 1faeb41eaa6e2293fa9189f81fa444f807008136..e2a456915c5c764bf9b23f192bc74cd194560c09 100644 (file)
@@ -8,7 +8,7 @@
  
  static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
  static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -375,12 +376,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
+@@ -375,12 +376,19 @@ struct mtd_info *cfi_cmdset_0002(struct
  
                if (extp->MajorVersion != '1' ||
                    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
index dd9bb57c3d0a3766e6f72e8848a6d2195e7e40da..5b99b3fd13e121af5d10f2b36c82414a48de3389 100644 (file)
  
  unsigned int vced_count, vcei_count;
  
-@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file 
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
        /*
         * For the first processor also print the system type
         */
index d4e42b0aa2ddffa1bb71ffa47ca28bc63e1d28a0..d5889ce62d526d71eb9dae2a62215617c7958c6a 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.32.12/drivers/mtd/chips/gen_probe.c
-===================================================================
---- linux-2.6.32.12.orig/drivers/mtd/chips/gen_probe.c 2010-05-03 10:48:00.000000000 +0200
-+++ linux-2.6.32.12/drivers/mtd/chips/gen_probe.c      2010-05-03 10:48:16.000000000 +0200
-@@ -249,6 +249,7 @@
+--- a/drivers/mtd/chips/gen_probe.c
++++ b/drivers/mtd/chips/gen_probe.c
+@@ -249,6 +249,7 @@ static struct mtd_info *check_cmd_set(st
  #endif
  #ifdef CONFIG_MTD_CFI_AMDSTD
        case 0x0002:
index eab03db50d0b8cd052b7a4778dfcac90fa60b601..4d1072cd4c4a97c469e1a27f9a352d5f74f1bbb8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct 
+@@ -374,7 +374,7 @@ struct mtd_info *cfi_cmdset_0002(struct
  
                cfi_fixup_major_minor(cfi, extp);
  
index be7d97fe1203646d5082b42bd10ec9394d19b6a0..de9c63c357abafaea08a9faaf4e825c76314a722 100644 (file)
@@ -71,7 +71,7 @@
        depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -89,6 +89,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT) 
+@@ -89,6 +89,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT)
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
index a9eb1089f5f206af1793b3897c123bf26bb1b00f..04ba7102740d210b3d01355792204da9e867f9e3 100644 (file)
  
                e = (struct ipt_entry *)(loc_cpu_entry + off);
                if (copy_to_user(userptr + off
-@@ -1002,6 +1042,14 @@ copy_entries_to_user(unsigned int total_
+@@ -1001,6 +1041,14 @@ copy_entries_to_user(unsigned int total_
+                       ret = -EFAULT;
                        goto free_counters;
                }
++
 +              flags = e->ip.flags & ~IPT_F_NO_DEF_MATCH;
 +              if (copy_to_user(userptr + off
 +                               + offsetof(struct ipt_entry, ip.flags),
 +                      ret = -EFAULT;
 +                      goto free_counters;
 +              }
-+
                for (i = sizeof(struct ipt_entry);
                     i < e->target_offset;
-                    i += m->u.match_size) {
index 9540ce0dde630abc2ef22ba15ad391e3fee2965a..f6e70d59da976cbcc3943ddf47fe2374c78a4e56 100644 (file)
                        dev_queue_xmit_nit(skb, dev);
  
                if (netif_needs_gso(dev, skb)) {
-@@ -1789,8 +1796,7 @@ u16 skb_tx_hash(const struct net_device 
+@@ -1789,8 +1796,7 @@ u16 skb_tx_hash(const struct net_device
  }
  EXPORT_SYMBOL(skb_tx_hash);
  
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
-@@ -80,7 +100,7 @@ void nf_unregister_queue_handlers(const 
+@@ -80,7 +100,7 @@ void nf_unregister_queue_handlers(const
  }
  EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
  
index 6ea9ba51ee0d24cf3a3ac657278109d9b11de859..e4324717b4459ce1f1009053e6317c930b01b6e4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/include/asm/string.h
 +++ b/arch/mips/include/asm/string.h
-@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__ 
+@@ -133,11 +133,44 @@ strncmp(__const__ char *__cs, __const__
  
  #define __HAVE_ARCH_MEMSET
  extern void *memset(void *__s, int __c, size_t __count);
index 0c1ae72a4ebe435e684bcd198039d89090e0cd13..5bbf9f5f0ef1986190db569ca4bdb55d35ab55cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/slab.h
 +++ b/include/linux/slab.h
-@@ -124,8 +124,8 @@ int kmem_ptr_validate(struct kmem_cache 
+@@ -124,8 +124,8 @@ int kmem_ptr_validate(struct kmem_cache
   * to do various tricks to work around compiler limitations in order to
   * ensure proper constant folding.
   */
index d71e3b6faa6644c2337588f4b344cc5677419841..b64630d50045480d022ba26c901cea68f6da66b3 100644 (file)
@@ -61,7 +61,7 @@
  #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
  extern int mini_fo_create(inode_t *dir, dentry_t *dentry, int mode, struct nameidata *nd);
  
-@@ -501,6 +505,29 @@ static inline void double_unlock(struct 
+@@ -501,6 +505,29 @@ static inline void double_unlock(struct
  #endif  /* if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0) */
  #endif /* __KERNEL__ */
  
  #endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
 --- a/fs/mini_fo/aux.c
 +++ b/fs/mini_fo/aux.c
-@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb, 
+@@ -164,11 +164,11 @@ dentry_t *bpath_walk(super_block_t *sb,
        err = vfs_path_lookup(mnt->mnt_root, mnt, bpath+1, 0, &nd);
  
        /* validate */
index 8bd9ba32447e15df6ebc7153edfe89dfd38f43f6..b5fa64e6a19e7fff343aed59f4ddccfc34578d91 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/mini_fo/super.c
 +++ b/fs/mini_fo/super.c
-@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int 
+@@ -84,6 +84,7 @@ mini_fo_write_inode(inode_t *inode, int
  #endif /* defined(FIST_DEBUG) || defined(FIST_FILTER_SCA) */
  
  
index 1892eb5bd9c8fad928a805757f5d364e8fe79ef9..4edb071adea2d27bd51306575d92b2f6df090254 100644 (file)
@@ -11,7 +11,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -40,3 +40,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += 
+@@ -40,3 +40,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
  obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)  += ledtrig-backlight.o
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index d6f7353dc1cc8dae714f69448d2980e42dff3c4d..4565740ca5bf7bccfa05dd07224c18688a3619c7 100644 (file)
@@ -14,7 +14,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -41,3 +41,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += 
+@@ -41,3 +41,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
index 5c70e79a058d050e90224ac0ef80dcb1180235ab..c334b17d0872a877f52cd9c0e4234ad118df7d09 100644 (file)
                        dev->checkpointBlockList[i] = -1;
        }
  
-@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device 
+@@ -191,18 +185,17 @@ int yaffs_GetCheckpointSum(yaffs_Device
  
  static int yaffs_CheckpointFlushBuffer(yaffs_Device *dev)
  {
  {
        unsigned char cDelta;   /* column parity delta */
        unsigned lDelta;        /* line parity delta */
-@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -294,8 +292,7 @@ int yaffs_ECCCorrectOther(unsigned char
                return 0; /* no error */
  
        if (lDelta == ~lDeltaPrime &&
                /* Single bit (recoverable) error in data */
  
                bit = 0;
-@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -307,7 +304,7 @@ int yaffs_ECCCorrectOther(unsigned char
                if (cDelta & 0x02)
                        bit |= 0x01;
  
                        return -1;
  
                data[lDelta] ^= (1 << bit);
-@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -316,7 +313,7 @@ int yaffs_ECCCorrectOther(unsigned char
        }
  
        if ((yaffs_CountBits32(lDelta) + yaffs_CountBits32(lDeltaPrime) +
                /* Reccoverable error in ecc */
  
                *read_ecc = *test_ecc;
-@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char 
+@@ -326,6 +323,4 @@ int yaffs_ECCCorrectOther(unsigned char
        /* Unrecoverable error */
  
        return -1;
  {
        unsigned char *alias;
        int ret;
-@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry 
+@@ -329,7 +395,7 @@ static int yaffs_readlink(struct dentry
        return ret;
  }
  
  static int yaffs_file_flush(struct file *file, fl_owner_t id)
  #else
  static int yaffs_file_flush(struct file *file)
-@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file 
+@@ -513,8 +579,8 @@ static int yaffs_file_flush(struct file
        yaffs_Device *dev = obj->myDev;
  
        T(YAFFS_TRACE_OS,
  
        yaffs_GrossLock(dev);
  
-@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct 
+@@ -535,15 +601,15 @@ static int yaffs_readpage_nolock(struct
  
        yaffs_Device *dev;
  
        BUG_ON(!PageLocked(pg));
  #else
        if (!PageLocked(pg))
-@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct 
+@@ -555,9 +621,9 @@ static int yaffs_readpage_nolock(struct
  
        yaffs_GrossLock(dev);
  
  
        yaffs_GrossUnlock(dev);
  
-@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct 
+@@ -575,7 +641,7 @@ static int yaffs_readpage_nolock(struct
        flush_dcache_page(pg);
        kunmap(pg);
  
                if (n < step) {
                        n++;
                        continue;
-@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file 
+@@ -2119,7 +2356,7 @@ static int yaffs_proc_write(struct file
        char *end;
        char *mask_name;
        const char *x;
        int i;
        int done = 0;
        int add, len = 0;
-@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file 
+@@ -2129,9 +2366,8 @@ static int yaffs_proc_write(struct file
  
        while (!done && (pos < count)) {
                done = 1;
  
                switch (buf[pos]) {
                case '+':
-@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file 
+@@ -2148,20 +2384,21 @@ static int yaffs_proc_write(struct file
                mask_name = NULL;
  
                mask_bitfield = simple_strtoul(buf + pos, &end, 0);
                                        mask_name = mask_flags[i].mask_name;
                                        mask_bitfield = mask_flags[i].mask_bitfield;
                                        done = 0;
-@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file 
+@@ -2172,7 +2409,7 @@ static int yaffs_proc_write(struct file
  
                if (mask_name != NULL) {
                        done = 0;
                        case '-':
                                rg &= ~mask_bitfield;
                                break;
-@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file 
+@@ -2191,13 +2428,13 @@ static int yaffs_proc_write(struct file
  
        yaffs_traceMask = rg | YAFFS_TRACE_ALWAYS;
  
  {
        /* Get the real object in case we were fed a hard link as an equivalent object */
        equivalentObject = yaffs_GetEquivalentObject(equivalentObject);
-@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object * 
+@@ -2363,33 +2396,31 @@ yaffs_Object *yaffs_Link(yaffs_Object *
  
  }
  
        int nToCopy;
        int n = nBytes;
        int nDone = 0;
-@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4600,27 +4665,26 @@ int yaffs_ReadDataFromFile(yaffs_Object
        dev = in->myDev;
  
        while (n > 0) {
                        if (dev->nShortOpCaches > 0) {
  
                                /* If we can't find the data in the cache, then load it up. */
-@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4641,14 +4705,9 @@ int yaffs_ReadDataFromFile(yaffs_Object
  
                                cache->locked = 1;
  
                                cache->locked = 0;
                        } else {
                                /* Read into the local buffer then copy..*/
-@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4657,41 +4716,19 @@ int yaffs_ReadDataFromFile(yaffs_Object
                                    yaffs_GetTempBuffer(dev, __LINE__);
                                yaffs_ReadChunkDataFromObject(in, chunk,
                                                              localBuffer);
                }
  
                n -= nToCopy;
-@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object 
+@@ -4704,28 +4741,37 @@ int yaffs_ReadDataFromFile(yaffs_Object
        return nDone;
  }
  
        int newFullChunks;
  
        yaffs_Device *dev = in->myDev;
-@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in, 
+@@ -4955,13 +4981,11 @@ int yaffs_ResizeFile(yaffs_Object * in,
  
        yaffs_CheckGarbageCollection(dev);
  
  
        if (newSize < oldFileSize) {
  
-@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in, 
+@@ -4994,21 +5018,20 @@ int yaffs_ResizeFile(yaffs_Object * in,
        }
  
  
  {
        obj = yaffs_GetEquivalentObject(obj);
  
-@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object * 
+@@ -5024,7 +5047,7 @@ loff_t yaffs_GetFileSize(yaffs_Object *
  
  
  
  {
        int init_failed = 0;
        unsigned x;
-@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7040,6 +7126,8 @@ int yaffs_GutsInitialise(yaffs_Device *
        dev->chunkOffset = 0;
        dev->nFreeChunks = 0;
  
        if (dev->startBlock == 0) {
                dev->internalStartBlock = dev->startBlock + 1;
                dev->internalEndBlock = dev->endBlock + 1;
-@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7049,18 +7137,18 @@ int yaffs_GutsInitialise(yaffs_Device *
  
        /* Check geometry parameters. */
  
                return YAFFS_FAIL;
        }
  
-@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7070,6 +7158,12 @@ int yaffs_GutsInitialise(yaffs_Device *
                return YAFFS_FAIL;
        }
  
        /* Got the right mix of functions? */
        if (!yaffs_CheckDevFunctions(dev)) {
                /* Function missing */
-@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7097,31 +7191,18 @@ int yaffs_GutsInitialise(yaffs_Device *
  
        dev->isMounted = 1;
  
  
        /*
         * Calculate chunkGroupBits.
-@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7133,16 +7214,15 @@ int yaffs_GutsInitialise(yaffs_Device *
        bits = ShiftsGE(x);
  
        /* Set up tnode width if wide tnodes are enabled. */
                dev->tnodeWidth = 16;
  
        dev->tnodeMask = (1<<dev->tnodeWidth)-1;
-@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7193,7 +7273,7 @@ int yaffs_GutsInitialise(yaffs_Device *
        dev->hasPendingPrioritisedGCs = 1; /* Assume the worst for now, will get fixed on first GC */
  
        /* Initialise temporary buffers and caches. */
                init_failed = 1;
  
        dev->srCache = NULL;
-@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7203,25 +7283,26 @@ int yaffs_GutsInitialise(yaffs_Device *
        if (!init_failed &&
            dev->nShortOpCaches > 0) {
                int i;
                        init_failed = 1;
  
                dev->srLastUse = 0;
-@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7229,29 +7310,30 @@ int yaffs_GutsInitialise(yaffs_Device *
  
        dev->cacheHits = 0;
  
                                T(YAFFS_TRACE_ALWAYS,
                                  (TSTR("yaffs: restored from checkpoint" TENDSTR)));
                        } else {
-@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7273,24 +7355,25 @@ int yaffs_GutsInitialise(yaffs_Device *
                                dev->nBackgroundDeletions = 0;
                                dev->oldestDirtySequence = 0;
  
                /* Clean up the mess */
                T(YAFFS_TRACE_TRACING,
                  (TSTR("yaffs: yaffs_GutsInitialise() aborted.\n" TENDSTR)));
-@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device * 
+@@ -7318,7 +7401,7 @@ int yaffs_GutsInitialise(yaffs_Device *
  
  }
  
  {
        if (etags) {
                memset(etags, 0, sizeof(*etags));
-@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags * 
+@@ -169,9 +169,9 @@ static int rettags(yaffs_ExtendedTags *
   * Returns YAFFS_OK or YAFFS_FAIL.
   */
  int nandmtd1_ReadChunkWithTagsFromNAND(yaffs_Device *dev,
 +                      yaffs_UnpackTags2(tags, &pt);
 +              }
 +      }
--      if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
--              tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
++
 +      if (localData)
 +              yaffs_ReleaseTempBuffer(dev, data, __LINE__);
  
+-      if(tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
 +      if (tags && retval == -EBADMSG && tags->eccResult == YAFFS_ECC_RESULT_NO_ERROR)
-+              tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+               tags->eccResult = YAFFS_ECC_RESULT_UNFIXED;
+-
        if (retval == 0)
                return YAFFS_OK;
        else
index 7552ceb33dd00fc0be9381b325389e3a6b0a16bc..22a65924da155e63575004a51a036e81f6a23a60 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/hostap/hostap_ap.c
 +++ b/drivers/net/wireless/hostap/hostap_ap.c
-@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t 
+@@ -2335,13 +2335,13 @@ int prism2_ap_get_sta_qual(local_info_t
                addr[count].sa_family = ARPHRD_ETHER;
                memcpy(addr[count].sa_data, sta->addr, ETH_ALEN);
                if (sta->last_rx_silence == 0)
index 453affe583354eb32f822efe76a0f028f4e0675e..a36ea49933bf9622a24da88f6d0f383b3a16a7e8 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/ioport.h>
  #include <linux/pci.h>
  #include <linux/smp_lock.h>
-@@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[] 
+@@ -48,6 +49,7 @@ static struct pci_device_id divil_pci[]
  MODULE_DEVICE_TABLE(pci, divil_pci);
  
  static struct cdev cs5535_gpio_cdev;
index 0b0c1e279c79dc86dbda83d48e7fcb2aabd503c9..8eff02fa6c951cd3f622110ec8fad5ec4ea13696 100644 (file)
@@ -24,7 +24,7 @@
   * All of these routines try to estimate how many bits of randomness a
   * particular randomness source.  They do this by keeping track of the
   * first and second order deltas of the event timings.
-@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk 
+@@ -714,6 +724,61 @@ void add_disk_randomness(struct gendisk
  }
  #endif
  
index f48c58052fecb2db91a0acc2e0513860f544480e..5931d29e8bafa4cceec0da7cffbdb7940419d44a 100644 (file)
  /* Helper to extract some _offset, which is one of the SSB_SPROM_XXX defines. */
  #define SPEX16(_outvar, _offset, _mask, _shift)       \
        out->_outvar = ((in[SPOFF(_offset)] & (_mask)) >> (_shift))
-@@ -253,7 +254,7 @@ static int sprom_do_read(struct ssb_bus 
+@@ -253,7 +254,7 @@ static int sprom_do_read(struct ssb_bus
        int i;
  
        for (i = 0; i < bus->sprom_size; i++)
 +static int ssb_pcmcia_get_mac(struct pcmcia_device *p_dev,
 +                      tuple_t *tuple,
 +                      void *priv)
-+{
+ {
+-      tuple_t tuple;
+-      int res;
+-      unsigned char buf[32];
 +      struct ssb_sprom *sprom = priv;
 +
 +      if (tuple->TupleData[0] != CISTPL_FUNCE_LAN_NODE_ID)
 +static int ssb_pcmcia_do_get_invariants(struct pcmcia_device *p_dev,
 +                                      tuple_t *tuple,
 +                                      void *priv)
- {
--      tuple_t tuple;
--      int res;
--      unsigned char buf[32];
++{
 +      struct ssb_init_invariants *iv = priv;
        struct ssb_sprom *sprom = &iv->sprom;
        struct ssb_boardinfo *bi = &iv->boardinfo;
index face9154d8da77d1abdb032bf5acee19b4bf0961..f81e22f116ddf86a0bce29587eb6ba454de397fc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/Makefile.lib
 +++ b/scripts/Makefile.lib
-@@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^) 
+@@ -228,7 +228,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
  
  quiet_cmd_lzma = LZMA    $@
  cmd_lzma = (cat $(filter-out FORCE,$^) | \