kernel: add mii library kernel module package
authorFlorian Fainelli <florian@openwrt.org>
Fri, 25 Oct 2013 01:47:32 +0000 (01:47 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 25 Oct 2013 01:47:32 +0000 (01:47 +0000)
This package is required for network drivers such as pcnet32

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 38530

package/kernel/linux/modules/netdevices.mk

index 9c808e1ba5e268d3aca5582e13846d68a9703a43..6cac27a02971721c5e165655cf10f1c3123e7c2b 100644 (file)
@@ -95,6 +95,20 @@ endef
 
 $(eval $(call KernelPackage,libphy))
 
+define KernelPackage/mii
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=MII library
+  KCONFIG:=CONFIG_MII
+  FILES:=$(LINUX_DIR)/drivers/net/mii.ko
+  AUTOLOAD:=$(call AutoLoad,15,mii,1)
+endef
+
+define KernelPackage/mii/description
+  MII library
+endef
+
+$(eval $(call KernelPackage,mii))
+
 
 define KernelPackage/et131x
   SUBMENU:=$(NETWORK_DEVICES_MENU)