shell-fm requires automake
authorFelix Fietkau <nbd@openwrt.org>
Wed, 17 Jan 2007 20:42:21 +0000 (20:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 17 Jan 2007 20:42:21 +0000 (20:42 +0000)
SVN-Revision: 6120

sound/shell-fm/Makefile

index 7c0b3de8c972580aa431dc636edc48724786e532..ecfe8271a5fa5161d0a03a48919d444a1aa943dc 100644 (file)
@@ -50,10 +50,16 @@ endef
 
 define Package/shell-fm/install        
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
        $(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/shell-fm.init $(1)/etc/init.d/shell-fm
 endef
 
 $(eval $(call BuildPackage,shell-fm))
+
+
+$(eval $(call RequireCommand,aclocal, \
+       shell-fm requires automake \
+))
+