kernel: gsc depends on kmod-i2c-core
authorLuka Perkov <luka@openwrt.org>
Thu, 12 Sep 2013 23:38:54 +0000 (23:38 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 12 Sep 2013 23:38:54 +0000 (23:38 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 37960

package/kernel/linux/modules/hwmon.mk

index b1f4744330ba2458ce695f82ac4a748d06c664e9..54e9b180b3887339506c9c5ec763ef30274110c5 100644 (file)
@@ -211,7 +211,7 @@ define KernelPackage/hwmon-w83627hf
   KCONFIG:=CONFIG_SENSORS_W83627HF
   FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,w83627hf)
   KCONFIG:=CONFIG_SENSORS_W83627HF
   FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,w83627hf)
-$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
+  $(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
 endef
 
 define KernelPacakge/hwmon-w83627hf/description
 endef
 
 define KernelPacakge/hwmon-w83627hf/description
@@ -225,8 +225,8 @@ define KernelPackage/hwmon-gsc
   TITLE:=Gateworks GSC monitoring support
   KCONFIG:=CONFIG_SENSORS_GSC
   FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
   TITLE:=Gateworks GSC monitoring support
   KCONFIG:=CONFIG_SENSORS_GSC
   FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
-  AUTOLOAD:=$(call AutoLoad,50,gsc)
-$(call AddDepends/hwmon)
+  AUTOLOAD:=$(call AutoLoad,60,gsc)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPacakge/hwmon-gsc/description
 endef
 
 define KernelPacakge/hwmon-gsc/description