Typo on PCI ids
authorFlorian Fainelli <florian@openwrt.org>
Mon, 15 Oct 2007 17:04:34 +0000 (17:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 15 Oct 2007 17:04:34 +0000 (17:04 +0000)
SVN-Revision: 9328

target/linux/rdc/files/drivers/net/r6040.c
target/linux/rdc/patches/004-rdc_fixes.patch

index e2044c9ad9a07dc3660d7c3d07d3ea558d30d205..6678f01a103e86376d11fcef85f46720a10e3e7b 100644 (file)
@@ -1002,8 +1002,7 @@ enum {
 };
 
 static struct pci_device_id r6040_pci_tbl[] = {
-       {0x17F3, 0x6040, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RDC_6040},
-       /* {PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_R6040, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RDC_6040},*/
+       {PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_RDC_R6040, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RDC_6040},
        /*{0x1106, 0x3065, PCI_ANY_ID, PCI_ANY_ID, 0, 0, RDC_6040},*/
        {0,}
 };
index e67678a8e826223f0ac22563ae36807cc724b3e5..7b87773cf14b004adaa9e50d5ff16e77e288c9dd 100644 (file)
@@ -67,7 +67,7 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
  };
  
  static struct device_fixup fixups_table[] = {
-+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_R6030, r8610_reset },
++{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_RDC_R6030, r8610_reset },
  { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
  { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
  };