Merge r16378 to 8.09
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 8 Jun 2009 12:00:59 +0000 (12:00 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 8 Jun 2009 12:00:59 +0000 (12:00 +0000)
SVN-Revision: 16379

package/nvram-brcm47xx/Makefile
package/nvram-brcm47xx/src/nvram.c

index d5954e8eef866a55971c7db1f1c8c742cc8249ed..ce7c86203d957b8572c833c8bfc3ddfc8bb6b7c4 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nvram-brcm47xx
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 78baa9431d3ae569fdd56b2523ba1f319a5d235c..ed3da4312b37ce6f01a7a1b7de73256a6d279d58 100644 (file)
@@ -411,8 +411,18 @@ char * nvram_find_mtd(void)
        char dev[PATH_MAX];
        char *path = NULL;
        struct stat s;
+       int supported = 1;
 
-       if( (fp = fopen("/proc/mtd", "r")) )
+       /* Refuse any operation on the WGT634U */
+       if( (fp = fopen("/proc/diag/model", "r")) )
+       {
+               if( fgets(dev, sizeof(dev), fp) && !strncmp(dev, "Netgear WGT634U", 15) )
+                       supported = 0;
+
+               fclose(fp);
+       }
+
+       if( supported && (fp = fopen("/proc/mtd", "r")) )
        {
                while( fgets(dev, sizeof(dev), fp) )
                {