ramips: add kernel support for the Upvel UR-326N4G board
authorGabor Juhos <juhosg@openwrt.org>
Mon, 11 Mar 2013 21:02:40 +0000 (21:02 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 11 Mar 2013 21:02:40 +0000 (21:02 +0000)
[juhosg: add missing symbols to config-3.{7,8}]

Patch from: Дмитрий Лебедев <lebedev@trendnet.ru>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35970

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-ur-326n4g.c [new file with mode: 0644]
target/linux/ramips/rt305x/config-3.7
target/linux/ramips/rt305x/config-3.8

index b3903fc2266d54a04edc89d06a948b904f6f65d3..200f737f719ae416cbb7b292e85ead6713a923d9 100644 (file)
@@ -67,6 +67,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_WR6202,             /* Accton WR6202 */
        RAMIPS_MACH_MZKW300NH2,         /* Planex MZK-W300NH2 Router */
        RAMIPS_MACH_XDXRN502J,          /* unknown XDX-RN502J */
+       RAMIPS_MACH_UR_326N4G,          /* UPVEL ROUTER */
        RAMIPS_MACH_UR_336UN,           /* UPVEL ROUTER */
 
        /* RT3352 based machines */
index c4653f5309239d449e739bd662296527be1f7e55..700a98338832dbe0b94dbce86709178481f74067 100644 (file)
@@ -134,6 +134,11 @@ config RT305X_MACH_WR512_3GN
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_UR_326N4G
+       bool "UR-326N4G Wireless N router"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_UR_336UN
        bool "UR-336UN Wireless N router"
        select RALINK_DEV_GPIO_BUTTONS
index 4e9f2f752c19f2390e467b62d2d2b1b0ab5c42db..47e9ce52ba38345334cb5bed75bc37019380e4eb 100644 (file)
@@ -45,6 +45,7 @@ obj-$(CONFIG_RT305X_MACH_W502U)               += mach-w502u.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
 obj-$(CONFIG_RT305X_MACH_WR512_3GN)    += mach-wr512-3gn.o
+obj-$(CONFIG_RT305X_MACH_UR_326N4G)    += mach-ur-326n4g.o
 obj-$(CONFIG_RT305X_MACH_UR_336UN)     += mach-ur-336un.o
 obj-$(CONFIG_RT305X_MACH_WL_330N)      += mach-wl-330n.o
 obj-$(CONFIG_RT305X_MACH_WL_330N3G)    += mach-wl-330n3g.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-ur-326n4g.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-ur-326n4g.c
new file mode 100644 (file)
index 0000000..a529694
--- /dev/null
@@ -0,0 +1,102 @@
+/*
+ *  UR-326N4G board support
+ *
+ *  Copyright (C) 2013 Dmitry Lebedev <Lebedev@upvel.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+
+#define UR_326N4G_GPIO_LED_3G          9
+#define UR_326N4G_GPIO_LED_GATEWAY     11
+#define UR_326N4G_GPIO_LED_AP          12
+#define UR_326N4G_GPIO_LED_STATION     13
+#define UR_326N4G_GPIO_LED_WPS         14
+
+#define UR_326N4G_GPIO_BUTTON_RESET    10
+#define UR_326N4G_GPIO_BUTTON_CONNECT  7
+#define UR_326N4G_GPIO_BUTTON_WPS      0
+#define UR_326N4G_GPIO_BUTTON_WPS2     8
+
+#define UR_326N4G_KEYS_POLL_INTERVAL   20
+#define UR_326N4G_KEYS_DEBOUNCE_INTERVAL (3 * UR_326N4G_KEYS_POLL_INTERVAL)
+
+static struct gpio_led UR_326N4G_leds_gpio[] __initdata = {
+       {
+               .name           = "ur326:green:3g",
+               .gpio           = UR_326N4G_GPIO_LED_3G,
+               .active_low     = 1,
+       }, {
+               .name           = "ur326:green:gateway",
+               .gpio           = UR_326N4G_GPIO_LED_GATEWAY,
+               .active_low     = 1,
+       }, {
+               .name           = "ur326:green:ap",
+               .gpio           = UR_326N4G_GPIO_LED_AP,
+               .active_low     = 1,
+       }, {
+               .name           = "ur326:green:wps",
+               .gpio           = UR_326N4G_GPIO_LED_WPS,
+               .active_low     = 1,
+       }, {
+               .name           = "ur326:green:station",
+               .gpio           = UR_326N4G_GPIO_LED_STATION,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button UR_326N4G_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset_wps",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = UR_326N4G_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = UR_326N4G_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "mode",
+               .type           = EV_KEY,
+               .code           = KEY_M,
+               .debounce_interval = UR_326N4G_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = UR_326N4G_GPIO_BUTTON_CONNECT,
+               .active_low     = 1,
+       }
+};
+
+#define UR_326N4G_GPIO_MODE \
+       ((RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT) | \
+        RT305X_GPIO_MODE_MDIO)
+
+static void __init UR_326N4G_init(void)
+{
+       rt305x_gpio_init(UR_326N4G_GPIO_MODE);
+
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(UR_326N4G_leds_gpio),
+                                 UR_326N4G_leds_gpio);
+       ramips_register_gpio_buttons(-1, UR_326N4G_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(UR_326N4G_gpio_buttons),
+                                    UR_326N4G_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_UR_326N4G, "UR-326N4G", "UR-326N4G Wireless N router",
+             UR_326N4G_init);
index 831219c26949d3caa7729883031b1659cdfce5d3..2c2ca0062a588159adecda52deb74a528f9207e9 100644 (file)
@@ -131,6 +131,7 @@ CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_RT_N10_PLUS=y
 CONFIG_RT305X_MACH_RT_N13U=y
 CONFIG_RT305X_MACH_SL_R7205=y
+CONFIG_RT305X_MACH_UR_326N4G=y
 CONFIG_RT305X_MACH_UR_336UN=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_W306R_V20=y
index 64fac151ebc52ad864c23bee1ff0cfbbe0dc3508..f0a6338ffd8f6150bd896b52e12110b9362028e2 100644 (file)
@@ -130,6 +130,7 @@ CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_RT_N10_PLUS=y
 CONFIG_RT305X_MACH_RT_N13U=y
 CONFIG_RT305X_MACH_SL_R7205=y
+CONFIG_RT305X_MACH_UR_326N4G=y
 CONFIG_RT305X_MACH_UR_336UN=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_W306R_V20=y