[backfire] packages: merge r28760, r28763, r28764 & r28765
authorNicolas Thill <nico@openwrt.org>
Sat, 5 Nov 2011 19:59:03 +0000 (19:59 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 5 Nov 2011 19:59:03 +0000 (19:59 +0000)
SVN-Revision: 28773

libs/apr-util/Makefile
libs/apr/Makefile
libs/apr/patches/101-fix_apr_time_now.patch [new file with mode: 0644]
net/subversion/Makefile

index 80806cc3e721fa57717eab128e321c3652b2bcba..2ed99838363ef369cbf900692198730fab3d6fdb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr-util
 PKG_VERSION:=1.3.12
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
@@ -32,6 +32,8 @@ define Package/libaprutil
 endef
 
 TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
 CONFIGURE_ARGS += \
        --with-pgsql=no \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
index 91776bde538f4aadef37be63dbfae3b8a56a0e0c..e3e5a65e6954579d314ef2e63a398c605e6a2375 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr
 PKG_VERSION:=1.4.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.ibiblio.org/pub/mirrors/apache/apr
@@ -31,6 +31,8 @@ define Package/libapr
 endef
 
 TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
 CONFIGURE_ARGS += \
        --with-devrandom=/dev/urandom \
        --disable-dso \
@@ -39,10 +41,11 @@ CONFIGURE_ARGS += \
 # XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
 CONFIGURE_VARS += \
        ac_cv_sizeof_struct_iovec=1 \
+       ac_cv_struct_rlimit=yes \
        apr_cv_process_shared_works=no \
        apr_cv_mutex_robust_shared=no \
        apr_cv_tcp_nodelay_with_cork=yes \
-       ac_cv_struct_rlimit=yes \
+       apr_cv_use_lfs64=yes \
        LDFLAGS="$$$$LDFLAGS -lpthread" \
 
 define Build/InstallDev
diff --git a/libs/apr/patches/101-fix_apr_time_now.patch b/libs/apr/patches/101-fix_apr_time_now.patch
new file mode 100644 (file)
index 0000000..6ad14a3
--- /dev/null
@@ -0,0 +1,13 @@
+https://dev.openwrt.org/ticket/9287
+
+--- a/time/unix/time.c
++++ b/time/unix/time.c
+@@ -75,7 +75,7 @@ APR_DECLARE(apr_time_t) apr_time_now(voi
+ {
+     struct timeval tv;
+     gettimeofday(&tv, NULL);
+-    return tv.tv_sec * APR_USEC_PER_SEC + tv.tv_usec;
++    return tv.tv_sec * (apr_time_t)APR_USEC_PER_SEC + (apr_time_t)tv.tv_usec;
+ }
+ static void explode_time(apr_time_exp_t *xt, apr_time_t t,
index 9eb8041ff85affbe9ae918019a11ee3545a526c4..690f10d50223a9dbc2227fc94ca0606a621b76fe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=subversion
 PKG_VERSION:=1.6.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://subversion.tigris.org/downloads
@@ -73,6 +73,9 @@ define Package/subversion-server/conffiles
 /etc/config/subversion
 endef
 
+TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
 CONFIGURE_ARGS += \
        --with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
        --with-apr-util="$(STAGING_DIR)/usr/bin/apu-1-config" \