[packages] ffmpeg: add support for aac, mp2, ogg & vorbis, bump release number
authorNicolas Thill <nico@openwrt.org>
Mon, 5 Jul 2010 01:56:49 +0000 (01:56 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 5 Jul 2010 01:56:49 +0000 (01:56 +0000)
SVN-Revision: 22071

multimedia/ffmpeg/Config.in
multimedia/ffmpeg/Makefile

index c5267f3f624c7123b6cc2847b813f36ea6f547fe..a2da1ffc19f28c99a837dfbefad139b8a395af0a 100644 (file)
@@ -68,11 +68,19 @@ config FFMPEG_ENCODER_png
        bool "PNG"
        select FFMPEG_ENCODER_zlib
 
+config FFMPEG_ENCODER_vorbis
+       bool "Vorbis"
+
 config FFMPEG_ENCODER_zlib
        bool "Zlib"
 
 comment "Decoders ---"
 
+config FFMPEG_DECODER_aac
+       bool "AAC (Advanced Audio Coding)"
+       depends FFMPEG_PATENTED
+       select FFMPEG_PARSER_aac
+
 config FFMPEG_DECODER_ac3
        bool "AC3"
        depends FFMPEG_PATENTED
@@ -92,8 +100,12 @@ config FFMPEG_DECODER_h264
 config FFMPEG_DECODER_jpegls
        bool "JPEG-LS"
 
+config FFMPEG_DECODER_mp2
+       bool "MP2 (MPEG Audio Layer 2)"
+       depends FFMPEG_PATENTED
+
 config FFMPEG_DECODER_mp3
-       bool "MP3"
+       bool "MP3 (MPEG Audio Layer 2)"
        depends FFMPEG_PATENTED
 
 config FFMPEG_DECODER_mpegvideo
@@ -124,6 +136,9 @@ config FFMPEG_DECODER_png
        bool "PNG"
        select FFMPEG_DECODER_zlib
 
+config FFMPEG_DECODER_vorbis
+       bool "Vorbis"
+
 config FFMPEG_DECODER_wmav1
        bool "WMAv1"
        depends FFMPEG_PATENTED
@@ -149,7 +164,7 @@ config FFMPEG_MUXER_h264
        depends FFMPEG_PATENTED
 
 config FFMPEG_MUXER_mp3
-       bool "MP3"
+       bool "MP3 (MPEG Audio Layer 3)"
 
 config FFMPEG_MUXER_mp4
        bool "MP4"
@@ -163,6 +178,9 @@ config FFMPEG_MUXER_mpeg2video
 config FFMPEG_MUXER_mpegts
        bool "MPEG-2 (TS)"
 
+config FFMPEG_MUXER_ogg
+       bool "Ogg"
+
 config FFMPEG_MUXER_oss
        bool "OSS (Open Sound System playback)"
 
@@ -182,7 +200,7 @@ config FFMPEG_DEMUXER_h264
        depends FFMPEG_PATENTED
 
 config FFMPEG_DEMUXER_mp3
-       bool "MP3"
+       bool "MP3 (MPEG Audio Layer 3)"
 
 config FFMPEG_DEMUXER_mpegvideo
        bool "MPEG Video"
@@ -193,6 +211,9 @@ config FFMPEG_DEMUXER_mpegps
 config FFMPEG_DEMUXER_mpegts
        bool "MPEG-2 (TS)"
 
+config FFMPEG_DEMUXER_ogg
+       bool "Ogg"
+
 config FFMPEG_DEMUXER_rm
        bool "RM"
        help
@@ -209,6 +230,10 @@ config FFMPEG_DEMUXER_sdp
 
 comment "Parsers ---"
 
+config FFMPEG_PARSER_aac
+       bool "AAC (Advanced Audio Coding)"
+       depends FFMPEG_PATENTED
+
 config FFMPEG_PARSER_ac3
        bool "AC3"
 
index 28639f333102f8ef21973b5de200a6ff2ed5b6e2..36592b8f86ca554cb3e1e3c2ba2884ed00897fa8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=0.5.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -24,14 +24,17 @@ FFMPEG_ENCODERS:= \
        pcm_s16be \
        pcm_s16le \
        png \
+       vorbis \
        zlib \
 
 FFMPEG_DECODERS:= \
+       aac \
        ac3 \
        atrac3 \
        gif \
        h264 \
        jpegls \
+       mp2 \
        mp3 \
        mpeg1video \
        mpeg2video \
@@ -41,6 +44,7 @@ FFMPEG_DECODERS:= \
        pcm_s16be \
        pcm_s16le \
        png \
+       vorbis \
        wmav1 \
        wmav2 \
        zlib \
@@ -54,6 +58,7 @@ FFMPEG_MUXERS:= \
        mpeg1video \
        mpeg2video \
        mpegts \
+       ogg \
        oss \
        rtp \
 
@@ -65,12 +70,14 @@ FFMPEG_DEMUXERS:= \
        mpegps \
        mpegts \
        mpegvideo \
+       ogg \
        rm \
        rtsp \
        sdp \
        v4l2 \
 
 FFMPEG_PARSERS:= \
+       aac \
        ac3 \
        h264 \
        mpegaudio \