added yaml implementation in c and modify pyyaml to make use of it
authorMirko Vogt <mirko@openwrt.org>
Thu, 15 Jan 2009 11:28:52 +0000 (11:28 +0000)
committerMirko Vogt <mirko@openwrt.org>
Thu, 15 Jan 2009 11:28:52 +0000 (11:28 +0000)
SVN-Revision: 14041

lang/pyyaml/Makefile
libs/libyaml/Makefile [new file with mode: 0644]

index c130480749a301e214be5842385718c28b3ea73c..7f7db7a6b984652e0c231810ceefe1d925ec3338 100644 (file)
@@ -25,7 +25,7 @@ define Package/pyyaml
   CATEGORY:=Languages
   TITLE:=pyyaml
   URL:=http://pyyaml.org
-  DEPENDS:=python-core
+  DEPENDS:=python-core +libyaml
 endef
 
 define Package/pyyaml/description
@@ -33,7 +33,7 @@ define Package/pyyaml/description
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+       $(call Build/Compile/PyMod,,--with-libyaml install --prefix="$(PKG_INSTALL_DIR)/usr")
 endef
 
 define Package/pyyaml/install
diff --git a/libs/libyaml/Makefile b/libs/libyaml/Makefile
new file mode 100644 (file)
index 0000000..8e490af
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yaml
+PKG_VERSION:=0.1.2
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pyyaml.org/download/libyaml/
+
+PKG_INSTALL:=1
+
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libyaml
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=libyaml
+  URL:=http://pyyaml.org/wiki/LibYAML
+endef
+
+define Package/libyaml/description
+  yaml library written in c
+endef
+
+define Package/libyaml/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml.so $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libyaml.{a,la} $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libyaml))