kernel: of_i2c is moved into i2c-core in 3.12, add kernel version check into modules...
authorZoltan Herpai <wigyori@uid0.hu>
Mon, 11 Nov 2013 22:03:35 +0000 (22:03 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Mon, 11 Nov 2013 22:03:35 +0000 (22:03 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 38760

package/kernel/linux/modules/i2c.mk

index 8a26f42e757510af9a732fae0ae06bdb5d87f2b5..c0f9f813ec5df37bba9b74f4829668a083081776 100644 (file)
@@ -24,8 +24,10 @@ I2C_CORE_MODULES:= \
   CONFIG_I2C:drivers/i2c/i2c-core \
   CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
 
-ifeq ($(CONFIG_OF),y)
-  I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.12.0)),1)
+  ifeq ($(CONFIG_OF),y)
+    I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
+  endif
 endif
 
 define KernelPackage/i2c-core