[include] add remaining missing build prereq checks
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 11 Aug 2012 00:05:18 +0000 (00:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 11 Aug 2012 00:05:18 +0000 (00:05 +0000)
SVN-Revision: 33122

include/prereq-build.mk

index 28c2a216b25692b8f2cba36dc89b62d044f741da..74f1e32a6ed7daf8f5fc71a51a854b7669598d5f 100644 (file)
@@ -79,6 +79,16 @@ $(eval $(call Require,working-gcc-static, \
     Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL). \
 ))
 
+define Require/working-g++-static
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               g++ -x c++ -static -o $(TMP_DIR)/a.out - -lstdc++ && \
+               $(TMP_DIR)/a.out
+endef
+
+$(eval $(call Require,working-g++-static, \
+       Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL). \
+))
+
 define Require/ncurses
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses
@@ -98,6 +108,15 @@ $(eval $(call Require,zlib, \
        Please install zlib. (Missing libz.so or zlib.h) \
 ))
 
+define Require/zlib-static
+       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
+               gcc -include zlib.h -x c -static -o $(TMP_DIR)/a.out - -lz
+endef
+
+$(eval $(call Require,zlib-static, \
+       Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL). \
+))
+
 $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))