[packages] xtables-addons: update to v1.22 and fix compile against iptables 1.4.6
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 20:41:44 +0000 (20:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 20:41:44 +0000 (20:41 +0000)
SVN-Revision: 19318

net/xtables-addons/Makefile
net/xtables-addons/patches/001-no_depmod.patch
net/xtables-addons/patches/002-portability.patch [deleted file]

index eec557bf30d2308ab17d40f9dded6edeed155be2..3c84c9255d3afb6b07e2a078773981192f895ddb 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=1.18
+PKG_VERSION:=1.22
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=5a8d2edbf5a3470bba58d6a60c350805
+PKG_MD5SUM:=990e2d84a1767c8247c92ae7b11e53a9
 PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
 
 PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
 
@@ -39,6 +39,7 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DEPMOD="/bin/true" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DEPMOD="/bin/true" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                all install
 endef
 
                all install
 endef
 
index 38fc8fdf6435770f70e3b49cb8bba5d32e6d075c..256d61bbfba44f5549ee032c7bc33dcfc84cf28a 100644 (file)
@@ -1,11 +1,12 @@
 --- a/Makefile.in
 +++ b/Makefile.in
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -753,7 +753,7 @@ install-dvi: install-dvi-recursive
+@@ -751,8 +751,7 @@
  install-dvi-am:
  
  install-dvi-am:
  
--install-exec-am: install-exec-local
-+install-exec-am:
+ install-exec-am:
+-      @$(NORMAL_INSTALL)
+-      $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
++
  install-html: install-html-recursive
  
  install-html: install-html-recursive
  
+ install-html-am:
diff --git a/net/xtables-addons/patches/002-portability.patch b/net/xtables-addons/patches/002-portability.patch
deleted file mode 100644 (file)
index acd854d..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/extensions/GNUmakefile.in
-+++ b/extensions/GNUmakefile.in
-@@ -2,8 +2,8 @@
- top_srcdir      := @top_srcdir@
- srcdir          := @srcdir@
--abstop_srcdir   := $(shell readlink -f ${top_srcdir})
--abssrcdir       := $(shell readlink -f ${srcdir})
-+abstop_srcdir   := $(shell cd ${top_srcdir} && pwd)
-+abssrcdir       := $(shell cd ${srcdir} && pwd)
- ifeq (${abstop_srcdir},)
- $(error Path resolution of ${top_srcdir} failed)
---- a/extensions/ipset/GNUmakefile.in
-+++ b/extensions/ipset/GNUmakefile.in
-@@ -3,8 +3,8 @@
- top_srcdir      := @top_srcdir@
- srcdir          := @srcdir@
- datarootdir     := @datarootdir@
--abstop_srcdir   := $(shell readlink -f ${top_srcdir})
--abssrcdir       := $(shell readlink -f ${srcdir})
-+abstop_srcdir   := $(shell cd ${top_srcdir} && pwd)
-+abssrcdir       := $(shell cd ${srcdir} && pwd)
- ifeq (${abstop_srcdir},)
- $(error Path resolution of ${top_srcdir} failed)