ar71xx: add support for TL-WR741ND v5
authorJohn Crispin <john@openwrt.org>
Tue, 7 Jul 2015 13:47:17 +0000 (13:47 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 7 Jul 2015 13:47:17 +0000 (13:47 +0000)
This device is identical to the TL-WR740N v5, it even uses the same HWID (which
wasn't the case for older TL-WR741ND revisions).

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 46238

target/linux/ar71xx/image/Makefile

index 018385dabfc5d2c7aef324789352dcefba05629b..74e68403490743698b8b1eefcf4cb79445120ee7 100644 (file)
@@ -548,6 +548,14 @@ define Device/tl-wr741nd-v4
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr741nd-v5
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR741ND-v4
+    DEVICE_PROFILE := TLWR741
+    TPLINK_HWID := 0x07400005
+    CONSOLE := ttyATH0,115200
+endef
+
 define Device/tl-wr743nd-v2
     $(Device/tplink-4mlzma)
     BOARDNAME := TL-WR741ND-v4
@@ -555,7 +563,7 @@ define Device/tl-wr743nd-v2
     TPLINK_HWID := 0x07430002
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr741nd-v5 tl-wr743nd-v2
 
 define Device/tl-wr841n-v8
     $(Device/tplink-4mlzma)