[backfire] merge [20906:20912], [20914:20922] & [20972]
authorNicolas Thill <nico@openwrt.org>
Thu, 22 Apr 2010 16:13:06 +0000 (16:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 22 Apr 2010 16:13:06 +0000 (16:13 +0000)
SVN-Revision: 21092

38 files changed:
package/ar7-atm/Config.in
package/ar7-atm/Makefile
package/busybox/Config.in [new file with mode: 0644]
package/busybox/Makefile
package/busybox/target-config.in [deleted file]
package/compcache/Config.in
package/compcache/Makefile
package/ifx-tapi/Config.in
package/ifx-tapi/Makefile
package/ifx-tapidemo/Config.in
package/ifx-tapidemo/Makefile
package/ifx-vmmc/Config.in
package/ifx-vmmc/Makefile
package/ifxmips-dsl-api/Config.in
package/ifxmips-dsl-api/Makefile
package/kexec-tools/Config.in [new file with mode: 0644]
package/kexec-tools/Makefile
package/kexec-tools/kexec-config.in [deleted file]
package/libpcap/Config.in
package/libpcap/Makefile
package/mac80211/Config.in [deleted file]
package/mac80211/Config.in.ath9k [deleted file]
package/mac80211/Config.in.b43 [deleted file]
package/mac80211/Config.in.b43legacy [deleted file]
package/mac80211/Config.in.rt2x00 [deleted file]
package/mac80211/Makefile
package/madwifi/Config.in
package/madwifi/Makefile
package/mmc_over_gpio/Makefile
package/openssl/Config.in
package/openssl/Makefile
package/uboot-ifxmips/Config.in
package/uboot-ifxmips/Makefile
package/uboot-lantiq/Config.in
package/uboot-lantiq/Makefile
package/udev/Config.in [new file with mode: 0644]
package/udev/Makefile
package/udev/udev-config.in [deleted file]

index 395755c594a2a6fbbaa8151536421ee30d9b0cf0..479b7ad072c06b8bb5557ad2220b4fefe3009cbb 100644 (file)
@@ -1,6 +1,8 @@
+menu "Configuration"
+       depends on (PACKAGE_kmod-sangam-atm-annex-a || PACKAGE_kmod-sangam-atm-annex-b)
+
 choice
        prompt "Firmware version"
-       depends on (PACKAGE_kmod-sangam-atm-annex-a || PACKAGE_kmod-sangam-atm-annex-b)
        default AR7_ATM_FW_VERSION_704
        help
                This option allows you to switch between firmware/driver versions which
@@ -16,3 +18,5 @@ config AR7_ATM_FW_VERSION_703
        bool "D7.03.01.00"
 
 endchoice
+
+endmenu
index e5cef079101c70748ce10c69bd8467054e7cab9f..fc8b5771241fb56181e3a24c6cbe49da462974ec 100644 (file)
@@ -42,6 +42,7 @@ define KernelPackage/sangam-atm/Default
   TITLE:=AR7 ADSL driver
   FILES:=$(PKG_BUILD_DIR)/tiatm.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,tiatm)
+  MENU:=1
 endef
 
 define KernelPackage/sangam-atm/config
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
new file mode 100644 (file)
index 0000000..1002a5a
--- /dev/null
@@ -0,0 +1,39 @@
+menu "Configuration"
+       depends on PACKAGE_busybox
+
+config BUSYBOX_CONFIG_FEATURE_DEVFS
+       bool
+       default y if LINUX_2_4
+       default n if LINUX_2_6
+
+config BUSYBOX_CONFIG_FEATURE_2_4_MODULES
+       bool
+       default y if LINUX_2_4
+       default n if LINUX_2_6
+
+config BUSYBOX_CONFIG_FEATURE_2_6_MODULES
+       bool
+       default n if LINUX_2_4
+       default y if LINUX_2_6
+
+config BUSYBOX_CONFIG_NOMMU
+       bool
+       depends NOMMU
+       default y if NOMMU
+       deselect BUSYBOX_CONFIG_ASH
+       deselect BUSYBOX_CONFIG_FEATURE_SH_IS_ASH
+       deselect BUSYBOX_CONFIG_LOCK
+
+config CONFIG_BUSYBOX_CONFIG_FEATURE_SH_IS_HUSH
+       bool
+       default y if NOMMU
+       default n if !NOMMU
+
+config BUSYBOX_CONFIG_HUSH
+       bool
+       default y if NOMMU
+       default n if !NOMMU
+
+source "package/busybox/config/Config.in"
+
+endmenu
index 6eeb07962b7cf1656e051a6f6ffef45907019639..e6934a6eb12176907daf7f8e4fd48cb0340cd1b1 100644 (file)
@@ -41,11 +41,7 @@ define Package/busybox/description
 endef
 
 define Package/busybox/config
-       menu "Configuration"
-               depends on PACKAGE_busybox
-               source "$(SOURCE)/target-config.in"
-               source "$(SOURCE)/config/Config.in"
-       endmenu
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Configure
diff --git a/package/busybox/target-config.in b/package/busybox/target-config.in
deleted file mode 100644 (file)
index b065561..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-config BUSYBOX_CONFIG_FEATURE_DEVFS
-       bool
-       default y if LINUX_2_4
-       default n if LINUX_2_6
-
-config BUSYBOX_CONFIG_FEATURE_2_4_MODULES
-       bool
-       default y if LINUX_2_4
-       default n if LINUX_2_6
-
-config BUSYBOX_CONFIG_FEATURE_2_6_MODULES
-       bool
-       default n if LINUX_2_4
-       default y if LINUX_2_6
-
-config BUSYBOX_CONFIG_NOMMU
-       bool
-       depends NOMMU
-       default y if NOMMU
-       deselect BUSYBOX_CONFIG_ASH
-       deselect BUSYBOX_CONFIG_FEATURE_SH_IS_ASH
-       deselect BUSYBOX_CONFIG_LOCK
-
-config CONFIG_BUSYBOX_CONFIG_FEATURE_SH_IS_HUSH
-       bool
-       default y if NOMMU
-       default n if !NOMMU
-
-config BUSYBOX_CONFIG_HUSH
-       bool
-       default y if NOMMU
-       default n if !NOMMU
-
index 9904237edc6c52b8a697d7187111e6d99649d2a9..11a94d434205c19eda5088759801964bae9c308e 100644 (file)
@@ -1,15 +1,14 @@
-# compcache configuration
+menu "Configuration"
+       depends on PACKAGE_kmod-compcache
 
 config COMPCACHE_ENABLE
        bool "enabled on boot"
        default n
-       depends on PACKAGE_kmod-compcache
        help
          Enables compressed ram swap devices.
 
 config COMPCACHE_RAM_REPORTED
        string "swap space reported to kernel in kb"
-       depends on PACKAGE_kmod-compcache
        default "2048"
        help
          This is the amount of memory that will be reported 
@@ -21,10 +20,10 @@ config COMPCACHE_RAM_REPORTED
 
 config COMPCACHE_BACKUP_DEV
        string "Backup device for compcache"
-       depends on PACKAGE_kmod-compcache
        default ""
        help
          Compcache will use this as a backup device for swap.
          Example:
                 /dev/sda5
 
+endmenu
index 2fec2895277ed3ed47230cc0121d08e88a11032e..13a9056db41da59ff66e9958fce2f7e2bfd86b75 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/compcache
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)+$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/ramzswap.$(LINUX_KMOD_SUFFIX) \
         $(PKG_BUILD_DIR)/sub-projects/compression/lzo-kmod/lzo1x.$(LINUX_KMOD_SUFFIX)
+  MENU:=1
 endef
 
 
index 56defb3dd11e9a4dc772585fcfeccc9bfba7df4f..e360883fd4e209e34b42648c22954d2400e726cc 100644 (file)
@@ -1,3 +1,6 @@
+menu "Configuration"
+       depends on PACKAGE_kmod-ifx-tapi
+
 config VOICE_CPE_TAPI_FAX
        bool "fax relay and modem support"
        default n
@@ -69,3 +72,5 @@ config VOICE_CPE_TAPI_TRACES
        help
                enable driver traces with different trace levels to be
                configured dynamically from the application or during insmod
+
+endmenu
index fe91ad015c3118b326db9f2fd100d1c913e57853..e4638186e2ae0aab377f093ea60f60536fbeb177 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/ifx-tapi
   DEPENDS:=+kmod-ifxos @BROKEN
   FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
+  MENU:=1
 endef
 
 define KernelPackage/ifx-tapi/description
@@ -33,9 +34,7 @@ define KernelPackage/ifx-tapi/description
 endef
 
 define KernelPackage/ifx-tapi/config
-       if PACKAGE_kmod-ifx-tapi
-               source "$(SOURCE)/Config.in"
-       endif
+       source "$(SOURCE)/Config.in"
 endef
 
 CONFIGURE_ARGS += \
index 32594ba9cb9d5088d522f80afabc96ece730419f..42ec5fa1c3a194a530eba49bbf5e6712ed8d6784 100644 (file)
@@ -1,3 +1,5 @@
+menu "Configuration"
+       depends on PACKAGE_ifx-tapidemo
 choice
        prompt "board selection"
        default VOICE_CPE_TAPIDEMO_BOARD_EASY50712_V3  if TARGET_ifxmips_platform_danube
@@ -34,3 +36,4 @@ config  VOICE_CPE_TAPIDEMO_FAX_T.38_FW
        help
                enable T.38 fax relay demo.
 
+endmenu
index 217d4641a5159fb8e4b3ef732e2a3c27cdbe081b..b294d9d3a721b3987615a42c74a55160a9e684e1 100644 (file)
@@ -26,6 +26,7 @@ define Package/ifx-tapidemo
   URL:=http://www.lantiq.com/
   MAINTAINER:=Lantiq
   DEPENDS:=+kmod-ifx-tapi +kmod-ifx-vmmc @BROKEN
+  MENU:=1
 endef
 
 define Package/ifx-tapidemo/description
@@ -33,9 +34,7 @@ define Package/ifx-tapidemo/description
 endef
 
 define Package/ifx-tapidemo/config
-       if PACKAGE_ifx-tapidemo
-               source "$(SOURCE)/Config.in"
-       endif
+       source "$(SOURCE)/Config.in"
 endef
 
 CONFIGURE_ARGS += \
index bd3c032d3a122aaac2ef8cdfc9ad7e5afd1b83e1..2a7894e7f0f1419ca2557bb5ab436af0be59245e 100644 (file)
@@ -1,3 +1,5 @@
+menu "Configuration"
+       depends on PACKAGE_kmod-ifx-vmmc
 choice
        prompt "device selection"
        default VOICE_CPE_VMMC_WITH_DEVICE_DANUBE_extract
@@ -47,3 +49,5 @@ config VOICE_CPE_VMMC_MPS_HISTORY_SIZE
                MPS history buffer (default=128 words, maximum=512 words, 0=disable)
                To opimize the memory footprint in RAM, you might want to set the
                buffer size to 0.
+
+endmenu
index 945d5ba7efa8558e73750d7da694ca4c594b43c9..0fa3649e9cafb66228d1a20449bb46f9eab137e6 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/ifx-vmmc
   DEPENDS:=+kmod-ifx-tapi @BROKEN
   FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,25,drv_vmmc)
+  MENU:=1
 endef
 
 define KernelPackage/ifx-vmmc/description
@@ -33,9 +34,7 @@ define KernelPackage/ifx-vmmc/description
 endef
 
 define KernelPackage/ifx-vmmc/config
-       if PACKAGE_kmod-ifx-vmmc
-               source "$(SOURCE)/Config.in"
-       endif
+       source "$(SOURCE)/Config.in"
 endef
 
 CONFIGURE_ARGS += \
index 56177d16894e0e5d75fb743a9f4ab519b1d6eaeb..72942e6fff75480d3f33381dac3399c85c07395b 100644 (file)
@@ -1,6 +1,8 @@
+menu "Configuration"
+       depends on PACKAGE_kmod-ifxmips-dsl-api
+
 choice
        prompt "Firmware"
-       depends on PACKAGE_kmod-ifxmips-dsl-api
        default IFXMIPS_ANNEX_B
        help
          This option controls which firmware is loaded
@@ -20,12 +22,12 @@ endchoice
 config IFXMIPS_DSL_FIRMWARE
        bool "ifxmips-dsl firmware extractor"
        default y
-       depends on PACKAGE_kmod-ifxmips-dsl-api
        help
          Say Y, if you need ifxmips-dsl to auto extract the firmware for you from the a800 firmware image
 
 config IFXMIPS_DSL_DEBUG
        bool "ifxmips-dsl debugging"
-       depends on PACKAGE_kmod-ifxmips-dsl-api
        help
          Say Y, if you need ifxmips-dsl to display debug messages.
+
+endmenu
index b1952b5edc92f435a44fe82bf4051853e42286b8..1e19da23d9af743fa39b5a9c19b8df9ddcbcf9ad 100644 (file)
@@ -39,6 +39,7 @@ define KernelPackage/ifxmips-dsl-api
        $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/src/mei/ifxmips_atm.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,ifxmips_mei drv_dsl_cpe_api ifxmips_atm)
+  MENU:=1
 endef
 
 define KernelPackage/ifxmips-dsl-api/description
diff --git a/package/kexec-tools/Config.in b/package/kexec-tools/Config.in
new file mode 100644 (file)
index 0000000..60c819d
--- /dev/null
@@ -0,0 +1,21 @@
+menu "Configuration"
+       depends on PACKAGE_kexec-tools
+
+config KEXEC_TOOLS_TARGET_NAME
+       string
+       prompt "Target name for kexec kernel"
+       default EXTRA_TARGET_ARCH_NAME  if powerpc64
+       default ARCH
+       help
+         Defines the target type of the kernels that kexec deals
+         with. This should be the target specification of
+         the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+       bool
+       prompt "kdump support"
+       default n
+       help
+         Include the kdump utility.
+
+endmenu
index d350bb2c8b6157a3b5c8106a7752beb9b9cc811d..978bb6fd504f1e549d5e0dbc688a892d73d4fe1f 100644 (file)
@@ -34,7 +34,7 @@ define Package/kexec-tools/description
 endef
 
 define Package/kexec-tools/config
-       source "$(SOURCE)/kexec-config.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/kexec-config.in
deleted file mode 100644 (file)
index 25fed1b..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-
-config KEXEC_TOOLS_TARGET_NAME
-       string
-       prompt "Target name for kexec kernel" if PACKAGE_kexec-tools
-       default EXTRA_TARGET_ARCH_NAME  if powerpc64
-       default ARCH
-       help
-         Defines the target type of the kernels that kexec deals
-         with. This should be the target specification of
-         the kernel you're booting.
-
-config KEXEC_TOOLS_kdump
-       bool
-       prompt "kdump support"
-       depends on PACKAGE_kexec-tools
-       default n
-       help
-         Include the kdump utility.
-
index 1b9463e6aa661b0590b1808158a972907941cd11..ef32c1bc0878d043117169f892f0fe875edd028d 100644 (file)
@@ -1,12 +1,15 @@
+menu "Configuration"
+       depends PACKAGE_libpcap
+
 config PCAP_HAS_USB
        bool "Include USB support"
-       depends PACKAGE_libpcap
        depends PACKAGE_kmod-usb-core
        default n
 
 config PCAP_HAS_BT
        bool "Include bluetooth support"
-       depends PACKAGE_libpcap
        depends PACKAGE_kmod-bluetooth
        depends BROKEN
        default n
+
+endmenu
index fcc9987c0f02b2fd7c6e8aca795b86074aa72e61..a885f90c7fe0bdc559f980f6ec565b209bc78fd8 100644 (file)
@@ -25,6 +25,7 @@ define Package/libpcap
   CATEGORY:=Libraries
   TITLE:=Low-level packet capture library
   URL:=http://www.tcpdump.org/
+  MENU:=1
 endef
 
 define Package/libpcap/description
@@ -33,7 +34,7 @@ capture.
 endef
 
 define Package/libpcap/config
-source "$(SOURCE)/Config.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 TARGET_CFLAGS += \
diff --git a/package/mac80211/Config.in b/package/mac80211/Config.in
deleted file mode 100644 (file)
index 5994ba7..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-# mac80211 configuration
-
-config PACKAGE_MAC80211_DEBUGFS
-       bool "Export mac80211 internals in DebugFS"
-       depends on PACKAGE_kmod-mac80211
-       default y
-       ---help---
-         Select this to see extensive information about
-         the internal state of mac80211 in debugfs.
-
-         Say N unless you know you need this.
diff --git a/package/mac80211/Config.in.ath9k b/package/mac80211/Config.in.ath9k
deleted file mode 100644 (file)
index 8f68b4e..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-# mac80211 configuration
-
-config PACKAGE_ATH9K_USE_MINSTREL
-       bool "use the new minstrel_ht rate control for ath9k"
-       depends PACKAGE_kmod-ath9k
diff --git a/package/mac80211/Config.in.b43 b/package/mac80211/Config.in.b43
deleted file mode 100644 (file)
index e1f4d37..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# B43 configuration
-
-choice
-       prompt "b43 firmware version"
-       depends on PACKAGE_kmod-b43
-       default B43_EXPERIMENTAL
-       help
-         This option allows you to select the version of the b43 firmware.
-
-config B43_STABLE
-       bool "4.150.10.5 (stable)"
-       help
-         Stable firmware for BCM43xx devices.
-
-         If unsure, select this.
-
-config B43_EXPERIMENTAL
-       bool "4.178.10.4 (experimental)"
-       help
-         Experimental firmware for BCM43xx devices.
-
-         This firmware is not tested as much as the "stable" firmware.
-
-         If unsure, select the "stable" firmware.
-
-config B43_OPENFIRMWARE
-       bool "Open FirmWare for WiFi networks"
-       help
-         Opensource firmware for BCM43xx devices.
-
-         Do _not_ select this, unless you know what you are doing.
-         The Opensource firmware is not suitable for embedded devices, yet.
-         It does not support QoS, which is bad for AccessPoints.
-         It does not support hardware crypto acceleration, which is a showstopper
-         for embedded devices with low CPU resources.
-
-         If unsure, select the "stable" firmware.
-
-endchoice
-
-config B43_FW_SQUASH
-       bool "Remove unnecessary firmware files"
-       depends on PACKAGE_kmod-b43 && !B43_OPENFIRMWARE
-       default y
-       help
-         This options allows you to remove unnecessary b43 firmware files
-         from the final rootfs image. This can reduce the rootfs size by
-         up to 200k.
-
-         If unsure, say Y.
-
-config B43_FW_SQUASH_COREREVS
-       string "Core revisions to include"
-       depends on PACKAGE_kmod-b43 && B43_FW_SQUASH
-       default "5,6,7,8,9,10,13,14,15"
-       help
-         This is a comma seperated list of core revision numbers.
-         Example (keep files for rev5 only):
-                5
-         Example (keep files for rev5 and rev11):
-                5,11
-
-config B43_FW_SQUASH_PHYTYPES
-       string "PHY types to include"
-       depends on PACKAGE_kmod-b43 && B43_FW_SQUASH
-       default "G,LP"
-       help
-         This is a comma seperated list of PHY types:
-         A         => A-PHY
-         AG        => Dual A-PHY G-PHY
-         G         => G-PHY
-         LP        => LP-PHY
-         N         => N-PHY
-
-         Example (keep files for G-PHY only):
-                G
-         Example (keep files for G-PHY and N-PHY):
-                G,N
-
diff --git a/package/mac80211/Config.in.b43legacy b/package/mac80211/Config.in.b43legacy
deleted file mode 100644 (file)
index 2e2f06e..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-# B43 configuration
-
-config B43LEGACY_FW_SQUASH
-       bool "Remove unnecessary firmware files"
-       depends on PACKAGE_kmod-b43legacy
-       default y
-       help
-         This options allows you to remove unnecessary b43legacy firmware files
-         from the final rootfs image. This can reduce the rootfs size by
-         up to 50k.
-
-         If unsure, say Y.
-
-config B43LEGACY_FW_SQUASH_COREREVS
-       string "Core revisions to include"
-       depends on PACKAGE_kmod-b43legacy && B43LEGACY_FW_SQUASH
-       default "1,2,3,4"
-       help
-         This is a comma seperated list of core revision numbers.
-         Example (keep files for rev4 only):
-                4
-         Example (keep files for rev2 and rev4):
-                2,4
-
diff --git a/package/mac80211/Config.in.rt2x00 b/package/mac80211/Config.in.rt2x00
deleted file mode 100644 (file)
index f985514..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-# rt2x00 configuration
-
-config PACKAGE_RT2X00_LIB_DEBUGFS
-       bool "Enable rt2x00 debugfs support"
-       depends PACKAGE_kmod-rt2x00-lib && PACKAGE_MAC80211_DEBUGFS
-       ---help---
-         Enable creation of debugfs files for the rt2x00 drivers.
-         These debugfs files support both reading and writing of the
-         most important register types of the rt2x00 hardware.
-
-config PACKAGE_RT2X00_DEBUG
-       bool "Enable rt2x00 debug output"
-       depends PACKAGE_kmod-rt2x00-lib
-       ---help---
-         Enable debugging output for all rt2x00 modules
index d93c982f6434ec67a1f62b4c955f4d6daba3b3c6..ba4cda5dfa99d23ee7c40ad333e00ee739ece035 100644 (file)
@@ -66,10 +66,23 @@ define KernelPackage/mac80211
   DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211
   FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,21,mac80211)
+  MENU:=1
 endef
 
 define KernelPackage/mac80211/config
-       source "$(SOURCE)/Config.in"
+       menu "Configuration"
+               depends on PACKAGE_kmod-mac80211
+
+       config PACKAGE_MAC80211_DEBUGFS
+               bool "Export mac80211 internals in DebugFS"
+               default y
+               help
+                 Select this to see extensive information about
+                 the internal state of mac80211 in debugfs.
+
+                 Say N unless you know you need this.
+
+       endmenu
 endef
 
 define KernelPackage/mac80211/description
@@ -186,10 +199,27 @@ $(call KernelPackage/rt2x00/Default)
   TITLE+= (LIB)
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/rt2x00/rt2x00lib.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,25,rt2x00lib)
+  MENU:=1
 endef
 
 define KernelPackage/rt2x00-lib/config
-       source "$(SOURCE)/Config.in.rt2x00"
+       menu "Configuration"
+               depends PACKAGE_kmod-rt2x00-lib
+
+       config PACKAGE_RT2X00_LIB_DEBUGFS
+               bool "Enable rt2x00 debugfs support"
+               depends PACKAGE_MAC80211_DEBUGFS
+               help
+                 Enable creation of debugfs files for the rt2x00 drivers.
+                 These debugfs files support both reading and writing of the
+                 most important register types of the rt2x00 hardware.
+
+       config PACKAGE_RT2X00_DEBUG
+               bool "Enable rt2x00 debug output"
+               help
+                 Enable debugging output for all rt2x00 modules
+
+       endmenu
 endef
 
 define KernelPackage/rt2x00-pci
@@ -321,24 +351,27 @@ define KernelPackage/zd1211rw
 endef
 
 define KernelPackage/ath/config
+       menu "Configuration"
+               depends on PACKAGE_kmod-ath
+
+       config ATH_USER_REGD
+               bool "Force Atheros drivers to respect the user's regdomain settings"
+               help
+                 Atheros' idea of regulatory handling is that the EEPROM of the card defines
+                 the regulatory limits and the user is only allowed to restrict the settings
+                 even further, even if the country allows frequencies or power levels that
+                 are forbidden by the EEPROM settings.
+
+                 Select this option if you want the driver to respect the user's decision about
+                 regulatory settings.
+
+       config PACKAGE_ATH_DEBUG
+               bool "Atheros wireless debugging"
+               help
+                 Say Y, if you want to debug atheros wireless drivers.
+                 Right now only ath9k makes use of this.
 
-config ATH_USER_REGD
-       bool "Force Atheros drivers to respect the user's regdomain settings"
-       depends on PACKAGE_kmod-ath
-       help
-               Atheros' idea of regulatory handling is that the EEPROM of the card defines
-               the regulatory limits and the user is only allowed to restrict the settings
-               even further, even if the country allows frequencies or power levels that
-               are forbidden by the EEPROM settings.
-               Select this option if you want the driver to respect the user's decision about
-               regulatory settings.
-
-config PACKAGE_ATH_DEBUG
-       bool "Atheros wireless debugging"
-       depends on PACKAGE_kmod-ath
-       help
-               Say Y, if you want to debug atheros wireless drivers.
-               Right now only ath9k makes use of this.
+       endmenu
 endef
 
 define KernelPackage/ath
@@ -347,6 +380,7 @@ define KernelPackage/ath
   DEPENDS+= @PCI_SUPPORT +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,26,ath)
+  MENU:=1
 endef
 
 define KernelPackage/ath/description
@@ -377,6 +411,7 @@ define KernelPackage/ath9k
        $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_hw.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,27,ath9k_hw ath9k_common ath9k)
+  MENU:=1
 endef
 
 define KernelPackage/ath9k/description
@@ -385,7 +420,13 @@ Atheros IEEE 802.11n AR5008 and AR9001 family of chipsets.
 endef
 
 define KernelPackage/ath9k/config
-       source "$(SOURCE)/Config.in.ath9k"
+       menu "Configuration"
+               depends PACKAGE_kmod-ath9k
+
+       config PACKAGE_ATH9K_USE_MINSTREL
+               bool "use the new minstrel_ht rate control for ath9k"
+
+       endmenu
 endef
 
 USB8388FW_NAME:=usb8388
@@ -579,10 +620,93 @@ $(call KernelPackage/b43-common)
   TITLE:=Broadcom 43xx wireless support
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/b43/b43.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,b43)
+  MENU:=1
 endef
 
 define KernelPackage/b43/config
-       source "$(SOURCE)/Config.in.b43"
+       menu "Configuration"
+               depends on PACKAGE_kmod-b43
+
+       choice
+               prompt "b43 firmware version"
+               default B43_EXPERIMENTAL
+               help
+                 This option allows you to select the version of the b43 firmware.
+
+       config B43_STABLE
+               bool "4.150.10.5 (stable)"
+               help
+                 Stable firmware for BCM43xx devices.
+
+                 If unsure, select this.
+
+       config B43_EXPERIMENTAL
+               bool "4.178.10.4 (experimental)"
+               help
+                 Experimental firmware for BCM43xx devices.
+
+                 This firmware is not tested as much as the "stable" firmware.
+
+                 If unsure, select the "stable" firmware.
+
+       config B43_OPENFIRMWARE
+               bool "Open FirmWare for WiFi networks"
+               help
+                 Opensource firmware for BCM43xx devices.
+
+                 Do _not_ select this, unless you know what you are doing.
+                 The Opensource firmware is not suitable for embedded devices, yet.
+                 It does not support QoS, which is bad for AccessPoints.
+                 It does not support hardware crypto acceleration, which is a showstopper
+                 for embedded devices with low CPU resources.
+
+                 If unsure, select the "stable" firmware.
+
+       endchoice
+
+       config B43_FW_SQUASH
+               bool "Remove unnecessary firmware files"
+               depends on !B43_OPENFIRMWARE
+               default y
+               help
+                 This options allows you to remove unnecessary b43 firmware files
+                 from the final rootfs image. This can reduce the rootfs size by
+                 up to 200k.
+
+                 If unsure, say Y.
+
+       config B43_FW_SQUASH_COREREVS
+               string "Core revisions to include"
+               depends on B43_FW_SQUASH
+               default "5,6,7,8,9,10,13,14,15"
+               help
+                 This is a comma seperated list of core revision numbers.
+
+                 Example (keep files for rev5 only):
+                   5
+
+                 Example (keep files for rev5 and rev11):
+                   5,11
+
+       config B43_FW_SQUASH_PHYTYPES
+               string "PHY types to include"
+               depends on B43_FW_SQUASH
+               default "G,LP"
+               help
+                 This is a comma seperated list of PHY types:
+                   A  => A-PHY
+                   AG => Dual A-PHY G-PHY
+                   G  => G-PHY
+                   LP => LP-PHY
+                   N  => N-PHY
+
+                 Example (keep files for G-PHY only):
+                   G
+
+                 Example (keep files for G-PHY and N-PHY):
+                   G,N
+
+       endmenu
 endef
 
 define KernelPackage/b43/description
@@ -594,10 +718,37 @@ $(call KernelPackage/b43-common)
   TITLE:=Broadcom 43xx-legacy wireless support
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/b43legacy/b43legacy.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,b43legacy)
+  MENU:=1
 endef
 
 define KernelPackage/b43legacy/config
-       source "$(SOURCE)/Config.in.b43legacy"
+       menu "Configuration"
+               depends on PACKAGE_kmod-b43legacy
+
+       config B43LEGACY_FW_SQUASH
+               bool "Remove unnecessary firmware files"
+               default y
+               help
+                 This options allows you to remove unnecessary b43legacy firmware files
+                 from the final rootfs image. This can reduce the rootfs size by
+                 up to 50k.
+
+                 If unsure, say Y.
+
+       config B43LEGACY_FW_SQUASH_COREREVS
+               string "Core revisions to include"
+               depends on B43LEGACY_FW_SQUASH
+               default "1,2,3,4"
+               help
+                 This is a comma seperated list of core revision numbers.
+
+                 Example (keep files for rev4 only):
+                   4
+
+                 Example (keep files for rev2 and rev4):
+                   2,4
+
+       endmenu
 endef
 
 define KernelPackage/b43legacy/description
index 7f1e36d04299002f6e4f6a9a1808a0a8cbb660c9..7b72eb854edb28c0b97d693c2d47dc6421241eac 100644 (file)
@@ -1,13 +1,13 @@
-# MadWifi configuration
+menu "Configuration"
+       depends on PACKAGE_kmod-madwifi
 
 config MADWIFI_DEBUG
        bool "Enable compilation of debugging features"
-       depends on DEVEL && PACKAGE_kmod-madwifi
+       depends on DEVEL
        default n
 
 config MADWIFI_COMPRESSION
        bool "Enable Atheros Super A/G Compression"
-       depends on PACKAGE_kmod-madwifi
        depends !TARGET_ar71xx
        default n
        help
@@ -15,7 +15,6 @@ config MADWIFI_COMPRESSION
 
 config MADWIFI_SINGLE_MODULE
        bool "Combine driver and net80211 into a single module"
-       depends on PACKAGE_kmod-madwifi
        default y
        help
          This option combines all driver and stack related code (except for HAL)
@@ -24,7 +23,6 @@ config MADWIFI_SINGLE_MODULE
 
 choice
        prompt "Rate control algorithm selection"
-       depends on PACKAGE_kmod-madwifi
        default MADWIFI_RCA_MINSTREL
        help
          This option controls how MadWifi chooses its bitrate.
@@ -53,3 +51,5 @@ config MADWIFI_RCA_SAMPLERATE
          average transmission time.
 
 endchoice
+
+endmenu
index 4c8415a6bebd80278dc0455e44426ad40c939bed..4f01f008fd7fd3baaaccf2922662ab626ca1d6f7 100644 (file)
@@ -165,6 +165,7 @@ define KernelPackage/madwifi
   DEPENDS:=+wireless-tools @LINUX_2_6 @PCI_SUPPORT @(!(TARGET_avr32||TARGET_cobalt||TARGET_ep93xx||TARGET_etrax||TARGET_octeon||TARGET_pxcab||TARGET_sibyte)||BROKEN)
   FILES:=$(MADWIFI_FILES)
   AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
+  MENU:=1
 endef
 
 define KernelPackage/madwifi/description
index 4c6fdb5a9c121fbf0f5d7d75049d906680d2a44f..5a3ab1d6011b37b90347a9f0e598a3bedd33db78 100644 (file)
@@ -21,28 +21,30 @@ define KernelPackage/mmc-over-gpio
   TITLE:=MMC/SD card over GPIO support
   FILES:=$(LINUX_DIR)/drivers/mmc/host/gpiommc.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,93,gpiommc)
+  MENU:=1
 endef
 
 define Package/kmod-mmc-over-gpio/config
-config KMOD_MMC_OVER_GPIO_DI_PIN
-       int "GPIO DI PIN"
-       depends PACKAGE_kmod-mmc-over-gpio
-       default 1
-
-config KMOD_MMC_OVER_GPIO_DO_PIN
-       int "GPIO DO PIN"
-       depends PACKAGE_kmod-mmc-over-gpio
-       default 3
-
-config KMOD_MMC_OVER_GPIO_CLK_PIN
-       int "GPIO CLK PIN"
-       depends PACKAGE_kmod-mmc-over-gpio
-       default 4
-
-config KMOD_MMC_OVER_GPIO_CS_PIN
-       int "GPIO CS PIN"
-       depends PACKAGE_kmod-mmc-over-gpio
-       default 7
+       menu "Configuration"
+               depends PACKAGE_kmod-mmc-over-gpio
+
+       config KMOD_MMC_OVER_GPIO_DI_PIN
+               int "GPIO DI (Data-In) pin"
+               default 1
+
+       config KMOD_MMC_OVER_GPIO_DO_PIN
+               int "GPIO DO (Data-Out) pin"
+               default 3
+
+       config KMOD_MMC_OVER_GPIO_CLK_PIN
+               int "GPIO CLK (Clock) pin"
+               default 4
+
+       config KMOD_MMC_OVER_GPIO_CS_PIN
+               int "GPIO CS (Chip-Select) pin"
+               default 7
+
+       endmenu
 endef
 
 define KernelPackage/mmc-over-gpio/description
index 96cba4916d60a4e4963333314f9ed1edfc09c837..1d310bdb5d58dcc81981ddafe74c92c015af394d 100644 (file)
@@ -1,9 +1,8 @@
-# OpenSSL configuration
-
-if PACKAGE_libopenssl
+menu "Configuration"
+       depends on PACKAGE_libopenssl
 
 config OPENSSL_ENGINE
        bool
        prompt "Crypto acceleration support"
 
-endif
+endmenu
index 9f80a98f3982c2ecb8e90fdc2ddf655fe06b556a..bdeb897e622aaa15b6638e442bf7498da31403b7 100644 (file)
@@ -46,6 +46,7 @@ $(call Package/openssl/Default)
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
+  MENU:=1
 endef
 
 define Package/libopenssl/description
index 4562fc8ef7695242b57cb4c591c70c0b179d6deb..afd192087751f32cf00aef2582cfc81f385396d9 100644 (file)
@@ -1,5 +1,9 @@
+menu "Configuration"
+       depends on PACKAGE_uboot-ifxmips
+
 config IFXMIPS_UBOOT_A800
        bool "add ARV452 Switch bringup hack"
-       depends on PACKAGE_uboot-ifxmips
        help
          Say Y, if you have a arv452 board (wav-281, A800, ..)
+
+endmenu
index 6b78c3d0af0045d75cd2b2316f0cb48f8db8f920..736e322c3c61a57aa1b4faffc7b5d1aa1ed3d7c4 100644 (file)
@@ -26,6 +26,7 @@ define Package/uboot-ifxmips
   DEPENDS:=@TARGET_ifxmips @BROKEN
   TITLE:=U-Boot for Infineon MIPS boards
   URL:=http://www.denx.de/wiki/U-Boot
+  MENU:=1
 endef
 
 define Build/Prepare
index e2c156d884b372177fe4bf52bd1f44692c477ed0..578b088646e5c7116d055c3670280c80b0900770 100644 (file)
@@ -1,7 +1,9 @@
+menu "Configuration"
+       depends on PACKAGE_uboot-lantiq
+
 config UBOOT_TARGET
        string "target"
        default "easy50712_DDR166M"
-       depends on PACKAGE_uboot-lantiq
        help
          The configuration reflects the settings for a dedicated board hardware.
          Select for Danube evaluation board easy50712_DDR166M .
@@ -9,7 +11,6 @@ config UBOOT_TARGET
 
 config UBOOT_RAMBOOT
        bool "Enable RAM boot image"
-       depends on PACKAGE_uboot-lantiq
        help
          Using the UART boot mode of the ROM code this image could be loaded to the RAM.
          While executing the image in the RAM the functionality of the uboot image can be 
@@ -30,6 +31,7 @@ config UBOOT_RAMBOOT_DDR_CONFIG
 
 config UBOOT_A800
        bool "add ARV452 Switch bringup hack"
-       depends on PACKAGE_uboot-lantiq
        help
          Say Y, if you have a arv452 board (wav-281, A800, ..)
+
+endmenu
index fc7c653716c73976fa1e5d0e8b7c910ddf70e1f3..d2a9cf2ad39662def09bdf816f37ef471b4abe60 100644 (file)
@@ -30,6 +30,7 @@ define Package/uboot-lantiq
   DEPENDS:=@TARGET_ifxmips
   TITLE:=U-Boot for Lantiq reference boards
   URL:=http://www.denx.de/wiki/U-Boot
+  MENU:=1
 endef
 
 define Build/Prepare
diff --git a/package/udev/Config.in b/package/udev/Config.in
new file mode 100644 (file)
index 0000000..9144c40
--- /dev/null
@@ -0,0 +1,92 @@
+# udev package config
+
+menu "Configuration"
+       depends on PACKAGE_udev
+
+config UDEV_DISABLE_LOGGING
+       bool "Disable udev logging to syslog"
+       default n
+       help
+        Disable logging of udev messages to the syslog.  If
+        unsure, choose the default N.
+
+config UDEV_ENABLE_DEBUG
+       bool "Enable debug build of the udev package"
+       default n
+       help
+        Compile in udev debug messages.  If unsure, choose
+        the default N.
+
+config UDEV_EXTRA_ata_id
+       bool "Install udev ata_id callout"
+       default y
+       help
+        ata_id - udev callout to read product/serial number
+        from ATA drives
+
+config UDEV_EXTRA_cdrom_id
+       bool "Install udev cdrom_id callout"
+       default y
+       help
+        cdrom_id - udev callout to determine the capabilities
+        of optical drives and media
+
+config UDEV_EXTRA_collect
+       bool "Install udev collect"
+       default n
+       help
+        Adds ID to the list governed by <checkpoint>
+
+config UDEV_EXTRA_edd_id
+       bool "Install udev edd_id callout"
+       default n
+       help
+        edd_id - udev callout to identify BIOS disk drives
+        via EDD
+
+config UDEV_EXTRA_firmware
+       bool "Install firmware support"
+       default n
+       help
+        udev firmware loader
+        via EDD
+
+config UDEV_EXTRA_floppy
+       bool "Install create_floppy_devices callout"
+       default n
+       help
+        create_floppy_devices - udev callout to create all
+        possible floppy device based on the CMOS type
+
+config UDEV_EXTRA_fstab_import
+       bool "Install fstab import"
+       default y
+       help
+        find matching entry in fstab and export it
+
+config UDEV_EXTRA_path_id
+       bool "Install udev path_id callout"
+       default y
+       help
+        path_id - udev callout to create a device path based
+        unique name for a device to implement the Linux
+        Persistent Device Naming scheme
+
+config UDEV_EXTRA_rule_generator
+       bool "Install udev rule_generator"
+       default y
+       help
+
+config UDEV_EXTRA_scsi_id
+       bool "Install udev scsi_id callout"
+       default y
+       help
+        scsi_id - retrieve and generate a unique SCSI identifier
+
+config UDEV_EXTRA_usb_id
+       bool "Install udev usb_id callout"
+       default y
+       help
+         usb_id - can find the unique id of USB devices
+
+endmenu
index f14fb3b8af879a5056a371650e696b6dcfd501a9..26bfe8bba2f1e24501bb12a002033adfc4eea619 100644 (file)
@@ -26,6 +26,7 @@ define Package/udev
   TITLE:=Dynamic device management subsystem
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
   MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
+  MENU:=1
 endef
 
 define Package/udev/description
@@ -34,7 +35,7 @@ define Package/udev/description
 endef
 
 define Package/udev/config
-       source "$(SOURCE)/udev-config.in"
+       source "$(SOURCE)/Config.in"
 endef
 
 udev-args-$(CONFIG_UDEV_DISABLE_LOGGING) += --disable-logging
diff --git a/package/udev/udev-config.in b/package/udev/udev-config.in
deleted file mode 100644 (file)
index c10bb9c..0000000
+++ /dev/null
@@ -1,94 +0,0 @@
-# udev package config
-
-menu "udev configuration"
-depends on PACKAGE_udev
-
-config UDEV_DISABLE_LOGGING
-       bool "Disable udev logging to syslog"
-       depends on PACKAGE_udev
-       default n
-       help
-        Disable logging of udev messages to the syslog.  If
-        unsure, choose the default N.
-
-config UDEV_ENABLE_DEBUG
-       bool "Enable debug build of the udev package"
-       depends on PACKAGE_udev
-       default n
-       help
-        Compile in udev debug messages.  If unsure, choose
-        the default N.
-
-config UDEV_EXTRA_ata_id
-       bool "Install udev ata_id callout"
-       default y
-       help
-        ata_id - udev callout to read product/serial number
-        from ATA drives
-
-config UDEV_EXTRA_cdrom_id
-       bool "Install udev cdrom_id callout"
-       default y
-       help
-        cdrom_id - udev callout to determine the capabilities
-        of optical drives and media
-
-config UDEV_EXTRA_collect
-       bool "Install udev collect"
-       default n
-       help
-        Adds ID to the list governed by <checkpoint>
-
-config UDEV_EXTRA_edd_id
-       bool "Install udev edd_id callout"
-       default n
-       help
-        edd_id - udev callout to identify BIOS disk drives
-        via EDD
-
-config UDEV_EXTRA_firmware
-       bool "Install firmware support"
-       default n
-       help
-        udev firmware loader
-        via EDD
-
-config UDEV_EXTRA_floppy
-       bool "Install create_floppy_devices callout"
-       default n
-       help
-        create_floppy_devices - udev callout to create all
-        possible floppy device based on the CMOS type
-
-config UDEV_EXTRA_fstab_import
-       bool "Install fstab import"
-       default y
-       help
-        find matching entry in fstab and export it
-
-config UDEV_EXTRA_path_id
-       bool "Install udev path_id callout"
-       default y
-       help
-        path_id - udev callout to create a device path based
-        unique name for a device to implement the Linux
-        Persistent Device Naming scheme
-
-config UDEV_EXTRA_rule_generator
-       bool "Install udev rule_generator"
-       default y
-       help
-
-config UDEV_EXTRA_scsi_id
-       bool "Install udev scsi_id callout"
-       default y
-       help
-        scsi_id - retrieve and generate a unique SCSI identifier
-
-config UDEV_EXTRA_usb_id
-       bool "Install udev usb_id callout"
-       default y
-       help
-         usb_id - can find the unique id of USB devices
-
-endmenu