update busybox to 1.8.2
authorTravis Kemen <thepeople@openwrt.org>
Thu, 29 Nov 2007 02:06:37 +0000 (02:06 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Thu, 29 Nov 2007 02:06:37 +0000 (02:06 +0000)
SVN-Revision: 9625

package/busybox/Makefile
package/busybox/patches/530-gunzip_src_fd.patch [deleted file]

index fc935d82940679e55cd7e896070539dd0407134a..e214bb3ca2c40fd8efcb592b84e20368126fa5b6 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.8.1
-PKG_RELEASE:=4
+PKG_VERSION:=1.8.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=c54554851d989328654a3eeab915a04f
+PKG_MD5SUM:=5794c6187c7cc8176c52b96af9bf2478
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/package/busybox/patches/530-gunzip_src_fd.patch b/package/busybox/patches/530-gunzip_src_fd.patch
deleted file mode 100644 (file)
index 3882628..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur a/archival/libunarchive/decompress_unzip.c b/archival/libunarchive/decompress_unzip.c
---- a/archival/libunarchive/decompress_unzip.c 2007-11-10 02:40:48.000000000 +0100
-+++ b/archival/libunarchive/decompress_unzip.c 2007-11-12 02:34:43.000000000 +0100
-@@ -1178,6 +1178,7 @@
-       ALLOC_STATE;
-       bytebuffer_max = 0x8000;
-       bytebuffer = xmalloc(bytebuffer_max);
-+      gunzip_src_fd = in;
-  again:
-       if (!check_header_gzip(PASS_STATE_ONLY)) {