[package] hostapd: Add 'identity' config option when eap_type is 'tls' on wpa_supplic...
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 3 Nov 2010 10:39:29 +0000 (10:39 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 3 Nov 2010 10:39:29 +0000 (10:39 +0000)
SVN-Revision: 23817

package/hostapd/Makefile
package/hostapd/files/wpa_supplicant.sh

index 172e89b259702e1c4a3c0dad20bbc123cfb1613e..6f3c639e69ca1db4981efb200b8160079afe93a8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20100705
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=2f1ce78bf78cecd7021385b04a4f55f22e76ab97
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 515fa6c0da3d8d645cd5ef234d1cfa93c3838144..6112517f37cb31b862368c78a40684c03b9c708a 100644 (file)
@@ -77,8 +77,10 @@ wpa_supplicant_setup_vif() {
                                tls)
                                        pairwise='pairwise=CCMP'
                                        group='group=CCMP'
+                                       config_get identity "$vif" identity
                                        config_get priv_key "$vif" priv_key
                                        config_get priv_key_pwd "$vif" priv_key_pwd
+                                       identity="identity=\"$identity\""
                                        priv_key="private_key=\"$priv_key\""
                                        priv_key_pwd="private_key_passwd=\"$priv_key_pwd\""
                                ;;