allow scan.mk to find python packages introduced in [8639]
authorNicolas Thill <nico@openwrt.org>
Thu, 6 Sep 2007 03:20:48 +0000 (03:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 6 Sep 2007 03:20:48 +0000 (03:20 +0000)
SVN-Revision: 8641

include/scan.mk

index 53b66f324a630d1849d549d987761568f106f3a1..819c8ca5959629e8631afbf969831ce54836d3e8 100644 (file)
@@ -34,7 +34,7 @@ endef
 
 $(FILELIST):
        rm -f tmp/info/.files-$(SCAN_TARGET)-*
-       $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|KernelPackage|Build(Package|Kernel))' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
+       $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|Build(Package|Kernel)|.+Package)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
 
 tmp/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
        ( \