add depend on iptables-extra and fix module loading for firewall
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 Apr 2005 18:46:55 +0000 (18:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Apr 2005 18:46:55 +0000 (18:46 +0000)
SVN-Revision: 558

openwrt/package/nocatsplash/Makefile
openwrt/package/nocatsplash/nocatsplash.control
openwrt/package/nocatsplash/patches/openwrt-firewall.patch [new file with mode: 0644]

index bb9cb4aeef425ce6deb21f4d3724ca3636893ecf..95e83c1f7953bca7871e10b7b8b5431446d46b39 100644 (file)
@@ -17,11 +17,12 @@ PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 $(DL_DIR)/$(PKG_SOURCE):
        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
        $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
+       $(PATCH) $(PKG_BUILD_DIR) ./patches
+       touch $(PKG_BUILD_DIR)/.patched
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -71,7 +72,7 @@ $(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
        $(IPKG) install $(PKG_IPK)
 
 source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
+prepare: $(PKG_BUILD_DIR)/.patched
 compile: $(PKG_IPK)
 install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
 
index 4bbcb4e35aeaca0608813b1efeb5fa3b50d00b3d..df10224845cec1d51a7ac144a98e58012dcbf1e7 100644 (file)
@@ -3,6 +3,7 @@ Priority: optional
 Section: net
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
+Depends: iptables-extra
 Description: NoCatSplash is an Open Public Network Gateway Daemon.
  It performs as a [captive/open/active] portal. When run on a gateway/router
  on a network, all web requests are redirected until the client either logs
diff --git a/openwrt/package/nocatsplash/patches/openwrt-firewall.patch b/openwrt/package/nocatsplash/patches/openwrt-firewall.patch
new file mode 100644 (file)
index 0000000..055b57f
--- /dev/null
@@ -0,0 +1,19 @@
+diff -urN NoCatSplash-0.92.old/libexec/iptables/initialize.fw NoCatSplash-0.92/libexec/iptables/initialize.fw
+--- NoCatSplash-0.92.old/libexec/iptables/initialize.fw        2002-12-27 11:44:41.000000000 +0100
++++ NoCatSplash-0.92/libexec/iptables/initialize.fw    2005-04-04 20:45:57.000000000 +0200
+@@ -28,13 +28,9 @@
+ # Load alllll the kernel modules we need.
+ #
+-rmmod ipchains > /dev/null 2>&1 # for RH 7.1 users.
+-for module in ip_tables ipt_REDIRECT ipt_MASQUERADE ipt_MARK ipt_REJECT  \
+-    ipt_TOS ipt_LOG iptable_mangle iptable_filter iptable_nat ip_nat_ftp \
+-    ip_conntrack ipt_mac ipt_state ipt_mark; do
+-
+-    modprobe $module
++for module in ipt_TOS ipt_mac; do
++    insmod $module
+ done