build: print missing dependency error to stderr
authorJonas Gorski <jogo@openwrt.org>
Thu, 18 Jul 2013 11:29:18 +0000 (11:29 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 18 Jul 2013 11:29:18 +0000 (11:29 +0000)
Allow to see the actual error even when compiling with V=w/V=1 only.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37388

include/package-ipkg.mk

index 696de156cfa98259f0d9754b8fee965f81a137b6..522a1de15f004db26bb1d21a91b73f2cdcae7c00 100644 (file)
@@ -64,8 +64,8 @@ ifneq ($(PKG_NAME),toolchain)
                                echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
                done; \
                if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \
-                       echo "Package $(1) is missing dependencies for the following libraries:"; \
-                       cat "$(PKG_INFO_DIR)/$(1).missing"; \
+                       echo "Package $(1) is missing dependencies for the following libraries:" >&2; \
+                       cat "$(PKG_INFO_DIR)/$(1).missing" >&2; \
                        false; \
                fi; \
        )