various minor package compilation issues
authorMike Baker <mbm@openwrt.org>
Wed, 6 Jun 2007 23:53:32 +0000 (23:53 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 6 Jun 2007 23:53:32 +0000 (23:53 +0000)
SVN-Revision: 7513

libs/apr/Makefile
libs/libjpeg/Makefile
net/nagios/Makefile

index 27bd72a0805bf6e626be1b751688a12a5c8e1499..5385939d9ecf27294e45474b78e0a24d40ffa8e0 100644 (file)
@@ -72,7 +72,7 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
 endef
 
 define Build/UninstallDev
-       rm      $(STAGING_DIR)/usr/bin/apr-config \
+       -rm     $(STAGING_DIR)/usr/bin/apr-config \
                $(STAGING_DIR)/usr/include/apr-0/{apr_allocator.h,apr_atomic.h,apr_compat.h,apr_dso.h,apr_env.h,apr_errno.h,apr_file_info.h,apr_file_io.h,apr_fnmatch.h,apr_general.h,apr_getopt.h,apr_global_mutex.h,apr.h,apr_hash.h,apr_inherit.h,apr_lib.h,apr_mmap.h,apr_network_io.h,apr_poll.h,apr_pools.h,apr_portable.h,\apr_proc_mutex.h,\apr_ring.h,apr_shm.h,apr_signal.h,apr_strings.h,apr_support.h,apr_tables.h,apr_thread_cond.h,apr_thread_mutex.h,apr_thread_proc.h,apr_thread_rwlock.h,apr_time.h,apr_user.h,apr_version.h,apr_want.h} \
                $(STAGING_DIR)/usr/lib/libapr-0* \
                $(STAGING_DIR)/usr/share/build/{apr_rules.mk,libtool,make_exports.awk,make_var_export.awk,mkdir.sh}
                $(STAGING_DIR)/usr/include/apr-0/{apr_allocator.h,apr_atomic.h,apr_compat.h,apr_dso.h,apr_env.h,apr_errno.h,apr_file_info.h,apr_file_io.h,apr_fnmatch.h,apr_general.h,apr_getopt.h,apr_global_mutex.h,apr.h,apr_hash.h,apr_inherit.h,apr_lib.h,apr_mmap.h,apr_network_io.h,apr_poll.h,apr_pools.h,apr_portable.h,\apr_proc_mutex.h,\apr_ring.h,apr_shm.h,apr_signal.h,apr_strings.h,apr_support.h,apr_tables.h,apr_thread_cond.h,apr_thread_mutex.h,apr_thread_proc.h,apr_thread_rwlock.h,apr_time.h,apr_user.h,apr_version.h,apr_want.h} \
                $(STAGING_DIR)/usr/lib/libapr-0* \
                $(STAGING_DIR)/usr/share/build/{apr_rules.mk,libtool,make_exports.awk,make_var_export.awk,mkdir.sh}
index 586786d6e1ed270a4d0a8839d2f3589cf00e87fa..4d5d62bcef921fe529f6a1a618e761fa22436a6b 100644 (file)
@@ -66,7 +66,8 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                exec_prefix="$(PKG_INSTALL_DIR)/usr" \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                exec_prefix="$(PKG_INSTALL_DIR)/usr" \
-               all install-headers install-lib install
+               all install-headers install-lib install \
+               LIBTOOL="./libtool --tag=CC"
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
index 7f4a8c598715d8ced45360cb003ea3a25995d3d0..dada35bf9211471a258c4a772106dea148dc7a11 100644 (file)
@@ -38,7 +38,8 @@ endef
 define Build/Configure
        $(call Build/Configure/Default,\
                --with-nagios-user="root" \
 define Build/Configure
        $(call Build/Configure/Default,\
                --with-nagios-user="root" \
-               --with-nagios-group="root" \
+               --with-nagios-group="root", \
+               LIBS="-lnotimpl" \
        )
 endef
 
        )
 endef