[ar71xx] rename RouterStation stuff, and add machine type for the LSX board
authorGabor Juhos <juhosg@openwrt.org>
Fri, 19 Dec 2008 19:17:53 +0000 (19:17 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 19 Dec 2008 19:17:53 +0000 (19:17 +0000)
SVN-Revision: 13694

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c [deleted file]
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c [new file with mode: 0644]
target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h

index f091cdf58aa573fab9f572de1e4e155e7a022a38..6fe93339632b0949431c70f98a96028dd8f45516 100644 (file)
@@ -8,8 +8,8 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
-CONFIG_AR71XX_MACH_ROUTERSTATION=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
index 566c8cda51c832e4af95abd1671b8fd4cac07ce9..5cb344df2d9374b51c3cf787a1efc5b2f3e66b32 100644 (file)
@@ -8,8 +8,8 @@ CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
-CONFIG_AR71XX_MACH_ROUTERSTATION=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
index 077260dd9c43ab049eb662a40c8847cd6ae4d82c..17eafa13d7578001668ba530c75086cbfbe00e66 100644 (file)
@@ -9,6 +9,7 @@ CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
index 87af166d5e5cf8a59f5cefb0b1ffbb835bd68229..8379aedab1aad2329e230d7caa4be675e2787575 100644 (file)
@@ -114,7 +114,8 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
 #define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
 #define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
-#define AR71XX_MACH_ROUTERSTATION 9    /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_RS    9       /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_LSX   10      /* Ubiquiti LSX */
 
 /*
  * PLL block
 
 /*
  * PLL block
index d16fdb82408c249755829b9f5c2ad663e3923f37..66500a94bd6eb6e494a368ca3452dd1e5b9e084d 100644 (file)
@@ -31,8 +31,8 @@ config AR71XX_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        default y
 
        bool "TRENDnet TEW-632BRP support"
        default y
 
-config AR71XX_MACH_ROUTERSTATION
-       bool "Ubiquiti RouterStation support"
+config AR71XX_MACH_UBNT
+       bool "Ubiquiti AR71xx based boards support"
        default y
 
 endmenu
        default y
 
 endmenu
index f53dc9daf1da3dd90ed5714c4e53b8878b511a18..902cbc353f147bed49783d6cc022303fc692fcd5 100644 (file)
@@ -14,6 +14,6 @@ obj-$(CONFIG_AR71XX_MACH_AP83)                += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
-obj-$(CONFIG_AR71XX_MACH_ROUTERSTATION)        += mach-routerstation.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
+obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-routerstation.c
deleted file mode 100644 (file)
index a8de711..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-/*
- *  Ubiquiti RouterStation support
- *
- *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
- *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/platform_device.h>
-#include <linux/spi/spi.h>
-#include <linux/spi/flash.h>
-
-#include <asm/mips_machine.h>
-#include <asm/mach-ar71xx/ar71xx.h>
-#include <asm/mach-ar71xx/pci.h>
-#include <asm/mach-ar71xx/platform.h>
-
-static struct spi_board_info routerstation_spi_info[] = {
-       {
-               .bus_num        = 0,
-               .chip_select    = 0,
-               .max_speed_hz   = 25000000,
-               .modalias       = "m25p80",
-       }
-};
-
-static void __init routerstation_setup(void)
-{
-       ar71xx_add_device_spi(NULL, routerstation_spi_info,
-                                       ARRAY_SIZE(routerstation_spi_info));
-}
-
-MIPS_MACHINE(AR71XX_MACH_ROUTERSTATION, "Ubiquiti RouterStation",
-                                       routerstation_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c
new file mode 100644 (file)
index 0000000..b1b18f9
--- /dev/null
@@ -0,0 +1,37 @@
+/*
+ *  Ubiquiti RouterStation support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static struct spi_board_info routerstation_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+       }
+};
+
+static void __init routerstation_setup(void)
+{
+       ar71xx_add_device_spi(NULL, routerstation_spi_info,
+                                       ARRAY_SIZE(routerstation_spi_info));
+}
+
+MIPS_MACHINE(AR71XX_MACH_UBNT_RS, "Ubiquiti RouterStation",
+                                 routerstation_setup);
index 87af166d5e5cf8a59f5cefb0b1ffbb835bd68229..8379aedab1aad2329e230d7caa4be675e2787575 100644 (file)
@@ -114,7 +114,8 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
 #define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
 #define AR71XX_MACH_AW_NR580   6       /* AzureWave AW-NR580 */
 #define AR71XX_MACH_AP83       7       /* Atheros AP83 */
 #define AR71XX_MACH_TEW_632BRP 8       /* TRENDnet TEW-632BRP */
-#define AR71XX_MACH_ROUTERSTATION 9    /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_RS    9       /* Ubiquiti RouterStation */
+#define AR71XX_MACH_UBNT_LSX   10      /* Ubiquiti LSX */
 
 /*
  * PLL block
 
 /*
  * PLL block