[package] get the enable/disable ipv6 configure option from the build system, do...
authorFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 11:57:29 +0000 (11:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 26 Jul 2009 11:57:29 +0000 (11:57 +0000)
SVN-Revision: 17009

24 files changed:
lang/php4/Makefile
lang/php5/Makefile
lang/python/Makefile
lang/ruby/Makefile
libs/apr/Makefile
libs/curl/Makefile
libs/net-snmp/Makefile
libs/ptlib/Makefile
libs/pwlib/Makefile
multimedia/ffmpeg/Makefile
net/bind/Makefile
net/elinks/Makefile
net/hiawatha/Makefile
net/ipsec-tools/Makefile
net/irssi-glib1/Makefile
net/irssi/Makefile
net/ngrep/Makefile
net/quagga-unstable/Makefile
net/quagga/Makefile
net/rsync/Makefile
net/tcpdump/Makefile
net/znc/Makefile
sound/mpd/Makefile
utils/sane-backends/Makefile

index 7303af34efcda5ecb2b1f6039adaa6623dedfa38..51d48c20c06bf488d3cdb5ca98dae3e5cdb5b33d 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php4
 PKG_VERSION:=4.4.7
 
 PKG_NAME:=php4
 PKG_VERSION:=4.4.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=php-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://fr.php.net/distributions/
 
 PKG_SOURCE:=php-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://fr.php.net/distributions/
@@ -157,7 +157,6 @@ PKG_CONFIGURE_OPTS:= \
        --without-pear \
        \
        --with-config-file-path=/etc \
        --without-pear \
        \
        --with-config-file-path=/etc \
-       --disable-ipv6 \
        --enable-magic-quotes \
        --enable-memory-limit \
        --disable-overload \
        --enable-magic-quotes \
        --enable-memory-limit \
        --disable-overload \
index 2af653e2b88a9383a79735d1e110d7a7ed458cc2..ba7d7195c27aa210aa979d8eec0ebe7ae914432c 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006,2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.2.6
 
 PKG_NAME:=php
 PKG_VERSION:=5.2.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
@@ -203,7 +203,6 @@ PKG_CONFIGURE_OPTS:= \
        --without-pear \
        \
        --with-config-file-path=/etc \
        --without-pear \
        \
        --with-config-file-path=/etc \
-       --disable-ipv6 \
        --enable-magic-quotes \
        --enable-memory-limit \
        --disable-short-tags \
        --enable-magic-quotes \
        --enable-memory-limit \
        --disable-short-tags \
index a985babfbd15cd6502e19c1b0efac6981927c6e5..24a1b4ce7f999be268178e12d5d552411a389b14 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python
 PKG_VERSION:=2.6.1
 
 PKG_NAME:=python
 PKG_VERSION:=2.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
@@ -126,7 +126,6 @@ define Build/Compile
        $(call Build/Configure/Default, \
                --sysconfdir=/etc \
                --disable-shared \
        $(call Build/Configure/Default, \
                --sysconfdir=/etc \
                --disable-shared \
-               --disable-ipv6 \
                --without-cxx-main \
                --with-threads \
                --with-system-ffi \
                --without-cxx-main \
                --with-threads \
                --with-system-ffi \
index 1f0ff0ce8b8cc01a70219880f205eee08ba9dceb..a3093fc445ff8b30ab15d66257178cdaecd6846b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ruby
 PKG_VERSION:=1.8.6-p287
 
 PKG_NAME:=ruby
 PKG_VERSION:=1.8.6-p287
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/1.8/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/1.8/
@@ -178,7 +178,6 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-rpath \
        --enable-shared \
        --enable-static \
        --disable-rpath \
-       --enable-ipv6 \
        --enable-wide-getaddrinfo \
 
 CONFIGURE_VARS += \
        --enable-wide-getaddrinfo \
 
 CONFIGURE_VARS += \
index 94f7426bced624b426381c03466a871d42696370..85e5ce061f21a19ce18fa7df2cad514f7b010238 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apr
 PKG_VERSION:=1.2.9
 
 PKG_NAME:=apr
 PKG_VERSION:=1.2.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://apache.d-s-s-p.de/apr/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://apache.d-s-s-p.de/apr/
@@ -30,8 +30,7 @@ endef
 TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --with-devrandom=/dev/urandom \
 TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --with-devrandom=/dev/urandom \
-       --disable-dso \
-       --enable-ipv6
+       --disable-dso
 
 CONFIGURE_VARS += \
        apr_cv_process_shared_works=no \
 
 CONFIGURE_VARS += \
        apr_cv_process_shared_works=no \
index 574d2484804fb0db9eddc14c800792f68415f87c..e1420e8fe6b010eac41f96980ca671bb543bb86d 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.19.5
 
 PKG_NAME:=curl
 PKG_VERSION:=7.19.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
@@ -57,7 +57,6 @@ CONFIGURE_ARGS += \
        --enable-file \
        --enable-ftp \
        --enable-http \
        --enable-file \
        --enable-ftp \
        --enable-http \
-       --enable-ipv6 \
        --disable-ares \
        --disable-debug \
        --disable-dict \
        --disable-ares \
        --disable-debug \
        --disable-dict \
index 2c374ddc7ea2334013877d5b4e8036c1e62fc0c8..c960c35e8eaa4d966d9d176bec9eefd9fcfef54c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.4.2.1
 
 PKG_NAME:=net-snmp
 PKG_VERSION:=5.4.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/net-snmp
@@ -150,7 +150,6 @@ TARGET_CFLAGS += $(FPIC)
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
-       --enable-ipv6 \
        --with-endianness=little \
        --with-logfile=/var/log/snmpd.log \
        --with-persistent-directory=/usr/lib/snmp/ \
        --with-endianness=little \
        --with-logfile=/var/log/snmpd.log \
        --with-persistent-directory=/usr/lib/snmp/ \
index 795ba5a095430a56f2e043a709862a9c01f12e32..bac7a2e7317fc7bd93ea75b573c2b1d726364253 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006-2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ptlib
 PKG_VERSION:=2.2.1
 
 PKG_NAME:=ptlib
 PKG_VERSION:=2.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
 PKG_SOURCE_URL:=@SF/opalvoip
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
 PKG_SOURCE_URL:=@SF/opalvoip
@@ -52,7 +52,6 @@ CONFIGURE_ARGS += \
        --disable-ftp \
        --disable-http \
        --disable-httpsvc \
        --disable-ftp \
        --disable-http \
        --disable-httpsvc \
-       --disable-ipv6 \
        --disable-jabber \
        --disable-odbc \
        --disable-openldap \
        --disable-jabber \
        --disable-odbc \
        --disable-openldap \
index e181201a3f64cf723077c3ded45bed1309d2c23a..36c4ae6ebb46403910c322f2335456c1491a8125 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006-2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pwlib
 PKG_VERSION:=1.11.1
 
 PKG_NAME:=pwlib
 PKG_VERSION:=1.11.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
@@ -50,7 +50,6 @@ CONFIGURE_ARGS += \
        --disable-ftp \
        --enable-http \
        --disable-httpsvc \
        --disable-ftp \
        --enable-http \
        --disable-httpsvc \
-       --disable-ipv6 \
        --disable-jabber \
        --disable-openldap \
        --disable-openssl \
        --disable-jabber \
        --disable-openldap \
        --disable-openssl \
index 21369055b36b1abe4b2b47728bb4b325e2547d4c..35dba7c26643fcff2cfd4c0dbf0068820b4cb385 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=20080419
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=20080419
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-export-snapshot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 
 PKG_SOURCE:=$(PKG_NAME)-export-snapshot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
@@ -176,13 +176,6 @@ FFMPEG_CONFIGURE_PROTOCOLS:= \
                $(if $(CONFIG_FFMPEG_PROTOCOL_$(c)),--enable-protocol="$(c)") \
        )
 
                $(if $(CONFIG_FFMPEG_PROTOCOL_$(c)),--enable-protocol="$(c)") \
        )
 
-ifneq ($(CONFIG_FFMPEG_PROTOCOL_IPv6),)
-       FFMPEG_CONFIGURE_IPv6:= --enable-ipv6
-else
-       FFMPEG_CONFIGURE_IPv6:= --disable-ipv6
-endif
-
-
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
@@ -221,7 +214,6 @@ define Build/Configure
                --disable-bsfs \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS) \
                --disable-bsfs \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS) \
-               $(FFMPEG_CONFIGURE_IPv6) \
        )
 endef
 
        )
 endef
 
index 5432bf799039736e6454b4e0c1e2e45d41d25d63..a5bad70a78614e111a9d40e2379c7239be0a8b59 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
 PKG_VERSION:=9.5.0-P1
 
 PKG_NAME:=bind
 PKG_VERSION:=9.5.0-P1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -81,7 +81,6 @@ export BUILD_CC="$(TARGET_CC)"
 CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static \
 CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static \
-               --enable-ipv6 \
                --with-randomdev="/dev/urandom" \
                --disable-threads \
                --with-openssl="$(STAGING_DIR)/usr" \
                --with-randomdev="/dev/urandom" \
                --disable-threads \
                --with-openssl="$(STAGING_DIR)/usr" \
index 4e94759297b66fd5abb63375ec5eb67ff722cf0c..d85027a12dc173fac8b1152fd502a8d549ca2a43 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elinks
 PKG_VERSION:=0.11.6
 
 PKG_NAME:=elinks
 PKG_VERSION:=0.11.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://elinks.or.cz/download
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://elinks.or.cz/download
@@ -79,7 +79,6 @@ define Build/Configure
                         --without-spidermonkey\
                         --without-x\
                         --without-zlib \
                         --without-spidermonkey\
                         --without-x\
                         --without-zlib \
-                        --disable-ipv6 \
        );
 endef
 
        );
 endef
 
index 47b0374d82aa659516e1d97c25094b386914a435..374554fb5cc7455773f69c7b4ae6d7fc95218ca1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hiawatha
 PKG_VERSION:=6.15
 
 PKG_NAME:=hiawatha
 PKG_VERSION:=6.15
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hiawatha-webserver.org/files/
@@ -32,8 +32,7 @@ endef
 
 CONFIGURE_ARGS+= \
        --disable-cache \
 
 CONFIGURE_ARGS+= \
        --disable-cache \
-       --disable-ssl \
-       --disable-ipv6
+       --disable-ssl
 
 CONFIGURE_VARS+= \
        ac_cv_file__dev_urandom=yes
 
 CONFIGURE_VARS+= \
        ac_cv_file__dev_urandom=yes
index d2b7f0441f5d22a4be7a1c6a4407a39596ae3933..9267a742bd9828394ee51dbbbceff4153754557b 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ipsec-tools
 PKG_VERSION:=0.7.2
 
 PKG_NAME:=ipsec-tools
 PKG_VERSION:=0.7.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ipsec-tools
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ipsec-tools
@@ -38,8 +38,7 @@ CONFIGURE_ARGS += \
        --enable-hybrid \
        --enable-security-context=no \
        --enable-natt \
        --enable-hybrid \
        --enable-security-context=no \
        --enable-natt \
-       --enable-adminport \
-       --enable-ipv6
+       --enable-adminport
 
 define Build/Prepare
        $(call Build/Prepare/Default)
 
 define Build/Prepare
        $(call Build/Prepare/Default)
index 8576d124a6a2a38e60b90e422bfa064b275f9a5e..9752fe6264e3159261dc178dcefea2e3c6286f0d 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=irssi-glib1
 PKG_VERSION:=0.8.10
 
 PKG_NAME:=irssi-glib1
 PKG_VERSION:=0.8.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=irssi-$(PKG_VERSION)a.tar.bz2
 PKG_SOURCE_URL:=http://irssi.org/files/
 
 PKG_SOURCE:=irssi-$(PKG_VERSION)a.tar.bz2
 PKG_SOURCE_URL:=http://irssi.org/files/
@@ -39,7 +39,6 @@ define Build/Configure
                --without-file-offset-size \
                --without-ssl \
                --disable-ssl \
                --without-file-offset-size \
                --without-ssl \
                --disable-ssl \
-               --enable-ipv6 \
                --disable-proxy \
        )
 endef
                --disable-proxy \
        )
 endef
index 126fe063cc01ddb551425fed99cd543fc3b584ba..37cec9222e57d94a610471ac10cf0b648d487be9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=irssi
 PKG_VERSION:=0.8.13
 
 PKG_NAME:=irssi
 PKG_VERSION:=0.8.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://irssi.org/files/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://irssi.org/files/
@@ -62,7 +62,6 @@ $(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
                --without-terminfo \
                --without-bot \
                --without-file-offset-size \
                --without-terminfo \
                --without-bot \
                --without-file-offset-size \
-               --disable-ipv6 \
                --disable-proxy \
                $(3))
        $(MAKE) -C $(PKG_BUILD_DIR)
                --disable-proxy \
                $(3))
        $(MAKE) -C $(PKG_BUILD_DIR)
index c02170adc33a8501d497482a61425b11cf37d13e..5321f0412907ee603283266f7223dffb7d5666fd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ngrep
 PKG_VERSION:=1.45
 
 PKG_NAME:=ngrep
 PKG_VERSION:=1.45
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ngrep
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ngrep
@@ -39,7 +39,6 @@ define Build/Configure
                --with-pcap-includes=$(STAGING_DIR)/usr/include \
                --enable-pcre \
                --with-pcre=$(STAGING_DIR)/usr \
                --with-pcap-includes=$(STAGING_DIR)/usr/include \
                --enable-pcre \
                --with-pcre=$(STAGING_DIR)/usr \
-               --enable-ipv6 \
                --disable-dropprivs \
                ,\
                LDFLAGS="$(TARGET_LDFLAGS) -lpcre" \
                --disable-dropprivs \
                ,\
                LDFLAGS="$(TARGET_LDFLAGS) -lpcre" \
index 087846dad5bde56237fd67bb392ce13b083e6193..9fa877f74522e32a8248183dd4e36cf6987bfc1b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga-unstable
 PKG_VERSION:=0.99.14
 
 PKG_NAME:=quagga-unstable
 PKG_VERSION:=0.99.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=3a075fd5e26ec6d52f4a51b14a2d3c2c
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
 PKG_MD5SUM:=3a075fd5e26ec6d52f4a51b14a2d3c2c
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
@@ -97,7 +97,6 @@ define Build/Configure
                --sysconfdir=/etc/quagga/ \
                --enable-shared \
                --disable-static \
                --sysconfdir=/etc/quagga/ \
                --enable-shared \
                --disable-static \
-               --enable-ipv6 \
                --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
                --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
index 903f8da5cd3b8b733be59e217bf959d3380d72fb..0815ebab4f3746c9b96b06d49090b5816b9975eb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quagga
 PKG_VERSION:=0.98.6
 
 PKG_NAME:=quagga
 PKG_VERSION:=0.98.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MD5SUM:=b0d4132039953a0214256873b7d23d68
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
 PKG_MD5SUM:=b0d4132039953a0214256873b7d23d68
 
 PKG_SOURCE_URL:=http://www.quagga.net/download/ \
@@ -96,7 +96,6 @@ define Build/Configure
                --sysconfdir=/etc/quagga/ \
                --enable-shared \
                --disable-static \
                --sysconfdir=/etc/quagga/ \
                --enable-shared \
                --disable-static \
-               --enable-ipv6 \
                --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
                --enable-vtysh \
                --enable-user=quagga \
                --enable-group=quagga \
index 6589ac30585512445d5fe8724b202c632ff3a41e..8fc225edf2778709d68325c6f6b8fc14fb3e9a8e 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.0.3
 
 PKG_NAME:=rsync
 PKG_VERSION:=3.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://rsync.samba.org/ftp/rsync
@@ -41,7 +41,6 @@ endef
 CONFIGURE_ARGS += \
        --with-included-popt=no \
        --disable-debug \
 CONFIGURE_ARGS += \
        --with-included-popt=no \
        --disable-debug \
-       --disable-ipv6 \
        --disable-locale \
        --disable-xattr-support \
        --disable-acl-support \
        --disable-locale \
        --disable-xattr-support \
        --disable-acl-support \
index 587806cc733ecd30934f494137624f4bee699c27..41c88c86a005776dffd943493f14f0f84580bf8e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcpdump
 PKG_VERSION:=3.9.8
 
 PKG_NAME:=tcpdump
 PKG_VERSION:=3.9.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
@@ -30,7 +30,6 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-ipv6 \
                --without-crypto \
                , \
                BUILD_CC="$(TARGET_CC)" \
                --without-crypto \
                , \
                BUILD_CC="$(TARGET_CC)" \
index 72e69fa54c8add5375f54e0035241c95926e1f19..d04dbefbad5e43ea7de8638f615799f126a5a816 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=znc
 PKG_VERSION:=0.070
 
 PKG_NAME:=znc
 PKG_VERSION:=0.070
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/znc
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/znc
@@ -42,7 +42,6 @@ CONFIGURE_VARS += \
 CONFIGURE_ARGS += \
        $(TARGET_CONFIGURE_OPTS) \
        --disable-perl \
 CONFIGURE_ARGS += \
        $(TARGET_CONFIGURE_OPTS) \
        --disable-perl \
-       --disable-ipv6 \
 
 MAKE_FLAGS += \
        CXX="g++-uc"
 
 MAKE_FLAGS += \
        CXX="g++-uc"
index e0732468bc8e236010effb2c33ed1241418dd78f..30165ce1fe1ec0bddcad8051c9cb77b0c4dec563 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
 PKG_VERSION:=0.15.1
 
 PKG_NAME:=mpd
 PKG_VERSION:=0.15.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/musicpd
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/musicpd
@@ -60,7 +60,6 @@ define Build/Configure
                --disable-mpc \
                --disable-aac \
                --disable-lsr \
                --disable-mpc \
                --disable-aac \
                --disable-lsr \
-               --disable-ipv6 \
                --disable-ao \
                --disable-mvp \
                --disable-lametest \
                --disable-ao \
                --disable-mvp \
                --disable-lametest \
index cfc8cd8ba58dfdfef4303b0165f2530fcf9fde2d..fc6bf3dd926a788a5aead31dc0c12efb679f2727 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sane-backends
 PKG_VERSION:=1.0.19
 
 PKG_NAME:=sane-backends
 PKG_VERSION:=1.0.19
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
@@ -68,7 +68,6 @@ endef
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
-       --disable-ipv6 \
        --disable-translations \
        --without-gphoto2 \
        --disable-debug \
        --disable-translations \
        --without-gphoto2 \
        --disable-debug \