cleanup, fix usage of cflags
authorFelix Fietkau <nbd@openwrt.org>
Tue, 31 Jul 2007 10:01:16 +0000 (10:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 31 Jul 2007 10:01:16 +0000 (10:01 +0000)
SVN-Revision: 8259

admin/osiris/Makefile

index d3037e948bd8f3ff5d716fb93fb832d1b1df0098..73da8e6101241cc5173c00470e4ea093f91c67a0 100644 (file)
@@ -30,22 +30,16 @@ define Package/osirisd
   URL:=http://www.hostintegrity.com/osiris
 endef
 
   URL:=http://www.hostintegrity.com/osiris
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-osiris-user=root \
-               --with-root-dir=/var/lib/osiris \
-               --with-readline=no, \
-               ac_cv_openssldir="$(STAGING_DIR)/usr" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-osiris-user=root \
+       --with-root-dir=/var/lib/osiris \
+       --with-readline=no, \
+       ac_cv_openssldir="$(STAGING_DIR)/usr"
 
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
+MAKE_FLAGS += \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INTERACTIVE=0 \
                all install
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INTERACTIVE=0 \
                all install
-endef
 
 define Package/osirisd/install 
        $(INSTALL_DIR) $(1)/usr/sbin
 
 define Package/osirisd/install 
        $(INSTALL_DIR) $(1)/usr/sbin