[packages] stunnel: cleanup
authorNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 12:07:33 +0000 (12:07 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 12:07:33 +0000 (12:07 +0000)
SVN-Revision: 22473

net/stunnel/Makefile

index 59acf976636fc55c5da574e773b2f56fa9940210..98dd5d0d2b87a405d6220f80c68f955f50dd02ef 100644 (file)
@@ -11,9 +11,9 @@ PKG_NAME:=stunnel
 PKG_VERSION:=4.33
 PKG_RELEASE:=1
 
-PKG_MD5SUM:=559a864066d8cc4afd8a97682c90d41c
 PKG_SOURCE_URL:=http://www.stunnel.org/download/stunnel/src/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=559a864066d8cc4afd8a97682c90d41c
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
@@ -40,13 +40,10 @@ define Package/stunnel/conffiles
 /etc/stunnel/stunnel.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-random=/dev/urandom \
-               --with-threads=fork \
-               --with-ssl=$(STAGING_DIR)/usr \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --with-random=/dev/urandom \
+       --with-threads=fork \
+       --with-ssl=$(STAGING_DIR)/usr \
 
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)/etc/stunnel