fix package name in template call, remove unneeded patch,
authorNicolas Thill <nico@openwrt.org>
Wed, 14 Dec 2005 23:01:47 +0000 (23:01 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 14 Dec 2005 23:01:47 +0000 (23:01 +0000)
don't use PKG_INSTALL_DIR since upstream does not provide a make install target,
add configurable init script,
add Id tag and target optimization cflags..

SVN-Revision: 2674

openwrt/package/vrrpd/Config.in [changed mode: 0755->0644]
openwrt/package/vrrpd/Makefile [changed mode: 0755->0644]
openwrt/package/vrrpd/files/vrrpd.default [new file with mode: 0644]
openwrt/package/vrrpd/files/vrrpd.init [new file with mode: 0644]
openwrt/package/vrrpd/ipkg/vrrpd.conffiles [new file with mode: 0644]
openwrt/package/vrrpd/ipkg/vrrpd.control [changed mode: 0755->0644]
openwrt/package/vrrpd/patches/01-honor-target_cc.patch [deleted file]

old mode 100755 (executable)
new mode 100644 (file)
index 793d3ed..767e2dd
@@ -3,10 +3,11 @@ config BR2_PACKAGE_VRRPD
        tristate
        default m if CONFIG_DEVEL
        help
-               VRRPd is an implementation of Virtual Router Redundancy
-               Protocol as specified in rfc2338.  VRRPd is interoperable with
-               other RFC-based VRRP implementations, including Cisco and
-               Juniper, and is included as a standard feature on ImageStream
-               routers.
-               
-               http://www.sourceforge.net/projects/vrrpd
+         VRRPd is an implementation of Virtual Router Redundancy
+         Protocol as specified in rfc2338.  VRRPd is interoperable with
+         other RFC-based VRRP implementations, including Cisco and
+         Juniper, and is included as a standard feature on ImageStream
+         routers.
+         
+         http://www.sourceforge.net/projects/vrrpd
+
old mode 100755 (executable)
new mode 100644 (file)
index 82ee36b..b4aa4e0
@@ -1,33 +1,35 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vrrpd
 PKG_VERSION:=1.0
 PKG_RELEASE:=1
-
 PKG_MD5SUM:=6d5066ea1a6ced817376ca0f54765447
-PKG_SOURCE_URL:=@SF/vrrpd
 
+PKG_SOURCE_URL:=@SF/vrrpd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,VRRPD,VRRPD,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,VRRPD,vrrpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       mkdir -p $(PKG_INSTALL_DIR)/usr/sbin
-       $(MAKE) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
-       install -m0755 $(PKG_BUILD_DIR)/vrrpd $(PKG_INSTALL_DIR)/usr/sbin/
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               DBG_OPT="" \
+               MAIN_OPT="$(TARGET_CFLAGS)" \
+               vrrpd
        touch $@
 
 $(IPKG_VRRPD):
-       mkdir -p $(IDIR_VRRPD)
-       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VRRPD)/
+       install -d -m0755 $(IDIR_VRRPD)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/vrrpd $(IDIR_VRRPD)/usr/sbin/
        $(RSTRIP) $(IDIR_VRRPD)
        $(IPKG_BUILD) $(IDIR_VRRPD) $(PACKAGE_DIR)
diff --git a/openwrt/package/vrrpd/files/vrrpd.default b/openwrt/package/vrrpd/files/vrrpd.default
new file mode 100644 (file)
index 0000000..0dfee0c
--- /dev/null
@@ -0,0 +1,4 @@
+ID=1
+IF=vlan1
+IP=10.0.0.1
+OPTIONS="-i $IF -v $ID $IP"
diff --git a/openwrt/package/vrrpd/files/vrrpd.init b/openwrt/package/vrrpd/files/vrrpd.init
new file mode 100644 (file)
index 0000000..5afc734
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+BIN=vrrpd
+DEFAULT=/etc/default/$BIN
+[ -f $DEFAULT ] && . $DEFAULT
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN_${IF}_${ID}.pid
+
+case $1 in
+ start)
+  $BIN $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/vrrpd/ipkg/vrrpd.conffiles b/openwrt/package/vrrpd/ipkg/vrrpd.conffiles
new file mode 100644 (file)
index 0000000..9680ca3
--- /dev/null
@@ -0,0 +1 @@
+/etc/default/vrrpd
old mode 100755 (executable)
new mode 100644 (file)
index 92cce30..435dda1
@@ -1,5 +1,4 @@
 Package: vrrpd
-Section: net
-Architecture: mipsel
 Priority: optional
-Description: VRRPd is an implementation of Virtual Router Redundancy Protocol as specified in rfc2338.
+Section: net
+Description: An implementation of the Virtual Router Redundancy Protocol
diff --git a/openwrt/package/vrrpd/patches/01-honor-target_cc.patch b/openwrt/package/vrrpd/patches/01-honor-target_cc.patch
deleted file mode 100644 (file)
index c750607..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urN orig/vrrpd-1.0/Makefile vrrpd-1.0/Makefile
---- orig/vrrpd-1.0/Makefile    2002-09-09 16:51:13.000000000 +0200
-+++ vrrpd-1.0/Makefile 2005-12-12 23:31:30.000000000 +0100
-@@ -15,7 +15,6 @@
- COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
- # set to compile with GCC
--CC=gcc
- CFLAGS= $(COMMON_CFLAGS) -Wall
- vrrpd : $(VRRPD_OBJS)