work around permission problems in the avrdude tarball - fixes avr32 compile error
authorFelix Fietkau <nbd@openwrt.org>
Wed, 8 Oct 2008 16:31:28 +0000 (16:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 8 Oct 2008 16:31:28 +0000 (16:31 +0000)
SVN-Revision: 12912

utils/avrdude/Makefile

index 8ba16085399c27ae4d63a01b18139fd7ce0d8fa8..adfa268c58d85ef8e5e2eca747a71932ed9b2a55 100644 (file)
@@ -30,6 +30,11 @@ define Package/avrdude/description
  AVRDUDE is a full featured program for programming Atmel's AVR CPU's.
 endef
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       chmod -R u+w $(PKG_BUILD_DIR)
+endef
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \