[packages] fix endianess issue in netcat
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 7 Feb 2009 02:33:24 +0000 (02:33 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 7 Feb 2009 02:33:24 +0000 (02:33 +0000)
SVN-Revision: 14427

net/netcat/Makefile
net/netcat/patches/001-netcat_flag_count.patch [new file with mode: 0644]

index 4354a978b063ab06a2e757c97636688e9f44b600..19906cc06caea3c59b1fb04529f1534ba3f634be 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netcat
 PKG_VERSION:=0.7.1
 
 PKG_NAME:=netcat
 PKG_VERSION:=0.7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/net/netcat/patches/001-netcat_flag_count.patch b/net/netcat/patches/001-netcat_flag_count.patch
new file mode 100644 (file)
index 0000000..44ee9e1
--- /dev/null
@@ -0,0 +1,22 @@
+Index: netcat-0.7.1/src/flagset.c
+===================================================================
+--- netcat-0.7.1.orig/src/flagset.c    2009-02-06 19:56:01.000000000 +0100
++++ netcat-0.7.1/src/flagset.c 2009-02-06 19:56:13.000000000 +0100
+@@ -134,7 +134,7 @@
+ int netcat_flag_count(void)
+ {
+-  register char c;
++  register unsigned char c;
+   register int i;
+   int ret = 0;
+@@ -154,7 +154,7 @@
+       Assumed that the bit number 1 is the sign, and that we will shift the
+       bit 1 (or the bit that takes its place later) until the the most right,
+       WHY it has to keep the wrong sign? */
+-      ret -= (c >> 7);
++      ret += (c >> 7);
+       c <<= 1;
+     }
+   }