fix kmod-hermes-* dependencies
authorNicolas Thill <nico@openwrt.org>
Tue, 28 Aug 2007 11:24:49 +0000 (11:24 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 28 Aug 2007 11:24:49 +0000 (11:24 +0000)
SVN-Revision: 8518

package/kernel/modules/wireless.mk

index ff5f08a..88b2bea 100644 (file)
@@ -116,9 +116,8 @@ $(eval $(call KernelPackage,net-hermes))
 define KernelPackage/net-hermes-pci
   TITLE:=Intersil Prism 2.5 PCI support
   DESCRIPTION:=Kernel modules for Intersil Prism 2.5 PCI support
-  DEPENDS:=@LINUX_2_6
-  KCONFIG:=CONFIG_PCI_HERMES
   DEPENDS:=kmod-net-hermes
+  KCONFIG:=CONFIG_PCI_HERMES
   SUBMENU:=$(WIMENU)
   FILES:=$(LINUX_DIR)/drivers/net/wireless/orinoco_pci.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,55,orinoco_pci)
@@ -129,9 +128,8 @@ $(eval $(call KernelPackage,net-hermes-pci))
 define KernelPackage/net-hermes-plx
   TITLE:=PLX9052 based PCI adaptor
   DESCRIPTION:=Kernel modules for Hermes in PLX9052 based PCI adaptors
-  DEPENDS:=@LINUX_2_6
-  KCONFIG:=CONFIG_PLX_HERMES
   DEPENDS:=kmod-net-hermes
+  KCONFIG:=CONFIG_PLX_HERMES
   SUBMENU:=$(WIMENU)
   FILES:=$(LINUX_DIR)/drivers/net/wireless/orinoco_plx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,55,orinoco_plx)