brcm63xx: move CPVA502+ to dts
authorJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:35:57 +0000 (15:35 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:35:57 +0000 (15:35 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44990

35 files changed:
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/dts/cpva502plus.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch
target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
target/linux/brcm63xx/profiles/telsey.mk

index 991e3636a6a79764a164ff0dde0a0c7e95cffac3..d9ec3ed7193eabf57cacff73b38d65776d51504b 100755 (executable)
@@ -192,6 +192,9 @@ brcm63xx_dt_detect() {
        "TECOM GW6200")
                board_name="g6200"
                ;;
+       "Telsey CVPA502+")
+               board_name="cpva502p"
+               ;;
        "Telsey CPVA642-type (CPA-ZNTE60T)")
                board_name="cpva642"
                ;;
@@ -216,9 +219,6 @@ brcm63xx_legacy_detect() {
        local board_name
 
        case "$1" in
-       CPVA502+)
-               board_name="cpva502p"
-               ;;
        MAGIC)
                board_name="magic"
                ;;
diff --git a/target/linux/brcm63xx/dts/cpva502plus.dts b/target/linux/brcm63xx/dts/cpva502plus.dts
new file mode 100644 (file)
index 0000000..3cb702d
--- /dev/null
@@ -0,0 +1,44 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "Telsey CPVA502+";
+       compatible = "telsey,cpva502+", "brcm,bcm6348";
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power_green {
+                       label = "CPVA502+:green:phone";
+                       gpios = <&gpio0 0 1>;
+               };
+
+               status {
+                       label = "CPVA502+:amber:link";
+                       gpios = <&gpio0 1 1>;
+               };
+       };
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index 0c164770a1a628caf312cfaf55ef01ae9a8721ad..d38ffe975f78332db4daec14d5b1038e6d2bdc4a 100755 (executable)
@@ -368,6 +368,8 @@ $(eval $(call ImageDTB,CFEDTB,SPW500V,SPW500V,spw500v,96348GW,6348))
 $(eval $(call ImageDTB,CFEDTB,GW6000,GW6000,gw6000,96348GW,6348))
 # Tecom GW6200
 $(eval $(call ImageDTB,CFEDTB,GW6200,GW6200,gw6200,96348GW,6348,--rsa-signature "$(shell printf '\x99')"))
+# Telsey CPVA502+
+$(eval $(call ImageDTB,Dummy,CPVA502PLUS,CVPA502PLUS,cpva502plus,CPVA502+,6348,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0"))
 # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
 $(eval $(call ImageDTB,CFEDTB,CPVA642,CPA-ZNTE60T,cpva642,CPVA642,6358,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0" --pad 4))
 # TP-Link TD-W8900GB
index 94a53e7cee1a4d3693bf2caf7dd641c92efbbb4e..756b6437de5b8d96473d90cc9ac215fd42fbd8d8 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1216,6 +1238,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+       { .compatible = "tecom,gw6000", .data = &board_gw6000, },
+       { .compatible = "tecom,gw6200", .data = &board_gw6200, },
++      { .compatible = "telsey,cpva502+", .data = &board_CPVA502plus, },
+       { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
+       { .compatible = "usr,9108", .data = &board_96348gw_a, },
+ #endif
index f9c3b73d9c20c2715118c01d55de05358b20f602..48cfd23019fae134d4cb1357553195faa335372b 100644 (file)
@@ -81,7 +81,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -1258,6 +1315,7 @@ static struct of_device_id const bcm963x
+@@ -1259,6 +1316,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 0979de726b1c9e19640a64935b6ab3897c4d60de..66490312a9c8d5a1b88cde24b4c673a69061040c 100644 (file)
@@ -64,7 +64,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
-@@ -1315,6 +1356,7 @@ static struct of_device_id const bcm963x
+@@ -1316,6 +1357,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 11e4ff4be56ccbfc9d3ebbb9d974e647f68370b0..0ce7e0a2628c8b7fc202833cec588be008fb73e4 100644 (file)
@@ -40,7 +40,7 @@
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -1475,6 +1501,7 @@ static struct of_device_id const bcm963x
+@@ -1476,6 +1502,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 4ac9d2db5cca8e9826d4fe725e02a30b0bf8c8a9..80d5d49c0bd04276315ba2f4bb6ab56f23a52ca6 100644 (file)
@@ -45,7 +45,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1504,6 +1535,7 @@ static struct of_device_id const bcm963x
+@@ -1505,6 +1536,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 68c1dc36969da30e598b77fa9dae82969808e07d..e4d8f4b2829452ba09fd726716b3c0ae7666915c 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -1546,6 +1618,9 @@ static struct of_device_id const bcm963x
+@@ -1547,6 +1619,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index 280ac79f67e76862d8843b938ae2c1d4d464bafa..5bc7c792f1524cfb5bed9daf97251217642babac 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -1856,6 +1947,9 @@ static struct of_device_id const bcm963x
+@@ -1857,6 +1948,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index c83e5b7ae0dfb7c13a2afeab1297aa597eb4aa84..e33c7232a1f5e12fb24337f59da183b230efec4c 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2055,6 +2093,7 @@ static struct of_device_id const bcm963x
+@@ -2056,6 +2094,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index ca7ed5519c38dfb9f92f80b05fc04a113419642c..289e5ded18183799b967b7501e659612f55e5940 100644 (file)
@@ -75,7 +75,7 @@
        &board_963269bhr,
        &board_vw6339gu,
  #endif
-@@ -2237,6 +2298,7 @@ static struct of_device_id const bcm963x
+@@ -2238,6 +2299,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 803ccc9c3d31425cd0024bb5ae601a5915b16f05..6412188036f96a3b76fb280226743f6ffc301638 100644 (file)
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2296,6 +2358,7 @@ static struct of_device_id const bcm963x
+@@ -2297,6 +2359,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 8660a6dfcbed457f16328576d386bbd34a0dedb7..71e9532abfeb0988072cf826a8f41577ebf95616 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2358,6 +2413,7 @@ static struct of_device_id const bcm963x
+@@ -2359,6 +2414,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index e63b5e22203e1c382847993231a66385344348c6..3f3f0b0631bb5845401ab0947a0f4a90066ea5e6 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2414,6 +2469,7 @@ static struct of_device_id const bcm963x
+@@ -2415,6 +2470,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 8078200a9d2c40ed6f80ebca007fe3c2929fd3fb..1a61b59125ca8fe94654049994ebb7c1612f6008 100644 (file)
@@ -58,7 +58,7 @@
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2471,6 +2515,7 @@ static struct of_device_id const bcm963x
+@@ -2472,6 +2516,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 19d5807b33f3c43920d694abebc8cdb42fe58da0..1a83b0eed0c72882de4a64fc7586b3df440c5b47 100644 (file)
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2492,6 +2524,7 @@ static struct of_device_id const bcm963x
+@@ -2493,6 +2525,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index c9463f00973da9db90288d0ed222fe9a5cc79d3f..896ec8b1152d1e63d114e0002120ff9a858f05b8 100644 (file)
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2730,6 +2773,7 @@ static struct of_device_id const bcm963x
+@@ -2731,6 +2774,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 94a53e7cee1a4d3693bf2caf7dd641c92efbbb4e..756b6437de5b8d96473d90cc9ac215fd42fbd8d8 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1216,6 +1238,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "t-com,spw500v", .data = &board_spw500v, },
+       { .compatible = "tecom,gw6000", .data = &board_gw6000, },
+       { .compatible = "tecom,gw6200", .data = &board_gw6200, },
++      { .compatible = "telsey,cpva502+", .data = &board_CPVA502plus, },
+       { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
+       { .compatible = "usr,9108", .data = &board_96348gw_a, },
+ #endif
index f9c3b73d9c20c2715118c01d55de05358b20f602..48cfd23019fae134d4cb1357553195faa335372b 100644 (file)
@@ -81,7 +81,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -1258,6 +1315,7 @@ static struct of_device_id const bcm963x
+@@ -1259,6 +1316,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 0979de726b1c9e19640a64935b6ab3897c4d60de..66490312a9c8d5a1b88cde24b4c673a69061040c 100644 (file)
@@ -64,7 +64,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
-@@ -1315,6 +1356,7 @@ static struct of_device_id const bcm963x
+@@ -1316,6 +1357,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 11e4ff4be56ccbfc9d3ebbb9d974e647f68370b0..0ce7e0a2628c8b7fc202833cec588be008fb73e4 100644 (file)
@@ -40,7 +40,7 @@
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -1475,6 +1501,7 @@ static struct of_device_id const bcm963x
+@@ -1476,6 +1502,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 4ac9d2db5cca8e9826d4fe725e02a30b0bf8c8a9..80d5d49c0bd04276315ba2f4bb6ab56f23a52ca6 100644 (file)
@@ -45,7 +45,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1504,6 +1535,7 @@ static struct of_device_id const bcm963x
+@@ -1505,6 +1536,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index 68c1dc36969da30e598b77fa9dae82969808e07d..e4d8f4b2829452ba09fd726716b3c0ae7666915c 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -1546,6 +1618,9 @@ static struct of_device_id const bcm963x
+@@ -1547,6 +1619,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index 280ac79f67e76862d8843b938ae2c1d4d464bafa..5bc7c792f1524cfb5bed9daf97251217642babac 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -1856,6 +1947,9 @@ static struct of_device_id const bcm963x
+@@ -1857,6 +1948,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index c83e5b7ae0dfb7c13a2afeab1297aa597eb4aa84..e33c7232a1f5e12fb24337f59da183b230efec4c 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -2055,6 +2093,7 @@ static struct of_device_id const bcm963x
+@@ -2056,6 +2094,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index ca7ed5519c38dfb9f92f80b05fc04a113419642c..289e5ded18183799b967b7501e659612f55e5940 100644 (file)
@@ -75,7 +75,7 @@
        &board_963269bhr,
        &board_vw6339gu,
  #endif
-@@ -2237,6 +2298,7 @@ static struct of_device_id const bcm963x
+@@ -2238,6 +2299,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 803ccc9c3d31425cd0024bb5ae601a5915b16f05..6412188036f96a3b76fb280226743f6ffc301638 100644 (file)
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2296,6 +2358,7 @@ static struct of_device_id const bcm963x
+@@ -2297,6 +2359,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 8660a6dfcbed457f16328576d386bbd34a0dedb7..71e9532abfeb0988072cf826a8f41577ebf95616 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2358,6 +2413,7 @@ static struct of_device_id const bcm963x
+@@ -2359,6 +2414,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index e63b5e22203e1c382847993231a66385344348c6..3f3f0b0631bb5845401ab0947a0f4a90066ea5e6 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2414,6 +2469,7 @@ static struct of_device_id const bcm963x
+@@ -2415,6 +2470,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 8078200a9d2c40ed6f80ebca007fe3c2929fd3fb..1a61b59125ca8fe94654049994ebb7c1612f6008 100644 (file)
@@ -58,7 +58,7 @@
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2471,6 +2515,7 @@ static struct of_device_id const bcm963x
+@@ -2472,6 +2516,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 19d5807b33f3c43920d694abebc8cdb42fe58da0..1a83b0eed0c72882de4a64fc7586b3df440c5b47 100644 (file)
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2492,6 +2524,7 @@ static struct of_device_id const bcm963x
+@@ -2493,6 +2525,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index c9463f00973da9db90288d0ed222fe9a5cc79d3f..896ec8b1152d1e63d114e0002120ff9a858f05b8 100644 (file)
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2730,6 +2773,7 @@ static struct of_device_id const bcm963x
+@@ -2731,6 +2774,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index ba304eac7e4c5fe619cb804ab47bab40d81e6a73..ca0f0746f7b5eceb832764d50dec5e2aca50ad5f 100644 (file)
@@ -41,7 +41,7 @@
        &board_HW520,
        &board_HW553,
        &board_HW556_A,
-@@ -2762,6 +2789,7 @@ static struct of_device_id const bcm963x
+@@ -2763,6 +2790,7 @@ static struct of_device_id const bcm963x
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
index 5e2359aa0df3d7bb744933d5a3cb7b601d10c069..a8ad31eb1f5e2e22696648e807af1dc4d582a3b0 100644 (file)
@@ -5,6 +5,15 @@
 # See /LICENSE for more information.
 #
 
+define Profile/CPVA502PLUS
+  NAME:=Telsey CPVA502+
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/CPVA502PLUS/Description
+  Package set optimized for CPVA502+.
+endef
+$(eval $(call Profile,CPVA502PLUS))
+
 define Profile/CPVA642
   NAME:=Telsey CPVA642-type (CPA-ZNTE60T)
   PACKAGES:=kmod-rt61-pci wpad-mini\