[net] Firewall: Moved firewalling related programs to Firewall submenu.
authorDaniel Dickinson <crazycshore@gmail.com>
Sat, 12 Mar 2011 01:14:02 +0000 (01:14 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Sat, 12 Mar 2011 01:14:02 +0000 (01:14 +0000)
SVN-Revision: 26055

net/conntrack-tools/Makefile
net/linuxigd/Makefile
net/miniupnpc/Makefile
net/miniupnpd/Makefile
net/natpmp/Makefile
net/nufw/Makefile
net/portsentry/Makefile
net/scanlogd/Makefile

index 1f90508073289941f29c786c69dd58a8ae8a9010..942b7facefad23551abf56d8d2fb66b7deba6f31 100644 (file)
@@ -27,6 +27,7 @@ define Package/conntrack-tools
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libnetfilter-conntrack
+  SUBMENU:=Firewall
   TITLE:=Connection tracking userspace tools
   URL:=http://conntrack-tools.netfilter.org/
 endef
index 520dc8534f5015ea975e29c3acc6237aa7262409..6fc5c153b0cc3a6ef403a6bcbe2e40be152ca9d9 100644 (file)
@@ -24,6 +24,7 @@ define Package/linuxigd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=UPnP daemon
+  SUBMENU:=Firewall
   DEPENDS:=+libiptc +libupnp +libpthread @!LINUX_2_4
   URL:=http://linux-igd.sourceforge.net/
 endef
index 58741286fd47f43660c1ba163ddff9ba6660fd6a..cd80bf4fcf6c86813a8fe23f81fc3ade31056116 100644 (file)
@@ -13,6 +13,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/miniupnpc
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Firewall
   TITLE:=Lightweight UPnP client
   URL:=http://miniupnp.tuxfamily.org/
 endef
index b9d08a5d8ddd31b77b8aa45eb6a169fbfdb56349..c19342faca8230ccd63f9a25e45bdeed9e825a82 100644 (file)
@@ -23,6 +23,7 @@ define Package/miniupnpd
   CATEGORY:=Network
   DEPENDS:=+iptables
   TITLE:=Lightweight UPnP daemon
+  SUBMENU:=Firewall
   URL:=http://miniupnp.free.fr/
   MAINTAINER:=Daniel Dickinson <openwrt@cshore.neomailbox.net>
 endef
index 00d764a0926a08134eef6e8da9fbe7ddca168ae6..ec81f335ab5e6db7a28c9c5205183f9bcc7d3b58 100644 (file)
@@ -14,6 +14,7 @@ define Package/natpmp
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+ip
+  SUBMENU:=Firewall
   TITLE:=A daemon implementing NAT-PMP
   URL:=http://savannah.nongnu.org/projects/natpmp
 endef
index f4985a255d8732ce0ad8534f5cfcabc64a6ff98b..b378f93c44ad52dfd7fff92b4383e91392d17859 100644 (file)
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/nufw/Default
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Firewall
   DEPENDS:=+glib2 +libgnutls +libsasl2 +libnetfilter-queue $(ICONV_DEPENDS) $(INTL_DEPENDS)
   TITLE:=nufw
   URL:=http://www.nufw.org/
index 0f1d61338d203119409a11ae212f95d65324aaff..0c18ace5472d7fad29d50f81e5c7ec8d699376a4 100644 (file)
@@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/portsentry
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Firewall
   TITLE:=Portscan protection utility
   URL:=http://sourceforge.net/projects/sentrytools
 endef
index 1083ea8de24a241f880d33b20f6edd90265bb943..81ae587b0a74060358b71892c14f85f8730b8d18 100644 (file)
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/scanlogd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Firewall
   DEPENDS:=+libpcap +libnet0 +libnids
   TITLE:=Port scan detection tool
   URL:=http://www.openwall.com/scanlogd