[packages] Update dependencies on gtk to match
authorAndy Boyett <agb@openwrt.org>
Mon, 23 Jun 2008 08:29:13 +0000 (08:29 +0000)
committerAndy Boyett <agb@openwrt.org>
Mon, 23 Jun 2008 08:29:13 +0000 (08:29 +0000)
SVN-Revision: 11568

XOrg/app/xmms/Makefile
XOrg/lib/imlib2/Makefile
lang/pygtk/Makefile
libs/wnck/Makefile
multimedia/gst-plugins-base/Makefile

index c469de64b0a8417ca26ee7b954eb919523eacb07..b4b338d8566ff84c523b9e4d10e566a88e71504b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -22,7 +22,7 @@ define Package/xmms
   SECTION:=xorg-app
   CATEGORY:=Xorg
   SUBMENU:=app
-  DEPENDS:=+xorg-server-essentials +alsa-lib +gtk-1.2.10 +libnotimpl
+  DEPENDS:=+xorg-server-essentials +alsa-lib +gtk1 +libnotimpl
   TITLE:=XMMS audio player
 endef
 
@@ -57,7 +57,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR=$(PKG_INSTALL_DIR) \
                LIBTOOL="libtool --tag=CC" \
-               all install 
+               all install
 endef
 
 define Package/xmms/install
index bf6a9f5cd547dc2583e23c268fc3bf1b71237d55..915d05114f8d9eb7546815f794d0902ac82f1dbc 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -23,7 +23,7 @@ define Package/imlib2
   CATEGORY:=Xorg
   SUBMENU:=libraries
   TITLE:=Image library
-  DEPENDS:=+xorg-server-essentials +giflib +libtiff +libjpeg +gtk-1.2.10 +libnotimpl +libfreetype
+  DEPENDS:=+xorg-server-essentials +giflib +libtiff +libjpeg +gtk1 +libnotimpl +libfreetype
 endef
 
 CONFIGURE_ARGS+=--disable-gtktest LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
@@ -52,7 +52,7 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/src/modules/loaders/.libs/*.so $(1)/usr/lib/imlib2/loaders/
        $(INSTALL_DIR) $(2)/bin
        mv $(1)/usr/bin/imlib2-config $(2)/bin/
-       $(SED)  "s,prefix.*,prefix=$(STAGING_DIR)/usr,g" $(2)/bin/imlib2-config 
+       $(SED)  "s,prefix.*,prefix=$(STAGING_DIR)/usr,g" $(2)/bin/imlib2-config
        $(SED)  "s,exec_prefix.*,exec_prefix=$(STAGING_DIR)/usr,g" $(2)/bin/imlib2-config
 endef
 
index a75283ae67fabdef25387bf17757efaf6d34af97..04e90c17bf48abf247f32a41f2e9a337a9adc473 100644 (file)
@@ -26,7 +26,7 @@ define Package/python-gtk
   CATEGORY:=Languages
   TITLE:=GTK bindings to python
   URL:=http://www.pygtk.org/
-  DEPENDS:=python-core +python-gobject +gtk-2.10.14 +pycairo
+  DEPENDS:=python-core +python-gobject +gtk2 +pycairo
 endef
 
 define Package/python-gtk/description
index 6cbc170e4137b4bd0b45eff4e4408fb8c64514eb..80f1dcb74f341db7251535aa8b7227e2e16d26a2 100644 (file)
@@ -25,7 +25,7 @@ define Package/libwnck
   CATEGORY:=Libraries
   TITLE:=Window Navigator Construction Kit
   URL:=http://ftp.gnome.org/
-  DEPENDS:=+gtk-2.10.14 +glib2 +libXext
+  DEPENDS:=+gtk2 +glib2 +libXext
 endef
 
 define Package/libwnck/description
index 1f24ca7ae9e638166fc1a5d9c29218d9ddade89d..6221b8e863660be69e0bb28ad95b751a3e8815e1 100644 (file)
@@ -25,7 +25,7 @@ define Package/gst-plugins-base
   CATEGORY:=Multimedia
   TITLE:=gst-plugins-base
   URL:=http://gst-plugins-base.freedesktop.org/
-  DEPENDS:=gstreamer +liboil +pango +gtk-2.10.14
+  DEPENDS:=gstreamer +liboil +pango +gtk2
 endef
 
 define Package/gst-plugins-base/description