add kmod-oprofile to package/kernel
authorFelix Fietkau <nbd@openwrt.org>
Thu, 24 Feb 2011 01:11:16 +0000 (01:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 24 Feb 2011 01:11:16 +0000 (01:11 +0000)
SVN-Revision: 25690

package/kernel/modules/other.mk

index 60a534c86d96037a0862a249389c442b82e8f14a..0ecc7b37861393594ddbdce57918f3c55ad31836 100644 (file)
@@ -663,6 +663,21 @@ endef
 $(eval $(call KernelPackage,mmc-atmelmci,1))
 
 
+define KernelPackage/oprofile
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=OProfile profiling support
+  KCONFIG:=CONFIG_OPROFILE
+  FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
+  DEPENDS:=@KERNEL_PROFILING
+endef
+
+define KernelPackage/oprofile/description
+  Kernel module for support for oprofile system profiling.
+endef
+
+$(eval $(call KernelPackage,oprofile))
+
+
 define KernelPackage/rfkill
   SUBMENU:=$(OTHER_MENU)
   TITLE:=RF switch subsystem support