add some sanity checking
authorFelix Fietkau <nbd@openwrt.org>
Sun, 15 Jun 2008 14:34:00 +0000 (14:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 15 Jun 2008 14:34:00 +0000 (14:34 +0000)
SVN-Revision: 11473

include/toplevel.mk
toolchain/Makefile

index 606e3e5844b45635645958e6f6090f844f078518..e13d66781aaa655f700f434b187fe2a56584aabd 100644 (file)
@@ -45,7 +45,7 @@ prepare-tmpinfo: FORCE
        touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf prepare-tmpinfo
        touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf prepare-tmpinfo
-       @+if [ \! -f .config ]; then \
+       @+if [ -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi
index cbc726ef013b90cbff93b921b44a0319336b80ba..4afcc439a37a5a905848b810ce98d548a8580c0f 100644 (file)
@@ -23,7 +23,8 @@ ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   $(curdir)/uClibc/install:=$(curdir)/gcc/install
 endif
 
   $(curdir)/uClibc/install:=$(curdir)/gcc/install
 endif
 
-$(TOOLCHAIN_DIR)/info.mk: .config
+ifneq ($(ARCH),)
+  $(TOOLCHAIN_DIR)/info.mk: .config
        @for dir in $(TOOLCHAIN_DIR); do ( \
                set -x; \
                mkdir -p "$$dir"; \
        @for dir in $(TOOLCHAIN_DIR); do ( \
                set -x; \
                mkdir -p "$$dir"; \
@@ -32,6 +33,7 @@ $(TOOLCHAIN_DIR)/info.mk: .config
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
        @touch $@
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
        @touch $@
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq