[backfire] packages/openswan: merge r27922 & r28739 (update to 2.6.37)
authorNicolas Thill <nico@openwrt.org>
Fri, 18 Nov 2011 20:53:19 +0000 (20:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 18 Nov 2011 20:53:19 +0000 (20:53 +0000)
SVN-Revision: 29244

net/openswan/Makefile
net/openswan/patches/110-scripts.patch
net/openswan/patches/130-compat_net_dev_ops.patch
net/openswan/patches/140-generated_autoconf.patch

index 2fef24010ab37c01fbda7e7f5b1d65a88d65a330..1a33dd1318225f667f4d354ae319f226c2a8f1c2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openswan
-PKG_VERSION:=2.6.33
+PKG_VERSION:=2.6.37
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openswan.org/download
-PKG_MD5SUM:=7e9c28585307b7ad4f59737debb0d940
+PKG_MD5SUM:=e5c948555088df06cfadcfbe6c13adfe
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
index 18e5b7762609ad1f35469c76208e527d4ee3d1d4..971ea593b4da066bf11ad8c492afe0b68af05215 100644 (file)
 +# pref. log to nfs mount
 +echo "$*" >> /dev/null
 +exit 0
---- a/programs/_plutorun/_plutorun.in
-+++ b/programs/_plutorun/_plutorun.in
-@@ -157,7 +157,7 @@ then
-                       exit 1
-               fi
-       else
--              if test ! -w "`dirname $stderrlog`"
-+              if test ! -w "${stderrlog%/*}"
-               then
-                       echo Cannot write to directory to create \"$stderrlog\".
-                       exit 1
---- a/programs/_realsetup/_realsetup.in
-+++ b/programs/_realsetup/_realsetup.in
-@@ -291,7 +291,7 @@ case "$1" in
-       # misc pre-Pluto setup
--      perform test -d $subsysdir "&&" touch $subsyslock
-+      perform test -d "${subsyslock%/*}" "&&" touch $subsyslock "&&" rm -f $subsyslock
-       manualconns
index 84c2a2b4ba05a1d0b93d56617b886d0863691b89..46786fa2fbfc8d92130d96dd26077904092427a8 100644 (file)
@@ -4,7 +4,7 @@
 
 --- a/linux/include/openswan/ipsec_kversion.h
 +++ b/linux/include/openswan/ipsec_kversion.h
-@@ -387,6 +387,12 @@
+@@ -393,6 +393,12 @@
  # endif
  #endif
  
index 6c0a9f66dae2b37e2b46162fd5fb4e4e89121bda..fedb5f191bc58a1f0a75c45538958d169cfe6c81 100644 (file)
---- a/linux/net/ipsec/ipsec_ocf.c
-+++ b/linux/net/ipsec/ipsec_ocf.c
-@@ -15,10 +15,12 @@
-  * for more details.
-  */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
+--- a/linux/include/ocf-compat.h
++++ b/linux/include/ocf-compat.h
+@@ -35,10 +35,11 @@
+ /****************************************************************************/
+ #ifdef __KERNEL__
  #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
- #define __NO_VERSION__
- #include <linux/module.h>
---- a/linux/net/ipsec/pfkey_v2_ext_process.c
-+++ b/linux/net/ipsec/pfkey_v2_ext_process.c
-@@ -19,10 +19,12 @@
-  *            Template from klips/net/ipsec/ipsec/ipsec_netlink.c.
-  */
--#ifndef AUTOCONF_INCLUDED
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif
- #include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
- #include <linux/kernel.h> /* printk() */
- #include "openswan/ipsec_param.h"
---- a/linux/net/ipsec/version.in.c
-+++ b/linux/net/ipsec/version.in.c
-@@ -15,10 +15,12 @@
+ #endif
+-
+ /*
+  * fake some BSD driver interface stuff specifically for OCF use
   */
- #ifdef __KERNEL__
--# ifndef AUTOCONF_INCLUDED
--#  include <linux/config.h>
--# endif
- # include <linux/version.h>
-+# if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+# include <generated/autoconf.h>
-+# else
-+# include <linux/autoconf.h>
-+# endif
- # define __NO_VERSION__
- # include <linux/module.h>
- # if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0) && LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,26)
---- a/linux/net/ipsec/ipsec_ipcomp.c
-+++ b/linux/net/ipsec/ipsec_ipcomp.c
-@@ -13,10 +13,12 @@
-  * for more details.
+--- a/linux/include/openswan/ipsec_kversion.h
++++ b/linux/include/openswan/ipsec_kversion.h
+@@ -43,10 +43,11 @@
+  * We use a lot of config defines,  on older kernels that means we
+  * need to include config.h
   */
--#ifndef AUTOCONF_INCLUDED
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif
- #include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
- #define __NO_VERSION__
- #include <linux/module.h>
---- a/linux/net/ipsec/radij.c
-+++ b/linux/net/ipsec/radij.c
-@@ -53,10 +53,12 @@
-  * Routines to build and maintain radix trees for routing lookups.
+ #endif
+-
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
+ /* Only enable IPv6 support on newer kernels with IPv6 enabled */
+ # if defined(CONFIG_IPV6) || defined(CONFIG_IPV6_MODULE)
+--- a/linux/net/ipsec/aes/ipsec_alg_aes.c
++++ b/linux/net/ipsec/aes/ipsec_alg_aes.c
+@@ -22,8 +22,10 @@
+  *
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
- #include <linux/kernel.h> /* printk() */
- #include "openswan/ipsec_param.h"
---- a/linux/net/ipsec/ipsec_mast.c
-+++ b/linux/net/ipsec/ipsec_mast.c
-@@ -17,9 +17,12 @@ char ipsec_mast_c_version[] = "Please us
- #define __NO_VERSION__
- #include <linux/module.h>
--#ifndef AUTOCONF_INCLUDED
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif        /* for CONFIG_IP_FORWARD */
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif /* For Config IP-FORWARD */
+ #endif
  #include <linux/version.h>
- #include <linux/kernel.h> /* printk() */
---- a/linux/net/ipsec/ipsec_xmit.c
-+++ b/linux/net/ipsec/ipsec_xmit.c
-@@ -21,9 +21,12 @@
  
- #define __NO_VERSION__
- #include <linux/module.h>
--#ifndef AUTOCONF_INCLUDED
+--- a/linux/net/ipsec/des/ipsec_alg_3des.c
++++ b/linux/net/ipsec/des/ipsec_alg_3des.c
+@@ -19,8 +19,10 @@
+  *
+  */
+ #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif        /* for CONFIG_IP_FORWARD */
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif /* for CONFIG_IP_FORWARD */
+ #endif
  #include <linux/version.h>
- #include <linux/kernel.h> /* printk() */
  
---- a/linux/net/ipsec/ipsec_ipip.c
-+++ b/linux/net/ipsec/ipsec_ipip.c
-@@ -13,8 +13,11 @@
-  * for more details.
-  */
+--- a/linux/net/ipsec/ipcomp.c
++++ b/linux/net/ipsec/ipcomp.c
+@@ -19,10 +19,11 @@
+ /* SSS */
  
--#ifndef AUTOCONF_INCLUDED
+ #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
  #endif
- #include <linux/version.h>
---- a/linux/net/ipsec/ipsec_snprintf.c
-+++ b/linux/net/ipsec/ipsec_snprintf.c
-@@ -18,10 +18,12 @@
-  * Split out from ipsec_proc.c.
+-
+ #define __NO_VERSION__
+ #include <linux/module.h>
+ #include <linux/kernel.h> /* printk() */
+--- a/linux/net/ipsec/ipsec_ah.c
++++ b/linux/net/ipsec/ipsec_ah.c
+@@ -14,10 +14,11 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
  #define __NO_VERSION__
  #include <linux/module.h>
  #include <linux/kernel.h> /* printk() */
---- a/linux/net/ipsec/ipsec_xform.c
-+++ b/linux/net/ipsec/ipsec_xform.c
-@@ -16,10 +16,12 @@
-  * RCSID $Id: ipsec_xform.c,v 1.65 2005/04/29 05:10:22 mcr Exp $
+--- a/linux/net/ipsec/ipsec_alg.c
++++ b/linux/net/ipsec/ipsec_alg.c
+@@ -19,10 +19,11 @@
+  *
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
+ #define __NO_VERSION__
+ #include <linux/module.h>
  #include <linux/kernel.h> /* printk() */
- #include "freeswan/ipsec_param.h"
---- a/linux/net/ipsec/alg/ipsec_alg_cryptoapi.c
-+++ b/linux/net/ipsec/alg/ipsec_alg_cryptoapi.c
-@@ -27,11 +27,12 @@
-  *   modprobe ipsec_cryptoapi aes=128,128                (force these keylens)
+--- a/linux/net/ipsec/ipsec_alg_cryptoapi.c
++++ b/linux/net/ipsec/ipsec_alg_cryptoapi.c
+@@ -26,10 +26,11 @@
   *   modprobe ipsec_cryptoapi des_ede3=0                 (everything but 3DES)
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
--
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
  /*    
   *    special case: ipsec core modular with this static algo inside:
   *    must avoid MODULE magic for this file
---- a/linux/net/ipsec/aes/ipsec_alg_aes.c
-+++ b/linux/net/ipsec/aes/ipsec_alg_aes.c
-@@ -21,10 +21,12 @@
-  *    PK:     make XCBC comply with latest draft (keylength)
-  *
+--- a/linux/net/ipsec/ipsec_esp.c
++++ b/linux/net/ipsec/ipsec_esp.c
+@@ -14,10 +14,11 @@
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
+ #define __NO_VERSION__
+ #include <linux/module.h>
+ #include <linux/kernel.h> /* printk() */
+--- a/linux/net/ipsec/ipsec_init.c
++++ b/linux/net/ipsec/ipsec_init.c
+@@ -19,8 +19,10 @@
+  */
  
- /*    
-  *    special case: ipsec core modular with this static algo inside:
---- a/linux/net/ipsec/ipsec_proc.c
-+++ b/linux/net/ipsec/ipsec_proc.c
-@@ -18,10 +18,12 @@
-  * Split out from ipsec_init.c version 1.70.
+ #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
++#include <generated/autoconf.h>
++#else
++#include <linux/autoconf.h>
+ #endif
+ #include <linux/module.h>
+ #include <linux/kernel.h> /* printk() */
+--- a/linux/net/ipsec/ipsec_ipcomp.c
++++ b/linux/net/ipsec/ipsec_ipcomp.c
+@@ -14,10 +14,11 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--# include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
  #define __NO_VERSION__
  #include <linux/module.h>
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0) && LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,26)
---- a/linux/net/ipsec/ipcomp.c
-+++ b/linux/net/ipsec/ipcomp.c
-@@ -18,10 +18,12 @@
- /* SSS */
+ #include <linux/kernel.h> /* printk() */
+--- a/linux/net/ipsec/ipsec_ipip.c
++++ b/linux/net/ipsec/ipsec_ipip.c
+@@ -14,10 +14,11 @@
+  */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
  #define __NO_VERSION__
  #include <linux/module.h>
---- a/linux/net/ipsec/ipsec_sa.c
-+++ b/linux/net/ipsec/ipsec_sa.c
-@@ -18,10 +18,12 @@
-  *
+ #include <linux/kernel.h> /* printk() */
+--- a/linux/net/ipsec/ipsec_ocf.c
++++ b/linux/net/ipsec/ipsec_ocf.c
+@@ -16,10 +16,11 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
+ #define __NO_VERSION__
+ #include <linux/module.h>
  #include <linux/kernel.h> /* printk() */
- #include "openswan/ipsec_param.h"
---- a/linux/net/ipsec/des/ipsec_alg_3des.c
-+++ b/linux/net/ipsec/des/ipsec_alg_3des.c
-@@ -18,10 +18,12 @@
-  * for more details.
-  *
+--- a/linux/net/ipsec/ipsec_ocf.h
++++ b/linux/net/ipsec/ipsec_ocf.h
+@@ -19,8 +19,10 @@
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+ #include <linux/kernel.h>
  
- /*    
-  *    special case: ipsec core modular with this static algo inside:
 --- a/linux/net/ipsec/ipsec_radij.c
 +++ b/linux/net/ipsec/ipsec_radij.c
-@@ -15,10 +15,12 @@
-  *
+@@ -16,8 +16,10 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
  #include <linux/kernel.h> /* printk() */
  
- #include "openswan/ipsec_param.h"
 --- a/linux/net/ipsec/ipsec_rcv.c
 +++ b/linux/net/ipsec/ipsec_rcv.c
-@@ -20,10 +20,12 @@
-  * for more details.
+@@ -21,10 +21,11 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+-
  #define __NO_VERSION__
  #include <linux/module.h>
---- a/linux/net/ipsec/ipsec_esp.c
-+++ b/linux/net/ipsec/ipsec_esp.c
-@@ -13,10 +13,12 @@
-  * for more details.
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0) && LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,26)
+--- a/linux/net/ipsec/ipsec_sa.c
++++ b/linux/net/ipsec/ipsec_sa.c
+@@ -19,8 +19,10 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
- #define __NO_VERSION__
- #include <linux/module.h>
---- a/linux/net/ipsec/ipsec_life.c
-+++ b/linux/net/ipsec/ipsec_life.c
-@@ -30,9 +30,12 @@
- #define __NO_VERSION__
- #include <linux/module.h>
--#ifndef AUTOCONF_INCLUDED
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif        /* for CONFIG_IP_FORWARD */
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif /* for CONFIG_IP_FORWARD */
- #include <linux/version.h>
+ #endif
  #include <linux/kernel.h> /* printk() */
  
---- a/linux/net/ipsec/ipsec_alg.c
-+++ b/linux/net/ipsec/ipsec_alg.c
-@@ -18,10 +18,12 @@
-  * for more details.
-  *
+--- a/linux/net/ipsec/ipsec_snprintf.c
++++ b/linux/net/ipsec/ipsec_snprintf.c
+@@ -19,8 +19,10 @@
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
- #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
  
- #define __NO_VERSION__
- #include <linux/module.h>
---- a/linux/net/ipsec/pfkey_v2.c
-+++ b/linux/net/ipsec/pfkey_v2.c
-@@ -22,8 +22,10 @@
- #define __NO_VERSION__
- #include <linux/module.h>
  #include <linux/version.h>
--#ifndef AUTOCONF_INCLUDED
--# include <linux/config.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
  #endif
- #include <linux/kernel.h>
---- a/linux/net/ipsec/ipsec_tunnel.c
-+++ b/linux/net/ipsec/ipsec_tunnel.c
-@@ -20,9 +20,12 @@
  #define __NO_VERSION__
  #include <linux/module.h>
--#ifndef AUTOCONF_INCLUDED
+--- a/linux/net/ipsec/ipsec_tunnel.c
++++ b/linux/net/ipsec/ipsec_tunnel.c
+@@ -24,8 +24,10 @@
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0) && LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,26)
+ # include <linux/moduleparam.h>
+ #endif
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif        /* for CONFIG_IP_FORWARD */
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif /* for CONFIG_IP_FORWARD */
- #include <linux/version.h>
+ #endif
  #include <linux/kernel.h> /* printk() */
  
---- a/linux/include/openswan/ipsec_kversion.h
-+++ b/linux/include/openswan/ipsec_kversion.h
-@@ -43,8 +43,11 @@
-  * We use a lot of config defines,  on older kernels that means we
-  * need to include config.h
+--- a/linux/net/ipsec/ipsec_xform.c
++++ b/linux/net/ipsec/ipsec_xform.c
+@@ -17,8 +17,10 @@
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
-+#include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
- #endif
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
---- a/linux/include/openswan/ipsec_rcv.h
-+++ b/linux/include/openswan/ipsec_rcv.h
-@@ -36,9 +36,12 @@
- /* struct options; */
  
- #define __NO_VERSION__
--#ifndef AUTOCONF_INCLUDED
+ #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif        /* for CONFIG_IP_FORWARD */
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif /* for CONFIG_IP_FORWARD */
- #ifdef CONFIG_MODULES
- #include <linux/module.h>
  #endif
---- a/linux/net/ipsec/ipsec_ocf.h
-+++ b/linux/net/ipsec/ipsec_ocf.h
-@@ -18,10 +18,12 @@
-  * for more details.
-  */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
- #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
- #include <linux/kernel.h>
+ #include <linux/kernel.h> /* printk() */
  
- #ifdef CONFIG_KLIPS_OCF
---- a/linux/net/ipsec/ipsec_ah.c
-+++ b/linux/net/ipsec/ipsec_ah.c
-@@ -13,10 +13,12 @@
-  * for more details.
+--- a/linux/net/ipsec/pfkey_v2_ext_process.c
++++ b/linux/net/ipsec/pfkey_v2_ext_process.c
+@@ -20,8 +20,10 @@
   */
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
+-#include <linux/config.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
+ #endif
+ #include <linux/kernel.h> /* printk() */
  
- #define __NO_VERSION__
- #include <linux/module.h>
 --- a/linux/net/ipsec/pfkey_v2_parser.c
 +++ b/linux/net/ipsec/pfkey_v2_parser.c
-@@ -22,10 +22,12 @@
-  */
+@@ -23,8 +23,10 @@
  
  
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
  #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
- #include <linux/kernel.h> /* printk() */
- #include "openswan/ipsec_param.h"
---- a/linux/net/ipsec/ipsec_init.c
-+++ b/linux/net/ipsec/ipsec_init.c
-@@ -18,10 +18,12 @@
-  *
-  */
--#ifndef AUTOCONF_INCLUDED
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
--#endif
- #include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
-+#endif
- #include <linux/module.h>
+ #endif
  #include <linux/kernel.h> /* printk() */
  
---- a/linux/net/ipsec/ipsec_alg_cryptoapi.c
-+++ b/linux/net/ipsec/ipsec_alg_cryptoapi.c
-@@ -27,10 +27,12 @@
-  *   modprobe ipsec_cryptoapi aes=128,128                (force these keylens)
-  *   modprobe ipsec_cryptoapi des_ede3=0                 (everything but 3DES)
+--- a/linux/net/ipsec/radij.c
++++ b/linux/net/ipsec/radij.c
+@@ -54,8 +54,10 @@
   */
--#ifndef AUTOCONF_INCLUDED
--#include <linux/config.h>
--#endif
- #include <linux/version.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
-+#include <generated/autoconf.h>
-+#else
-+#include <linux/autoconf.h>
-+#endif
  
- /*    
-  *    special case: ipsec core modular with this static algo inside:
---- a/linux/include/ocf-compat.h
-+++ b/linux/include/ocf-compat.h
-@@ -34,8 +34,11 @@
-  */
- /****************************************************************************/
- #ifdef __KERNEL__
--#ifndef AUTOCONF_INCLUDED
+ #include <linux/version.h>
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,38) && !defined(AUTOCONF_INCLUDED)
 -#include <linux/config.h>
-+#include <linux/version.h>
 +#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,33))
 +#include <generated/autoconf.h>
 +#else
 +#include <linux/autoconf.h>
  #endif
+ #include <linux/kernel.h> /* printk() */
  
- /*