merge r13821 to 8.09 (closes: #4582)
authorNicolas Thill <nico@openwrt.org>
Fri, 10 Apr 2009 13:34:40 +0000 (13:34 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 10 Apr 2009 13:34:40 +0000 (13:34 +0000)
SVN-Revision: 15201

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

index 04ceef0ab8e7afd3ab4c76d48c4a9b1757a4da7d..5706e4464015eb29fc24ea7752447b231502a1aa 100644 (file)
@@ -36,7 +36,7 @@ config X86_GRUB_BOOTOPTS
 
 
 config X86_VDI_IMAGES
-    bool "Build VirtualBox image files (VDI). Requires vditool"
+    bool "Build VirtualBox image files (VDI). Requires VBoxManage"
     depends TARGET_x86
     depends TARGET_ROOTFS_EXT2FS
     depends X86_GRUB_IMAGES
index d707d2f435c141f4acd582cff047fec66e541010..9980cf01524ef4ba585e71b26b8f2419902ba280 100644 (file)
@@ -66,7 +66,7 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext2)
                rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
-               vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
+               VBoxManage convertfromraw -format VDI $(BIN_DIR)/openwrt-$(BOARD)-ext2.image $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi
     endif
   endef
 endif
@@ -110,8 +110,8 @@ endef
 $(eval $(call BuildImage))
 
 ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  $(eval $(call RequireCommand,vditool, \
-       You need vditool to generate VirtualBox images. \
+  $(eval $(call RequireCommand,VBoxManage, \
+       You need VBoxManage to generate VirtualBox images. \
   ))
 endif