[8.09] [packages] libsigc++, libtorrent, rtorrent: merge fixes from ./packages to...
authorNicolas Thill <nico@openwrt.org>
Wed, 13 May 2009 22:17:43 +0000 (22:17 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 13 May 2009 22:17:43 +0000 (22:17 +0000)
 - link 'em all against libstdc++ only
 - add "-fno-strict-aliasing -fno-inline" flags
 - remove BROKEN status
 - bump release number

SVN-Revision: 15831

libs/libsigc++/Makefile
libs/libsigc++/patches/001-no_doc_tests_examples.patch
libs/libtorrent/Makefile
net/rtorrent/Makefile

index 90443bc9c04031810bc40f5e94da1dad79f634db..7a8f7c0b58d46d4ab7bdd9150788882ca6317ab2 100644 (file)
@@ -4,13 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
 PKG_VERSION:=2.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/
@@ -25,7 +24,7 @@ define Package/libsigcxx
   CATEGORY:=Libraries
   TITLE:=typesafe callback system for standard C++
   URL:=http://libsigc++.sourceforge.net/
-  DEPENDS:=+uclibcxx
+  DEPENDS:=+libstdcpp
 endef
 
 define Package/libsigcxx/description
@@ -36,16 +35,13 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+TARGET_CPPFLAGS +=  \
+       -fno-strict-aliasing -fno-inline \
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-CONFIGURE_VARS += \
-       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
-       LDFLAGS="$$$$LDFLAGS" \
-       LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
index 8304746ac39dd0a2bf234ba39e57d796e84f3ec7..20c840f258c909d3034c32b7ea170e95d3e60d34 100644 (file)
@@ -6,7 +6,7 @@ diff -urN libsigc++-2.2.3/Makefile.am libsigc++-2.2.3.new/Makefile.am
  # ACLOCAL_FLAGS = -I scripts
  
 -SUBDIRS      = sigc++ tests docs examples scripts MSVC_Net2005 MSVC_Net2008
-+SUBDIRS      = sigc++ scripts MSVC_Net2005 MSVC_Net2008
++SUBDIRS      = sigc++ scripts
  DIST_SUBDIRS = $(SUBDIRS)
  
  sigc_configdir = $(libdir)/sigc++-2.0/include
@@ -18,7 +18,7 @@ diff -urN libsigc++-2.2.3/Makefile.in libsigc++-2.2.3.new/Makefile.in
  EXTRA_DIST = autogen.sh sigc++config.h.in libsigc++-2.0.spec.in
  # ACLOCAL_FLAGS = -I scripts
 -SUBDIRS = sigc++ tests docs examples scripts MSVC_Net2005 MSVC_Net2008
-+SUBDIRS = sigc++ scripts MSVC_Net2005 MSVC_Net2008
++SUBDIRS = sigc++ scripts
  DIST_SUBDIRS = $(SUBDIRS)
  sigc_configdir = $(libdir)/sigc++-2.0/include
  sigc_config_DATA = sigc++config.h
index d6022d09d1a41f4fffae9ecad2aa6090dc02c80a..4c0fceda014bceff671acc258cefcbff8c8b6a6e 100644 (file)
@@ -4,13 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtorrent
 PKG_VERSION:=0.12.4
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
@@ -38,6 +37,9 @@ endef
 
 TARGET_CFLAGS += $(FPIC)
 
+TARGET_CPPFLAGS +=  \
+        -fno-strict-aliasing -fno-inline \
+
 # XXX: rtorrent needs encryption (--enable-openssl)
 CONFIGURE_ARGS+= \
        --enable-shared \
index 8432d0327473109efbdbb19f78281da5a4fd2b6f..9506f728f8f7f16d17ee118f220b0d6dde348059 100644 (file)
@@ -4,13 +4,12 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
 PKG_VERSION:=0.8.2
-PKG_RELEASE:=1
+PKG_RELEASE:=1.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads/
@@ -26,7 +25,7 @@ define Package/rtorrent
   CATEGORY:=Network
   TITLE:=BitTorrent client for ncurses
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx @BROKEN
+  DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx
 endef
 
 define Package/rtorrent/description
@@ -36,14 +35,14 @@ define Package/rtorrent/description
  based clients in an ncurses client.
 endef
 
+TARGET_CPPFLAGS +=  \
+       -fno-strict-aliasing -fno-inline \
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \
        --disable-debug \
 
-CONFIGURE_VARS += \
-       LIBS="-lm -luClibc++" \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \