[packages] remove libnotimpl, missing math functions are provided by uClibc since...
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 21:04:45 +0000 (21:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 21:04:45 +0000 (21:04 +0000)
SVN-Revision: 15454

ipv6/mrd6/Makefile
libs/libnotimpl/Makefile [deleted file]
libs/libnotimpl/src/math.c [deleted file]
libs/liboil/Makefile
libs/postgresql/Makefile
libs/speex/Makefile
net/kismet/Makefile
net/nagios/Makefile
net/qolyester/Makefile
sound/sox/Makefile
utils/rrdtool/Makefile

index 4d2459dd2661903fd2a5506476dac0b085fb33c4..0bd3f440389eb11278a571a6f67c46caba56f76d 100644 (file)
@@ -17,8 +17,6 @@ PKG_SOURCE_URL:=http://fivebits.net/files/mrd6/ \
        http://hng.av.it.pt/mrd6/download/
 PKG_MD5SUM:=361322198dafcc5ffab5e8e23197012b
 
        http://hng.av.it.pt/mrd6/download/
 PKG_MD5SUM:=361322198dafcc5ffab5e8e23197012b
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mrd6
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mrd6
@@ -45,7 +43,7 @@ define Build/Compile
                SPACE_OPTIMIZE=yes \
                FULL_STATIC=no \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DNO_INET6_OPTION -fno-builtin -fno-rtti" \
                SPACE_OPTIMIZE=yes \
                FULL_STATIC=no \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -DNO_INET6_OPTION -fno-builtin -fno-rtti" \
-               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -ldl -lgcc -lm -lnotimpl" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -ldl -lgcc -lm" \
                MODULE_CXX="\$$$$(CC) -shared \$$$$(CXXFLAGS) \$$$$(LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                PREFIX="/usr" \
                MODULE_CXX="\$$$$(CC) -shared \$$$$(CXXFLAGS) \$$$$(LDFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                PREFIX="/usr" \
diff --git a/libs/libnotimpl/Makefile b/libs/libnotimpl/Makefile
deleted file mode 100644 (file)
index c1e7b70..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libnotimpl
-PKG_VERSION:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/libnotimpl
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libnotimpl
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=Implements functions missing from uClibc
-endef
-
-ifeq ($(ARCH),x86_64)
-  FPIC:=-fPIC
-endif
-
-define cc
-       $(TARGET_CC) $(TARGET_CFLAGS) $(FPIC) -Wall -c src/$(1).c -o $(PKG_BUILD_DIR)/$(1).o
-endef
-
-define Build/Prepare
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(call cc,math)
-       $(TARGET_CROSS)ar rc $(PKG_BUILD_DIR)/libnotimpl.a $(PKG_BUILD_DIR)/*.o
-endef
-
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libnotimpl.a $(STAGING_DIR)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libnotimpl))
diff --git a/libs/libnotimpl/src/math.c b/libs/libnotimpl/src/math.c
deleted file mode 100644 (file)
index 0cbd1b3..0000000
+++ /dev/null
@@ -1,128 +0,0 @@
-/* vi: set sw=4 ts=4: */
-
-#include <math.h>
-
-
-/* cosf for uClibc
- *
- * wrapper for cos(x)
- */
-
-#ifdef __STDC__
-       float cosf(float x)
-#else
-       float cosf(x)
-       float x;
-#endif
-{
-       return (float) cos( (double)x );
-}
-
-
-/* sinf for uClibc
- *
- * wrapper for sin(x)
- */
-
-#ifdef __STDC__
-       float sinf(float x)
-#else
-       float sinf(x)
-       float x;
-#endif
-{
-       return (float) sin( (double)x );
-}
-
-
-/* ceilf for uClibc
- *
- * wrapper for ceil(x)
- */
-
-#ifdef __STDC__
-       float ceilf(float x)
-#else
-       float ceilf(x)
-       float x;
-#endif
-{
-       return (float) ceil( (double)x );
-}
-
-
-/* rintf for uClibc
- *
- * wrapper for rint(x)
- */
-
-#ifdef __STDC__
-       float rintf(float x)
-#else
-       float rintf(x)
-       float x;
-#endif
-{
-       return (float) rint( (double)x );
-}
-
-/* logf for uClibc
- * 
- * wrapper for logf(x)
- */
-
-#ifdef __STDC__
-       float logf(float x)
-#else
-       float logf(x)
-       float x;
-#endif
-{
-       return (float) logf( (double)x );
-}
-
-/* expf for uClibc
- *
- * wrapper for expf(x)
- */
-
-#ifdef __STDC__
-    float expf(float x)
-#else
-    float expf(x)
-    float x;
-#endif
-{
-    return (float) expf( (double)x );
-}
-
-/* lround for uClibc
- *
- * wrapper for lround(x)
- */
-
-#ifdef __STDC__
-    long lround(double x)
-#else
-    long lround(x)
-    double x;
-#endif
-{
-    return (long) ((x - ((long)x) >= 0.5f) ? (((long)x) + 1) : ((long)x));
-}
-
-/* lround for uClibc
- *
- * wrapper for roundf(x)
- */
-
-#ifdef __STDC__
-    float roundf(float x)
-#else
-    float roundf(x)
-       float x;
-#endif
-{
-       return (float) ((x - ((long)x) >= 0.5f) ? (((long)x) + 1) : ((long)x));
-}      
-
index 7b19966e09b0e87b44fc7330c8f5059bef78cb56..8c0695569fc2cf06f7d66f1884d5edb845c3ebb4 100644 (file)
@@ -15,7 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
 PKG_MD5SUM:=11dd39b1ca13ce2e0618d4df8303f137
 
 PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
 PKG_MD5SUM:=11dd39b1ca13ce2e0618d4df8303f137
 
-PKG_BUILD_DEPENDS:=libnotimpl
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
index 68a74842f0015c30675393ebf8498ac651f59796..aa7d800e82d25bbfc7595a17a09bca738780e22c 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
 PKG_VERSION:=8.3.3
 
 PKG_NAME:=postgresql
 PKG_VERSION:=8.3.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=\
@@ -20,8 +20,6 @@ PKG_SOURCE_URL:=\
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
 PKG_MD5SUM:=0ae4bd9620e84d3e08dcf923808d14d0
 
        ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
 PKG_MD5SUM:=0ae4bd9620e84d3e08dcf923808d14d0
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libpq
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libpq
@@ -114,7 +112,6 @@ define Build/Configure
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="$$$$CPPFLAGS $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="$$$$CPPFLAGS $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBS="-lnotimpl" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index b8a5f431467788653db346b1a4f8b5a28626b779..f75507aeb15a52b4afb97c0040db8b09406f0efb 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,8 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
 PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
 
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
 PKG_MD5SUM:=b47396952c5fdd54b6468316c3bd339f
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libspeex
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libspeex
@@ -59,8 +57,6 @@ define Package/libspeexdsp/description
        This package contains the shared dsp library, needed by other programs.
 endef
 
        This package contains the shared dsp library, needed by other programs.
 endef
 
-TARGET_LDFLAGS:=$(TARGET_LDFLAGS) -lnotimpl
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
index 158ec7beec4dd26f143eeeed90ab4ae97f10ac31..9e6675d066e089d6c2efb377f79d5207872d128a 100644 (file)
@@ -15,7 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
 PKG_MD5SUM:=6ee365d36354b4dee4945e67f8149294
 
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
 PKG_MD5SUM:=6ee365d36354b4dee4945e67f8149294
 
-PKG_BUILD_DEPENDS:=libnotimpl libpcap libncurses uclibcxx
+PKG_BUILD_DEPENDS:=libpcap libncurses uclibcxx
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -95,7 +95,7 @@ CONFIGURE_VARS += \
        CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
        LDFLAGS="$$$$LDFLAGS" \
        CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
        LDFLAGS="$$$$LDFLAGS" \
-       LIBS="-nodefaultlibs -luClibc++ -lm -lnotimpl -lgcc" \
+       LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
index 989a9668380b081103f3eade769c2330b4797e44..f64b0062a348bf039daddba3d1f9b135060d0a39 100644 (file)
@@ -19,8 +19,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
@@ -44,9 +42,6 @@ CONFIGURE_ARGS += \
        --without-gd-inc \
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)"
        
        --without-gd-inc \
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)"
        
-CONFIGURE_VARS += \
-       LIBS="-lnotimpl"
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
index e6079336be05f31fc74343503e4b39ca4bc93050..212985dc05d6117abc8b37aae988f993cd92c1ed 100644 (file)
@@ -15,8 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://qolsr.lri.fr/code/
 PKG_MD5SUM:=650286fc2ea3e13c246d233aaa46f2a4
 
 PKG_SOURCE_URL:=http://qolsr.lri.fr/code/
 PKG_MD5SUM:=650286fc2ea3e13c246d233aaa46f2a4
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/qolyester
 include $(INCLUDE_DIR)/package.mk
 
 define Package/qolyester
@@ -37,7 +35,6 @@ endef
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               LIBS="-L$(STAGING_DIR)/usr/lib -lnotimpl" \
                all install
 endef
 
                all install
 endef
 
index 46f9db8016f6e6946054a5c9dea825fab6f63cbd..27c12fe0685b80c115fcdd60318a9f75c91ed577 100644 (file)
@@ -17,7 +17,6 @@ PKG_SOURCE_URL:=@SF/sox
 PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
 
 PKG_FIXUP = libtool
 PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
 
 PKG_FIXUP = libtool
-PKG_BUILD_DEPENDS:=libnotimpl
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -44,8 +43,6 @@ define Build/Configure
                --disable-external-gsm \
                --without-libltdl \
                --with-ogg \
                --disable-external-gsm \
                --without-libltdl \
                --with-ogg \
-               , \
-               LIBS="-lnotimpl -lm" \
        )
 endef
 
        )
 endef
 
index 4a93970f51fd87b7f36289704e114765c81f55ce..bf5b12cd5bbb178788505988ad4b7a37f0bf9fd6 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,8 @@ PKG_SOURCE_URL:=http://oss.oetiker.ch/rrdtool/pub/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_MD5SUM:=19b24f7184a8dbf7b48c1bbb565ad9fb
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_MD5SUM:=19b24f7184a8dbf7b48c1bbb565ad9fb
 
-PKG_BUILD_DEPENDS:=python libnotimpl
+PKG_BUILD_DEPENDS:=python
+
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
@@ -69,7 +70,6 @@ CONFIGURE_ARGS += \
        --with-rrd-default-font="/usr/share/rrdtool/fonts/DejaVuSansMono-Roman.ttf" \
 
 CONFIGURE_VARS += \
        --with-rrd-default-font="/usr/share/rrdtool/fonts/DejaVuSansMono-Roman.ttf" \
 
 CONFIGURE_VARS += \
-       LIBS="-lnotimpl" \
        rd_cv_ieee_works=yes \
        rd_cv_null_realloc=nope \
        ac_cv_func_mmap_fixed_mapped=yes \
        rd_cv_ieee_works=yes \
        rd_cv_null_realloc=nope \
        ac_cv_func_mmap_fixed_mapped=yes \