move package descriptions to separate definitions
authorNicolas Thill <nico@openwrt.org>
Tue, 11 Sep 2007 13:29:53 +0000 (13:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 11 Sep 2007 13:29:53 +0000 (13:29 +0000)
SVN-Revision: 8745

package/kernel/modules/other.mk

index 781a05187619797c12d037eb7c9952443b91eb39..0cd869dace2695272f242cf8663312214b2d8005 100644 (file)
@@ -11,12 +11,15 @@ EMENU:=Other modules
 define KernelPackage/crc-itu-t
   SUBMENU:=$(EMENU)
   TITLE:=CRC ITU-T V.41 support
-  DESCRIPTION:=Kernel module for CRC ITU-T V.41 support
   KCONFIG:=CONFIG_CRC_ITU_T
   FILES:=$(LINUX_DIR)/lib/crc-itu-t.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,20,crc-itu-t)
 endef
 
+define KernelPackage/crc-itu-t/description
+ Kernel module for CRC ITU-T V.41 support
+endef
+
 $(eval $(call KernelPackage,crc-itu-t))
 
 
@@ -58,13 +61,16 @@ $(eval $(call KernelPackage,crypto))
 define KernelPackage/eeprom-93cx6
   SUBMENU:=$(EMENU)
   TITLE:=EEPROM 93CX6 support
-  DESCRIPTION:=Kernel module for EEPROM 93CX6 support
   DEPENDS:=@LINUX_2_6
   KCONFIG:=CONFIG_EEPROM_93CX6
   FILES:=$(LINUX_DIR)/drivers/misc/eeprom_93cx6.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,20,eeprom_93cx6)
 endef
 
+define KernelPackage/eeprom-93cx6/description
+ Kernel module for EEPROM 93CX6 support
+endef
+
 $(eval $(call KernelPackage,eeprom-93cx6))