Port frickin to -ng
authorFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 22:42:35 +0000 (22:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 22:42:35 +0000 (22:42 +0000)
SVN-Revision: 4384

net/frickin/Config.in [new file with mode: 0644]
net/frickin/Makefile [new file with mode: 0644]
net/frickin/files/frickin.default [new file with mode: 0644]
net/frickin/files/frickin.init [new file with mode: 0644]

diff --git a/net/frickin/Config.in b/net/frickin/Config.in
new file mode 100644 (file)
index 0000000..b118a11
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_FRICKIN
+       prompt "frickin........................... PPTP (Point-to-Point Tunneling Protocol) proxy"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         Frickin PPTP Proxy allows a Point-to-Point Tunneling Protocol (PPTP) 
+         client to connect to a PPTP server through Network Address 
+         Translation (NAT).
+         
+         http://frickin.sourceforge.net/
+
diff --git a/net/frickin/Makefile b/net/frickin/Makefile
new file mode 100644 (file)
index 0000000..056adb2
--- /dev/null
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=frickin
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+PKG_MD5SUM:= 5b2e98da2310c71c703d4617b88a173f
+
+PKG_SOURCE_URL:=@SF/frickin
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/frickin
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PPTP (Point-to-Point Tunneling Protocol) proxy
+  DESCRIPTION:=Frickin PPTP Proxy allows a Point-to-Point Tunneling Protocol (PPTP)\\\
+client to connect to a PPTP server through Network Address\\\
+Translation (NAT).\\\
+  URL:=http://frickin.sourceforge.net
+endef
+
+define Package/frickin/conffiles
+/etc/default/frickin
+endef
+
+define Build/Configure
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all
+endef
+
+define Package/frickin/install
+       install -d -m0755 $(1)/etc/default
+       install -m0644 ./files/frickin.default $(1)/etc/default/frickin
+       install -d -m0755 $(1)/etc/init.d
+       install -m0755 ./files/frickin.init $(1)/etc/init.d/frickin
+       install -d -m0755 $(1)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/frickin $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,frickin))
diff --git a/net/frickin/files/frickin.default b/net/frickin/files/frickin.default
new file mode 100644 (file)
index 0000000..9f55d5b
--- /dev/null
@@ -0,0 +1,16 @@
+# ip address of the server the proxy should connect to
+TARGET_IP=192.168.1.2
+
+# ip address the proxy should listen to for incoming connections
+#LISTEN_IP=192.168.1.1
+
+# maximum number of simultaneous connections
+#PROXY_CONN_MAX=20
+
+# user the proxy should run as
+#PROXY_USER=root
+
+[ -n "$TARGET_IP" ] && OPTIONS="$OPTIONS -s $TARGET_IP"
+[ -n "$LISTEN_IP" ] && OPTIONS="$OPTIONS -l $LISTEN_IP"
+[ -n "$PROXY_CONN_MAX" ] && OPTIONS="$OPTIONS -c $PROXY_CONN_MAX"
+[ -n "$PROXY_USER" ] && OPTIONS="$OPTIONS -u $PROXY_USER"
diff --git a/net/frickin/files/frickin.init b/net/frickin/files/frickin.init
new file mode 100644 (file)
index 0000000..e07a094
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+BIN=frickin
+DEFAULT=/etc/default/$BIN
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  $BIN $OPTIONS &
+  ;;
+ *)
+  echo "usage: $0 (start)"
+  exit 1
+esac
+
+exit $?