[package] add fowsr (#6952)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 27 Mar 2010 17:21:02 +0000 (17:21 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 27 Mar 2010 17:21:02 +0000 (17:21 +0000)
SVN-Revision: 20519

utils/fowsr/Makefile [new file with mode: 0644]

diff --git a/utils/fowsr/Makefile b/utils/fowsr/Makefile
new file mode 100644 (file)
index 0000000..43b9847
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fowsr
+PKG_VERSION:=1.0
+PKG_RELEASE:=20100323
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_RELEASE).tar.gz
+PKG_SOURCE_URL:=http://fowsr.googlecode.com/files
+PKG_MD5SUM:=74456362f8256a81659ef64400d84352
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fowsr
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libusb
+  TITLE:=Fine Offset Wireless Weather Station Reader
+  URL:=http://fowsr.googlecode.com/
+endef
+
+define Package/fowsr/description
+  fowsr is a USB Data Collector application for WH1080 compatible
+  weather stations.
+  Output formats includes Wunderground.com and pywws.
+  See http://www.foshk.com for details and download of the
+  EasyWeather application.
+  All weather stations that can use the EasyWeather application
+  will work with this software.
+endef
+
+CONFIGURE_ARGS += \
+       --with-linux-headers="$(LINUX_DIR)" \
+
+define Package/fowsr/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fowsr $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,fowsr))