ar71xx: build separate image for the WNDR3700 with NA region
authorGabor Juhos <juhosg@openwrt.org>
Fri, 14 Jan 2011 10:37:11 +0000 (10:37 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 14 Jan 2011 10:37:11 +0000 (10:37 +0000)
SVN-Revision: 24982

target/linux/ar71xx/image/Makefile

index f1a9362184c2cec366d20c481839a597a55b6224..90000639024210db85f96a71f3713bfc3993a9b2 100644 (file)
@@ -371,6 +371,10 @@ define Image/Build/WNDR3700
                -B WNDR3700 -v OpenWrt.$(REVISION) \
                -i $(call imgname,$(1),$(2))-sysupgrade.bin \
                -o $(call imgname,$(1),$(2))-factory.img
                -B WNDR3700 -v OpenWrt.$(REVISION) \
                -i $(call imgname,$(1),$(2))-sysupgrade.bin \
                -o $(call imgname,$(1),$(2))-factory.img
+       $(STAGING_DIR_HOST)/bin/mkdniimg \
+               -B WNDR3700 -v OpenWrt.$(REVISION) -r "NA" \
+               -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+               -o $(call imgname,$(1),$(2))-factory-NA.img
 endef
 
 ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
 endef
 
 ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh