Cleanup gtk1 Makefile.
authorLars-Peter Clausen <lars@metafoo.de>
Fri, 12 Sep 2008 20:50:05 +0000 (20:50 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Fri, 12 Sep 2008 20:50:05 +0000 (20:50 +0000)
SVN-Revision: 12578

XOrg/lib/gtk1/Makefile

index c4299e7ebcc39be261718975354435e9dc1495b3..90c5c5b8055ed5106150b3020c6fbb378dcb0857 100644 (file)
@@ -1,10 +1,11 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # blogic@openwrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # blogic@openwrt.org
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
@@ -13,13 +14,15 @@ PKG_VERSION:=1.2.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.gz
 PKG_RELEASE:=1
 
 PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:= \
-       ftp://ftp.gtk.org/pub/gtk/v1.2/ \
-       http://gd.tuwien.ac.at/graphics/gimp/gtk/v1.2/
+PKG_SOURCE_URL:=@GNOME/gtk+/1.2/
 PKG_BUILD_DIR=$(BUILD_DIR)/gtk+-1.2.10
 PKG_BUILD_DIR=$(BUILD_DIR)/gtk+-1.2.10
+PKG_MD5SUM:=4d5cb2fc7fb7830e4af9747a36bfce20
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
                --x-libraries=$(STAGING_DIR)/usr/lib \
                --with-glib-prefix=$(STAGING_DIR)/usr/ \
 CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
                --x-libraries=$(STAGING_DIR)/usr/lib \
                --with-glib-prefix=$(STAGING_DIR)/usr/ \
@@ -27,7 +30,7 @@ CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
                --enable-static=yes
 
 EXTRA_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
                --enable-static=yes
 
 EXTRA_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
-TARGET_CFLAGS+= -I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
+TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
 EXTRA_LDFLAGS+=-lnotimpl -lglib -lgmodule
 
 define Package/gtk1
 EXTRA_LDFLAGS+=-lnotimpl -lglib -lgmodule
 
 define Package/gtk1
@@ -38,23 +41,6 @@ define Package/gtk1
   DEPENDS:=+glib1 +libX11
 endef
 
   DEPENDS:=+glib1 +libX11
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
-               if [ -x $(CONFIGURE_CMD) ]; then \
-                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-                       $(CONFIGURE_VARS) \
-                       $(CONFIGURE_CMD) \
-                       $(CONFIGURE_ARGS_XTRA) \
-                       $(CONFIGURE_ARGS) ;\
-               fi \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR)/ install DESTDIR=$(PKG_INSTALL_DIR)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
 define Build/InstallDev
        $(INSTALL_DIR) $(1)
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/