[PATCH] [dsl-qos-queue] Add libipq to DEPENDS, and reference shared library, since...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 4 Aug 2010 17:14:11 +0000 (17:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 4 Aug 2010 17:14:11 +0000 (17:14 +0000)
This fixes the build of this package and makes it work again.
Signed-off-by: Ithamar R. Adema <ithamar.adema@team-embedded.nl>
SVN-Revision: 22489

net/dsl-qos-queue/Makefile

index 99a2d3e98e5c8a4ed8de72440a6687ee9bc3b1b4..e3d0739813584ade442614a5b6d2280de3e67276 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
+  DEPENDS:=+iptables +kmod-ipt-queue +iptables-mod-ipopt +libipq @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27 @!LINUX_2_6_28
   TITLE:=ADSL/ATM Bandwith management
   URL:=http://www.sonicspike.net/software/
 endef
   TITLE:=ADSL/ATM Bandwith management
   URL:=http://www.sonicspike.net/software/
 endef
@@ -34,7 +34,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.a \
+               LIBIPQ=$(STAGING_DIR)/usr/lib/libipq.so \
                all \
        )
 endef
                all \
        )
 endef