[package] rebuild libgd configure script before compiling (#6241)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 30 Nov 2009 10:51:42 +0000 (10:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 30 Nov 2009 10:51:42 +0000 (10:51 +0000)
SVN-Revision: 18610

libs/gd/Makefile

index b9c5195cb7d76ba776c7a50d5e79550345298407..175a3c71b852ecb13adacf057c100a62d280171f 100644 (file)
@@ -40,13 +40,19 @@ CONFIGURE_ARGS += \
        --without-freetype \
        --with-jpeg=$(STAGING_DIR)/usr \
        --with-png=$(STAGING_DIR)/usr \
        --without-freetype \
        --with-jpeg=$(STAGING_DIR)/usr \
        --with-png=$(STAGING_DIR)/usr \
-       --without-xpm
+       --without-xpm \
+       --without-iconv
 
 CONFIGURE_VARS += \
        LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
 
 TARGET_CFLAGS += $(FPIC)
 
 
 CONFIGURE_VARS += \
        LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config"
 
 TARGET_CFLAGS += $(FPIC)
 
+define Build/Configure
+       ( cd $(PKG_BUILD_DIR); aclocal; libtoolize; autoreconf; );
+       $(call Build/Configure/Default)
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \