add a new package for intltool (host only) to get rid of another prereq check
authorFelix Fietkau <nbd@openwrt.org>
Wed, 2 Sep 2009 22:39:37 +0000 (22:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 2 Sep 2009 22:39:37 +0000 (22:39 +0000)
SVN-Revision: 17487

Xorg/lib/vte/Makefile
Xorg/lib/wnck/Makefile
libs/avahi/Makefile
libs/gconf2/Makefile
libs/intltool/Makefile [new file with mode: 0644]

index 7d6d4803938aba0fc49c60891e24f3cd6d23ce49..2e5f6dff793cbda3eda02f90c98a1795ffea5fcb 100644 (file)
@@ -16,6 +16,8 @@ PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/0.17
 PKG_MD5SUM:=ec6cb2668db7146eae7cfc48af98f3ed
 PKG_FIXUP:=libtool
 
+PKG_BUILD_DEPENDS:=intltool/host
+
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
 
@@ -103,10 +105,6 @@ define Package/python-vte/install
                $(1)$(PYTHON_PKG_DIR)/gtk-2.0
 endef
 
-$(eval $(call RequireCommand,intltool-update, \
-    $(PKG_NAME) requires intltool >= 0.35.0 \
-))
-
 $(eval $(call BuildPackage,vte))
 $(eval $(call BuildPackage,python-vte))
 
index 3b5fac4d8f51d1d75a7e8e81e731b18ac2a56c24..4595cf2f939941ca413f8139bb02c78d898b5dc2 100644 (file)
@@ -17,6 +17,8 @@ PKG_MD5SUM:=015b5d2e65d15448fa143513fce03541
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
+PKG_BUILD_DEPENDS:=intltool/host
+
 include $(INCLUDE_DIR)/package.mk
 
 TARGET_CFLAGS+= \
index 3e8301c78b2f325ff39ebba47cfc1eaf39464a8f..6122e646c99e1cfe98e6645c887d08d79a900439 100644 (file)
@@ -15,7 +15,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://avahi.org/download/
 PKG_MD5SUM:=a83155a6e29e3988f07e5eea3287b21e
 
-PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm
+PKG_BUILD_DEPENDS:=libexpat libdaemon libgdbm intltool/host
 
 PKG_FIXUP = libtool
 
@@ -197,10 +197,6 @@ define Package/avahi-dnsconfd/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/avahi-dnsconfd $(1)/usr/sbin/
 endef
 
-$(eval $(call RequireCommand,intltool-update, \
-       $(PKG_NAME) requires intltool >= 0.35.0 \
-))
-
 $(eval $(call BuildPackage,libavahi))
 $(eval $(call BuildPackage,avahi-autoipd))
 $(eval $(call BuildPackage,avahi-daemon))
index e3f5eb82037bbe17f18dcc6e8ad31be13a71513b..3fa87ebae73f1222f555fd96701456c6dedfe1a3 100644 (file)
@@ -9,7 +9,7 @@ PKG_SOURCE:=GConf-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/GConf/2.24
 PKG_FIXUP:=libtool
 
-PKG_BUILD_DEPENDS:=orbit2/host
+PKG_BUILD_DEPENDS:=orbit2/host intltool/host
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -107,8 +107,5 @@ define Package/gconf2/install
                $(1)/usr/bin/
 endef
 
-$(eval $(call RequireCommand,intltool-update, \
-       $(PKG_NAME) requires intltool >= 0.35.0 \
-))
 $(eval $(call BuildPackage,libgconf2))
 $(eval $(call BuildPackage,gconf2))
diff --git a/libs/intltool/Makefile b/libs/intltool/Makefile
new file mode 100644 (file)
index 0000000..1b1d704
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=intltool
+PKG_LIBVER:=0.40
+PKG_VERSION:=$(PKG_LIBVER).6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/intltool/$(PKG_LIBVER)
+PKG_MD5SUM:=69bc0353323112f42ad4f9cf351bc3e5
+
+PKG_HOST_ONLY:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/intltool
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=set of tools to centralize translation using GNU gettext
+  URL:=http://www.freedesktop.org/wiki/Software/intltool
+  BUILDONLY:=1
+endef
+
+define Package/intltool/description
+  intltool is a set of tools to centralize translation of many different
+  file formats using GNU gettext-compatible PO files. 
+endef
+
+$(eval $(call BuildPackage,intltool))
+$(eval $(call HostBuild))